VirtualBox

Ticket #6786 (reopened defect)

Opened 4 years ago

Last modified 5 weeks ago

Unable to drag and drop on host machine when launch virtualbox

Reported by: user2 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

sometimes Unable to drag and drop on host machine when launch virtualbox

host:xp guest:xp

Change History

comment:1 Changed 4 years ago by locutus

Same issue on Windows 7 x64 (guest also xp!) (version 3.2.5). affects all drag'n'drop-functions, including moving of file-placeholders (aka icons), tabs in firefox et c. also, changing row-size or moving a row in task-manager, win-explorer, et c. does not work either. but dragging windows works.

when trying to move an item on the desktop, it sometimes looks like the item gets "gripped" shortly to then be dismissed again from the "mouseforce"!

issue persists after quiting VB (and all apending tasks)but goes away after some time.

the issue itself occurs randomly, so steps to reproduce are difficult to figure.

comment:2 Changed 2 years ago by arencambre

Also experiencing this with Windows 7 x64 host. Per  https://forums.virtualbox.org/viewtopic.php?f=8&t=12074, this may be a longstanding problem.

comment:3 Changed 2 years ago by arencambre

...and running VirtualBox 4.1.6.

comment:4 Changed 2 years ago by romanha

...and running the latest 4.1.10 version as well !

comment:5 Changed 2 years ago by frank

  • Description modified (diff)

Cannot reproduce this on a Windows 7 host. What exactly did you try on the host? Be aware that there were some problems with VirtualBox and copy'n'paste which were finally fixed in VBox 4.1.0.

comment:6 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

comment:7 Changed 19 months ago by Aren Cambre

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Woah, little doggies! This issue is still a problem with VBox 4.1.x. I am running Windows 7 x64 as the host OS and Ubuntu 12.04 as the guest OS running Guest Extensions.

Still have routine problems with drag and drop on the host OS. Pressing ESC sometimes fixes it, as if the ESC key is getting stuck?

I don't have a reliable way to reproduce yet. This has been a problem for at least a couple of years.

comment:8 Changed 19 months ago by frank

And you are 100% sure that you are using VirtualBox 4.1.22?

comment:9 Changed 19 months ago by Aren Cambre

Absolutely. I just checked the version number.

comment:10 Changed 19 months ago by frank

Is it sufficient to disturb the host clipboard if you just launch the VM selector without starting any VM? If you need to start a VM, is the host clipboard still disturbed by VirtualBox if you disable the clipboard for the guest?

comment:11 Changed 19 months ago by Aren Cambre

I don't think the clipboard is being disturbed. I realize "drag and drop" has specific meaning to the clipboard, but this is really about the UI interactions that allow the drag and drop to happen.

For example, when DnD is messed up on the host OS, if you hold down the left mouse button on a desktop icon and try to move it, it doesn't move.

comment:12 Changed 14 months ago by geebee75

Still doesn't work on v4.2.8 (Feb 2013 release). Host=OSX 10.8 Guest=Win7 Pro x64.

Dragging a file from host desktop to guest desktop, mouse pointer changes to a "no" (Slash-O) symbol when over the Win7 desktop.

comment:13 Changed 5 weeks ago by Jonathanwint

Yep I have the same Error I using fully installed 4.3.8 r92456 with extensions on a Fresh installed windows 7 host and using a XP pro updated install. "drag and drop" doesn't work in anyway disabled all my security.. I used VirtaulBox for many years and this first time had this issue.

comment:14 Changed 5 weeks ago by frank

Jonathanwint, please could you stop this spamming?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use