VirtualBox

Ticket #6725 (closed defect: obsolete)

Opened 5 years ago

Last modified 9 days ago

USB won't attach in 2009.06 - size 0 bytes, no serial number, cannot open device

Reported by: jpl Owned by:
Priority: major Component: USB
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description (last modified by frank) (diff)

I'm trying without success to attach USB mass storage devices (a flash disk or an external hard disk) into an OpenSolaris 2009.06 guest running under a Debian host. This is the same host on which I was able to get USB 1.x (but not EHCI) working within a Linux guest as described in ticket #6724. Therefore, I am now experimenting both with EHCI and without EHCI enabled.

Without EHCI enabled

  • dmesg, iostat, fdisk output after re-attaching the device appear as shown on the attached screenshot (1)
  • the USB activity icon keeps blinking for 30 seconds or so, then stops

With EHCI enabled

  • booting is noticeably slowed down
  • dmesg, iostat, fdisk output after re-attaching the device appear as shown on the attached screenshot (2)
  • the USB activity icon only blinks shortly
  • after issuing the fdisk command it hangs for a minute or so, before getting back with "Cannot open device"

Attachments

VBox.log Download (58.3 KB) - added by jpl 5 years ago.
VBox.log (with EHCI enabled)
scrshot-ohci.png Download (204.7 KB) - added by jpl 5 years ago.
Screenshot wihout EHCI
scrshot-ehci.png Download (201.9 KB) - added by jpl 5 years ago.
Screenshot with EHCI

Change History

Changed 5 years ago by jpl

VBox.log (with EHCI enabled)

Changed 5 years ago by jpl

Screenshot wihout EHCI

Changed 5 years ago by jpl

Screenshot with EHCI

comment:1 Changed 9 days ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use