VirtualBox

Ticket #6724 (closed defect: obsolete)

Opened 6 years ago

Last modified 6 weeks ago

USB devices in guest don't attach when EHCI enabled

Reported by: jpl Owned by:
Priority: major Component: USB
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by aeichner) (diff)

I'm using Debian as host, experimenting with Debian and Finnix (a Debian-based LiveCD) as guests. I'm unable to attach an external storage USB 2.0 device in guest if the EHCI controller is enabled (I tried with a flash disk and external HD). It works ok with the EHCI controller disabled. I'm observing dmesg in guest, with the following symptoms:

  1. The device appears to be recognized (e.g. id, serial number appear correctly)
  2. After that I get a series of "reset high speed USB device using ehci_hcd" messages with a few seconds delay between them.
  3. Finally a message "Device offlined - not ready after error recovery" appears.

When I detach and re-attach the device, the sequence of messages is repeated.

Attachments

VBox.log Download (72.1 KB) - added by jpl 6 years ago.
VBox.log
scrshot.png Download (25.4 KB) - added by jpl 6 years ago.
Screenshot of dmesg in guest

Change History

Changed 6 years ago by jpl

VBox.log

Changed 6 years ago by jpl

Screenshot of dmesg in guest

comment:1 Changed 6 years ago by jpl

See also ticket #6725 for related (?) problems with USB and OpenSolaris running on the same host.

comment:2 Changed 6 weeks ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use