VirtualBox

Ticket #6597 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Win98 installlation crashes VirtualBox

Reported by: alehandro Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox got crashed during Windows98 installation (yes, VT-X was ON) logs attached

Attachments

VBox.log Download (35.8 KB) - added by alehandro 4 years ago.
VBox.log.1 Download (54.7 KB) - added by alehandro 4 years ago.
dumps_and_logs.zip Download (47.7 KB) - added by mhanor 4 years ago.
3.1.6 and 3.2.0 VB crash dumps and logs (host xp sp3)
VBox-log Download (250.0 KB) - added by jtr1888 4 years ago.
Crash during install (host win7 ultimate x64 - guest win 98 SE)
VBox_alreadyinstalled_crash_vtxoff.log Download (31.1 KB) - added by mhanor 3 years ago.
vb3_2_10.dmp Download (43.5 KB) - added by mhanor 3 years ago.
VBox_win98setup_vtxon.log Download (50.3 KB) - added by mhanor 3 years ago.

Change History

Changed 4 years ago by alehandro

Changed 4 years ago by alehandro

comment:1 Changed 4 years ago by alehandro

I believe that VBox.log.1 is a previous log file when Windows98 installer asked to reboot and all was fine VBox.log - latest log when after reboot VirtualBox crashed

comment:2 Changed 4 years ago by alehandro

and here is the info from crash (under Win7 Ultimate)

Problem signature:

Problem Event Name: APPCRASH Application Name: VirtualBox.exe Application Version: 3.1.6.0 Application Timestamp: 4babb120 Fault Module Name: VBoxDD.DLL Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4babb144 Exception Code: c0000094 Exception Offset: 00000000000564a6 OS Version: 6.1.7600.2.0.0.256.1 Locale ID: 1033 Additional Information 1: 0309 Additional Information 2: 0309522899dc5f08e44bd904dd003cd7 Additional Information 3: ab8c Additional Information 4: ab8c7bfceb4bfe9803ddda8d3d4b385c

Read our privacy statement online:

 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:

C:\Windows\system32\en-US\erofflps.txt


Problem signature:

Problem Event Name: APPCRASH Application Name: VirtualBox.exe Application Version: 3.1.6.0 Application Timestamp: 4babb120 Fault Module Name: VBoxDD.DLL Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4babb144 Exception Code: c0000094 Exception Offset: 00000000000564a6 OS Version: 6.1.7600.2.0.0.256.1 Locale ID: 1033 Additional Information 1: 0309 Additional Information 2: 0309522899dc5f08e44bd904dd003cd7 Additional Information 3: ab8c Additional Information 4: ab8c7bfceb4bfe9803ddda8d3d4b385c

Read our privacy statement online:

 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:

C:\Windows\system32\en-US\erofflps.txt

comment:3 Changed 4 years ago by mhanor

I can always reproduce this crash with VB 3.1.6 and 3.2.0 beta2 (host XP SP3), with VT-x,NX,LAN,audio all disabled. USB also disabled in VM settings (USB support is not even installed, I don't need it), 64 or 265MB RAM, 4 or 32MB VRAM
It always crashes with exception c0000094 (divide by zero), @VBoxDD!VBoxUsbRegister+offset, at the first run of the OS, after the Win98 setup restars from hw detection.

Changed 4 years ago by mhanor

3.1.6 and 3.2.0 VB crash dumps and logs (host xp sp3)

comment:4 Changed 4 years ago by mhanor

Sorry, it wasn't the first run of the OS, it's the last run of the setup (where you set up the time zone)... By messing around with the registers of several div instructions, I managed to get the setup to continue (this time with VT-x enabled)... Of course, it does that every time it boots, unless you disable some things

comment:5 Changed 4 years ago by Technologov

Duplicate of #2865

-Technologov

comment:6 Changed 4 years ago by mhanor

this is not a duplicate... it triggers c0000094 (divide by zero), it doesn't matter if VT-x is enabled or disabled

Changed 4 years ago by jtr1888

Crash during install (host win7 ultimate x64 - guest win 98 SE)

comment:7 Changed 4 years ago by frank

  • Component changed from other to VMM

jtr18888, your crash might be fixed by the upcoming release 3.2.10.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.10.

comment:9 Changed 3 years ago by mhanor

  • Status changed from closed to reopened
  • Resolution fixed deleted

if the OS is already installed, VB 3.2.10 crashes in the same manner (division by zero inside VBoxDD), while the guest OS starts, with or without VT-x

with VT-x enabled, the Win98 setup fails shortly after starting the setup GUI for the first time, with the message "Standard mode: fault outside of MS-DOS extender"

comment:10 Changed 3 years ago by frank

Please attach a VBox.log file.

Changed 3 years ago by mhanor

Changed 3 years ago by mhanor

Changed 3 years ago by mhanor

comment:11 Changed 3 years ago by mhanor

I found out where it crashes with divide by zero (VT-x disabled),
\vbox\src\VBox\Devices\Storage\DevATA.cpp, line 1425, CHS "else" branch

cyl = iLBA / (s->PCHSGeometry.cHeads * s->PCHSGeometry.cSectors);

SVN 35302, 32 bit, non-debug build

comment:12 Changed 3 years ago by mhanor

I forgot the stack backtrace

VBoxDD!ataSetSector+0xae  vbox\src\vbox\devices\storage\devata.cpp @ 1425 
VBoxDD!ataReadSectorsSS+0x49  vbox\src\vbox\devices\storage\devata.cpp @ 1583 
VBoxDD!ataAsyncIOLoop+0x307  vbox\src\vbox\devices\storage\devata.cpp @ 4751 
VBoxRT!rtThreadMain+0x33  vbox\src\vbox\runtime\common\misc\thread.cpp @ 680 
VBoxRT!rtThreadNativeMain+0x68  vbox\src\vbox\runtime\r3\win\thread-win.cpp @ 109 
MSVCR100!_callthreadstartex+0x1b  dd\vctools\crt_bld\self_x86\crt\src\threadex.c @ 314 
MSVCR100!_threadstartex+0x64  dd\vctools\crt_bld\self_x86\crt\src\threadex.c @ 292 
kernel32!BaseThreadStart+0x37

comment:13 Changed 3 years ago by mhanor

The ATADevState structure passed to the ataSetSector function, indicates that it crashes when the function is working with the virtual "VBOX CD-ROM", indicated by szModelNumber and szInquiryProductId. The PCHSGeometry (part of ATADevState) structure's members are all set to zero.

comment:14 Changed 3 years ago by mhanor

After removing the virtual CD-ROM from VM settings, the Win98 setup is able to continue without crashing the VM.

comment:15 Changed 3 years ago by frank

Thanks for the additional information, we will investigate!

comment:16 Changed 3 years ago by frank

  • Component changed from VMM to virtual disk

comment:17 Changed 3 years ago by klaus

I'm wondering what makes Win98 think a CD-ROM will support hard disk read commands. Either VirtualBox reports something incorrectly (unlikely, as I haven't heard of such a problem in years), or Win98 is buggy and issues such commands to the wrong drive.

The command parsing in VirtualBox is a bit too simple, it prevents most hard disk commands but not the read/write ones.

As you built VirtualBox yourself you could try replacing "if (!s->pDrvBlock)" with "if (!s->pDrvBlock || s->fATAPI)" in line 3655 in src/VBox/Devices/Storage/DevATA.cpp. If this works around the problem let us know. There are more places to fix, but the information alone would be rather interesting and you have the testcase at hand.

comment:18 Changed 3 years ago by mhanor

With that modification, it doesn't crash. The VM is able to start and finish the Win98 installation process, without any other problems.

comment:19 Changed 3 years ago by mhanor

Btw, it always crashed at the same point, during Win98 setup hardware detection. Maybe it's probing the optical device in an unusual manner.

comment:20 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

The crash should be fixed in VBox 4.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use