VirtualBox

Ticket #6552 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Clipboard use locks up VirtualBox in some circumstances (reproduceable)

Reported by: danf84 Owned by:
Priority: trivial Component: clipboard
Version: VirtualBox 3.1.6 Keywords: paste freeze save dialog
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox process freezes and renders the clipboard operations on the system unusable upon pasting data that was previously copied from inside VirtualBox process. You may find there's something else that's going on, but the exact steps to reproduce the lockup are as follows:

Start VirtualBox GUI. Start "Create New Virtual Machine Wizard" Hit Next, for VM name type "VIRBS_SERVER_MY" Select the text ("VIRBS_SERVER_MY") and hit CTRL+C (I do this as I usually paste the same name for VDI). Click Next, leave memory at default. Click Next, Create New hard disk should be as default. In the "Create New Virtual Disk Wizard" click Next, leave default "Dynamically expanding storage". Click Next, for Location of the VDI, click the browse icon/button to the right of the text box. Press CTRL+V - it should lock up.

This doesn't happen if I copy the same text from, say, Notepad.

After writing this, I realised the you can go straight to creating a new VDI.

Change History

comment:1 Changed 4 years ago by danf84

Pasting the copied text in Notepad prior to openning the File Save Dialog prevents the lockup. Pasting the copied text in Notepad after openning the File Save Dialog locks up Notepad until the Save Dialog is closed.

comment:2 Changed 4 years ago by danf84

Copy/pasting stuff while editing Host-only networks (e.g. copy/pasting IP addresses within the DHCP server window) also causes a freeze.

comment:3 Changed 4 years ago by danf84

Fixed in 3.2.0

comment:4 Changed 4 years ago by Technologov

danf84: no man, it is not fixed. Just this bug is not 100% reproducible.

Duplicate of #4491.

-Technologov

comment:5 Changed 3 years ago by Pok

This is still present as of version 4.0.4. If I open the configuration screen of a VM and select the text from the General -> Description field and than I try to paste the content of the clipboard into the same field but for a different VM the UI freezes. The same happens for any field in the VM creation wizard. In fact if I try to paste the same info (that has just been copies to the clipboard in a Notepad opened after the copy operation, nothing happens: the copies text is not pasted into Notepad upon issuing the paste command. In fact if - after all this - one tries to open the context menu of the General -> Description field (so not even pasting) the VirtualBox UI freezes again! In other word it looks like after copying a text from the VirtualBox UI, clipboard operations within that same UI cause a lock-up. None of the above happens if the copy is done in another app, like Notepad.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Definitely a duplicate of #4491 and fixed in the next major release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use