VirtualBox

Ticket #645 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

When doing a snapshot, network does not work any more with Linux guest. => Fixed in 1.5.4

Reported by: Vincent Bernat Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Using VirtualBox 1.5.0 OSE (1.5.0-dfsg-1 from Debian).

Here are the steps:

  • install a Debian Etch as guest system
  • after installation, check that network is working (ping another machine)
  • take a snapshot
  • ping again the same machine: does not work any more.

Rebooting the guest does not solve the problem. modprobe -r pcnet32 ; modprobe pcnet32 does not solve the problem. Halting the guest and starting it again solves the problem.

I use a bridged tun interface.

br0		8000.000cf1a5600d	no		eth0
							tun-test

If I use tcpdump on tun-test, I see DHCP request from guest and answers from DHCP server. I suppose the problem is then receiving on guest. Same applies for ARP. Guest kernel is 2.6.18-5 from Debian. I suppose this is not a kernel problem since rebooting does not solve the problem.

Change History

comment:1 Changed 7 years ago by Vincent Bernat

Another way to solve the problem is shutting down the machine and asking it to restore the previous state. When starting the machine again, the network is here again.

comment:2 Changed 7 years ago by deepstar

I have the same problem and the same setup. I'm using Ubuntu Feisty as the host (kernel 2.6.20-16-generic), virtualbox 1.5.0

I've tried a Debian sarge as guest OS, aswell as Windows XP.

I've also tried reverting to virtualbox 1.4.0 and get the same problem. Virtualbox 1.3.8 didn't want to run on my Ubuntu, so I couldn't test there

comment:3 Changed 6 years ago by rsgratien

I have the same problem using NAT networking mode with Etch and Knoppix 5.1.1 as guest OS (host OS is Etch).

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from When doing a snapshot, network does not work any more with Linux guest. to When doing a snapshot, network does not work any more with Linux guest. => Fixed in 1.5.4

Duplicate of #837, fixed in 1.5.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use