VirtualBox

Ticket #644 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VirtualBox randomly causes mouse to jump to top left corner permanently in Ubuntu Gutsy host, XP VM

Reported by: neilcawse Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Also applies to 1.4.0. While working in an XP virtual machine, occasionally the mouse "jumps" position by a couple of inches. Every now and then, the mouse seems to jump into a state that it cannot recover. It moves to the top left corner of the screen and is trapped there. The mouse button still works but you cannot move it off that position. This occurs both for the built in trackpad and any external mouse. Restarting X fixes the problem. I suspect there may be an issue with Gutsy or my drivers causing the jump but VirtualBox should not trap the mouse that way. I can provide further data if needs be xorg.conf or anything.

Attachments

VBox.log.VTon Download (34.5 KB) - added by kiko 6 years ago.
VT-x enabled, from start up virtual machine till mouse locks up.

Change History

comment:1 Changed 6 years ago by tlex

I experience the same problem on Gentoo, with app-emulation/virtualbox-bin-1.5.2. In my X server logfile I can see the message 'Synaptics DeviceOff called' two times right after the mouse freezes in the top-left corner of the screen. The same, if I restart X, everything works fine for a while. I can still use the mouse pointer with the help of the numeric keypad (option enabled in the KDE Config Center). I have experienced this behavior more while being in "Seamless Integration", "Full Screen" or "Maximize Window" than in a regular window smaller than the desktop.

The behavior is for the Synaptics Touchpad and extends to the USB mouse plugged in (of course, when I have the USB mouse plugged in).

My setup is:

tlex@miniaturix ~ $ gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.1.2 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --enable-libmudflap --disable-libssp --disable-libgcj --with-arch=i686 --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 4.1.2 (Gentoo 4.1.2 p1.0.1)

---

tlex@miniaturix ~ $ uname -a
Linux miniaturix 2.6.22-gentoo-r8-miniaturix #10 SMP PREEMPT Mon Oct 29 00:30:48 EAT 2007 i686 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux

The relevant part of xorg.conf is:

   Section "ServerLayout"
           Identifier     "X.org Configured"
           Screen      0  "Screen0" 0 0
           InputDevice    "Mouse0" "CorePointer"
           InputDevice    "TouchPad" "CorePointer"
           InputDevice     "TouchPad"      "SendCoreEvents"
           InputDevice    "Keyboard0" "CoreKeyboard"
   EndSection
   Section "InputDevice"
           Identifier  "Mouse0"
           Driver      "mouse"
           Option      "Protocol" "auto"
           Option      "Device" "/dev/input/mice"
           Option      "ZAxisMapping" "4 5 6 7"
   EndSection
   Section "InputDevice"
      Driver "synaptics"
      Identifier "TouchPad"
      Option "Protocol" "auto-dev"
      Option "SHMConfig" "on"
      Option "LeftEdge" "1900"
      Option "RightEdge" "5400"
      Option "TopEdge" "1400"
      Option "BottomEdge" "4500"
      Option "FingerLow" "25"
      Option "FingerHigh" "30"
      Option "MaxTapTime" "180"
      Option "MaxTapMove" "220"
      Option "VertScrollDelta" "90"
      Option "MinSpeed" "0.02"
      Option "MaxSpeed" "0.18"
      Option "AccelFactor" "0.0010"
   EndSection

This problem doesn't appear with other VM software, or other software whatsoever, except while using these setting in xorg.conf:

   Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "TouchPad" "CorePointer"
        InputDevice     "TouchPad"      "AlwaysCore"
        InputDevice    "Keyboard0" "CoreKeyboard"
   EndSection

or when I omit:

   Option "SHMConfig" "on"

comment:2 Changed 6 years ago by khelidan

Same problem for me,on gentoo and virtualbox 1.5.2

comment:3 Changed 6 years ago by arak

I meet the issue too, on Archlinux , kernel 2.6.22.6, xorg 1.4.0.90, virtualbox 1.5.2

comment:4 Changed 6 years ago by michael

Did I understand correctly that the mouse gets stuck in the top left-hand corner of the host display? And that it stays there even after exiting VirtualBox? Does this also occur with Guest Additions installed?

comment:5 Changed 6 years ago by neilcawse

Thats correct. It failed in the host. Guest additions were installed. Only thing that corrected problem was restarting X. Never happened without VirtualBox running.

comment:6 in reply to: ↑ description Changed 6 years ago by avinas

I meet the issue too, on Ubuntu , kernel 2.6.24.2, (xorg-server 2:1.4.1~git20071212-1ubuntu2), virtualbox 1.5.4

comment:7 Changed 6 years ago by frank

Please could you check if this problem appears when you disable virtualization hardware support (VT-x/SVM) in the VM settings as well?

comment:8 Changed 6 years ago by neilcawse

Im not having any problems with my current config - old config is gone - so I cant recreate. I remember clearly trying it both ways and it failed..

comment:9 follow-up: ↓ 10 Changed 6 years ago by kiko

I have exact same problem on Kernel 2.6.23-gentoo-r3, VirtualBox 1.5.4 with guest additions installed.
It seems the problem occurs when VT-x is enabled. Though,I have only spent short amount of time to test this. Please let me know if there is any further information or tests that may help to track down this problem.

comment:10 in reply to: ↑ 9 Changed 6 years ago by kiko

Correction to my previous post: VirtualBox version is 1.5.2.
I have not met this issue with OSE. However, I can't say anything for sure since it occurs randomly (but quite often).

comment:11 Changed 6 years ago by frank

Everyone who is posting additional comments here: Please attach your VBox.log file and please check if this happens with disabled VT-x / SVM!

Changed 6 years ago by kiko

VT-x enabled, from start up virtual machine till mouse locks up.

comment:12 Changed 6 years ago by kiko

Replying to frank:

Here's my result..
binary edition 1.5.4
1, VT-x enabled => Happened (See attached 'VBox.log.VTon')
2, VT-x enabled, nohz=off => Happened
3, VT-x disabled => Not happned

open source edition 1.5.4
1, VT-x enabled => Not happned.

Machine: Thinkpad X61 (C2D T7500)
Kernel: 2.6.23-gentoo-r3 (NO_HZ [y])

Note that I only tested twice in each, about an hour total.

comment:13 Changed 6 years ago by Matze

Fixed it für my gentoo box.

You have to disable virtualiziaion in kernel, and if possible activate virtualiziaion in bios.

MfG Matze

comment:14 Changed 6 years ago by kalin

Well, I started having this problem some time ago, but was too busy to debug it. Now that I have found this bug, and the problem starting to get more reproducible (several times a day) I did some tests. I even happens when VirtualBox is running in the background and I am moving some windows around or scrolling.

As a start I switched back to 1.5.6_OSE, and installed latest guest addons. However the problem persists.

My relevant kernel config:

$ uname -a Linux jr 2.6.24.0-K01_C2D_laptop #1 SMP Thu Jan 31 12:43:26 JST 2008 i686 Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz GenuineIntel GNU/Linux

$ zcat /proc/config.gz| egrep "VIRTUALIZATION|NO_HZ" CONFIG_NO_HZ=y CONFIG_VIRTUALIZATION=y

VT-x is enabled in BIOS.

So, I can say as long as VT-x is enabled for the virtual machine and is compiled in the kerel the bug is present in both OSE and closed source of 1.5.6.

I turned off the VT-x, will see how it behaves now.

comment:15 follow-up: ↓ 17 Changed 6 years ago by abouillet

The same problem occurs for me on my Lenovo R60 (VT-X enabled in BIOS).

I'm running Virtualbox 1.5.6 binary edition on an actual ArchLinux installation. My relevant kernel config:

$ uname -a

Linux myhost 2.6.24-ARCH #1 SMP PREEMPT Sun Mar 30 11:40:06 CEST 2008 i686 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz GenuineIntel GNU/Linux

$ zcat /proc/config.gz| egrep "VIRTUALIZATION|NO_HZ"

CONFIG_NO_HZ=y CONFIG_VIRTUALIZATION=y

I've tried to disable NO_HZ via the kernel parameter nohz=off (also in combination highres=off), but that didn't work.

In the config.gz from ArchLinux there are also the following options set:

CONFIG_PARAVIRT=y CONFIG_PARAVIRT_GUEST=y

Might that cause the problems?

comment:16 Changed 6 years ago by kalin

Well, after about two weeks of testing I can conclude that turning off VT-x for the guest solves the problem. I am running 1.5.6_OSE at the moment, but I guess non-OSE will behave the same.

Apart from that I seem to be experiencing more hangs/crashes in certain apps (e.g. Lotus Notes) inside the WinXP guest, but it is very hard to measure or reproduce.

comment:17 in reply to: ↑ 15 Changed 6 years ago by abouillet

Replying to abouillet:

Tested it this evening with VT-X disabled in Virtualbox and the problem appeared again!

So in summary my tests:

binary edition 1.5.6

1, VT-X enabled in Virtualbox: Happened

  1. VT-X enabled in Virtualbox: nohz=off: Happend
  2. VT-X disabled in Virtualbox: Happend[[BR]]

So I had no success so far to run Virtualbox stable on my computer!

comment:18 Changed 6 years ago by frank

Please can you try 1.6.0?

comment:19 Changed 6 years ago by seerhut

I faced the same problem in 1.5.7/6/0 , whatever the VT-X is on or off. After I upgrade it to 1.6, the problem disappeared, at least until now.

comment:20 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you for this report. I will close this defect as 'solved', reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use