VirtualBox

Ticket #6401 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

FIN_WAIT2 Error in Host NAT Service

Reported by: semidark Owned by:
Priority: minor Component: network/NAT
Version: VirtualBox 3.1.4 Keywords: TIME_WAIT2 TCP Connection
Cc: Guest type: Linux
Host type: Windows

Description

Since Version 3.1.2 I have a problem with the NAT Network service on my Windows XP Host and my Ubuntu Karmic Koala Linux Guest.

TCP IP Connections don't get closed correctly anymore and if many connections are kept open in FIN_WAIT2 status new connections even get interrupted. Typically this happens when I open a lot of websites at once in my Guest Webbrowser. Suddenly the Browser can't open Websites anymore.

Running

# netstat -tuanp |grep FIN_WAIT2

on the guest gives awful lot of not correctly closed TCP Connections that only disappear when the Linux kernel kills them due to an timeout of 60 seconds.

It seams to be a problem on the Host Side since I tried multiple Linux Kernel releases that Karmic offered.

My host system is a fully patched Windows XP Professional SP3.

With VirtualBox 3.1.0 the problem doesn't occur. Even with the GuestAdditions 3.1.4 installed everything works just like a charm.

So updating to more current versions of virtualbox is currently impossible for me.

Thanks in advance

with kind regards Semidark

Change History

comment:1 Changed 4 years ago by Hachiman

Could you please attach logs?

comment:2 follow-ups: ↓ 3 ↓ 4 Changed 4 years ago by semidark

Hello Hachiman,

what logs do you need. I took a quick look into the "Help/Guide" Section of this Trac installation but could not find any information on that topic.

Sorry for my ignorance, but I've never posted nor analysed a bug for VirtualBox

Greetz Semidark

comment:3 in reply to: ↑ 2 Changed 4 years ago by Hachiman

Replying to semidark:

Hello Hachiman,

what logs do you need. I took a quick look into the "Help/Guide" Section of this Trac installation but could not find any information on that topic.

You can find more information here  http://www.virtualbox.org/manual/ch11.html#id2552161

comment:4 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 4 years ago by Hachiman

Replying to semidark: Your description looks like the problem #6237. Could you please check the build  http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-22-09-52-22-win-3.1-rel-3.1.5-r59094-MultiArch.exe fixes issue for you? If no probably we've met with new issue.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 4 years ago by semidark

Replying to Hachiman:

Your description looks like the problem #6237. Could you please check the build  http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-22-09-52-22-win-3.1-rel-3.1.5-r59094-MultiArch.exe fixes issue for you? If no probably we've met with new issue.

Hello Hachiman,

the testcase binary you suggested seams to fix my NAT problem. Just installed it and did a quick check. Started the Firefox with 20 Tabs and kept an eye on the network connections of my Guest using

watch "sudo netstat -tuanp |grep WAIT2"

All connections entering FIN_WAIT2 state get closed after a second or so. I will keep testing this pre-release version a bit, but until further notice I would say this is a duplicate of problem #6237.

Thanks for the very quick help.

Greetz Semidark

comment:6 in reply to: ↑ 5 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

Replying to semidark:

All connections entering FIN_WAIT2 state get closed after a second or so. I will keep testing this pre-release version a bit, but until further notice I would say this is a duplicate of problem #6237.

Thanks for the very quick help.

Thank you for feedback. I'll mark it as duplicate of #6237. Please feel free to reopen it in case you'll find any abnormals.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use