VirtualBox

Ticket #6237 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

svn cannot work properly after upgrading to 3.1.4 -> Fixed in SVN.

Reported by: wschee Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.1.4 Keywords: svn connection
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I upgraded VB 3.1.2 to 3.1.4. My host is windows 7 and guest is ubuntu 9.10. Even though I did not have any problems with other programs (web browsers, apt-get, etc) that access network, I have problem with svn/rapidsvn to work with the repositories.

For svn up, svn updates the files, then the prompt is not returned. Thus, the process hangs indefinitely. For svn co, after svn detects repository, svn hangs. Thus, no files cannot be commited.

This system worked perfectly until 3.1.4 upgrade.

I tested with windows 7 firewall turned off, but I got no luck.

Attachments

VBox.log Download (60.2 KB) - added by wschee 4 years ago.
vbox.log
usb_error_message.doc Download (54.5 KB) - added by wschee 4 years ago.
usb error message

Change History

Changed 4 years ago by wschee

vbox.log

comment:1 Changed 4 years ago by wschee

The repositories are my own repositories NOT virtual box repository.

comment:2 follow-up: ↓ 3 Changed 4 years ago by frank

Sounds like a network problem. The subversion client will hang if the server does not respond. Do other networking operations work from within the guest, for example web browsing, transferring files with ssh?

comment:3 in reply to: ↑ 2 Changed 4 years ago by wschee

Other network operations in the guest work perfect. Also, rapidsvn installed on host Windows 7 works perfect when the svn/rapidsvn in the guest hangs. As mentioned earlier, there was no problem with vbox 3.1.2.

Replying to frank:

Sounds like a network problem. The subversion client will hang if the server does not respond. Do other networking operations work from within the guest, for example web browsing, transferring files with ssh?

comment:4 follow-up: ↓ 7 Changed 4 years ago by wschee

I switched NAT to bridged connection. Now, svn/rapidsvn does not hang at all. It looks like NAT of virtualbox 3.1.4 has some problem. I wish I get some response regarding this from the Oracle staff.

comment:5 Changed 4 years ago by frank

You already got a response.

comment:6 Changed 4 years ago by frank

  • Component changed from network to network/NAT

comment:7 in reply to: ↑ 4 Changed 4 years ago by Hachiman

Replying to wschee:

I switched NAT to bridged connection. Now, svn/rapidsvn does not hang at all. It looks like NAT of virtualbox 3.1.4 has some problem.

Could you please collect pcap file from host (please see  http://wireshark.org) and guest side (please see  http://www.virtualbox.org/wiki/Network_tips). Please note: that enabling net tracing will disable port forwarding for you. The result pcap files you can send to me (vasily _dot_ levchenko _at_ Sun _dot_ COM).

comment:8 Changed 4 years ago by Hachiman

Could you please replace VBoxDD.dll with  http://www.virtualbox.org/download/testcase/VBoxDD.dll.6237, in case if it doesn't solve regression for you. Could you please together with pcap files collect log by starting VBox in the following way

> set VBOX_LOG=drv_nat.e.l2
> set VBOX_LOG_DEST=file=c:/nat.log
> VirtualBox -startvm your-vm-name

The behavior you're describing, reminds me some graceful connection termination problem we'd met previously, looking at the changes I found that potentially we might broke socket draining, marking socket as closed before drain.

comment:9 follow-up: ↓ 10 Changed 4 years ago by wschee

VBoxDD.dll.6237 solved the problem. Now everything works perfect on NAT mode. Thanks.

comment:10 in reply to: ↑ 9 Changed 4 years ago by Hachiman

Replying to wschee:

VBoxDD.dll.6237 solved the problem. Now everything works perfect on NAT mode. Thanks.

Thanks for feedback.

comment:11 follow-up: ↓ 14 Changed 4 years ago by Hachiman

Could you please verify the build

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-02-26-10-04-31-win-rel-3.1.51-r58091-MultiArch.exe ? This build of 3.1 containing patch fixes graceful connection termination problem for you, to be sure that everything is correct we need feedback from you.

comment:12 follow-up: ↓ 13 Changed 4 years ago by wschee

What do you mean by "verify the build"? Do you want me to download the file and install? If so, do I need to uninstall 3.1.4 before installation? Please be more specific on what you want me to do.

comment:13 in reply to: ↑ 12 Changed 4 years ago by Hachiman

Replying to wschee:

What do you mean by "verify the build"? Do you want me to download the file and install? If so, do I need to uninstall 3.1.4 before installation? Please be more specific on what you want me to do.

Sorry. You're right, build verification is installing release build and repeating the test. Special action like uninstallation isn't required.

comment:14 in reply to: ↑ 11 Changed 4 years ago by wschee

I installed the build and confirmed that the network works perfect with svn as well as other applications.

Thanks.

Replying to Hachiman:

Could you please verify the build

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-02-26-10-04-31-win-rel-3.1.51-r58091-MultiArch.exe ? This build of 3.1 containing patch fixes graceful connection termination problem for you, to be sure that everything is correct we need feedback from you.

comment:15 Changed 4 years ago by Hachiman

  • Summary changed from svn cannot work properly after upgrading to 3.1.4 to svn cannot work properly after upgrading to 3.1.4 -> Fixed in SVN.

Thanks for feedback.

Changed 4 years ago by wschee

usb error message

comment:16 Changed 4 years ago by wschee

With the new build, which resolved NAT problem, I cannot attach a USB devices. Please see the usb_error_message.doc in the attached.

comment:17 Changed 4 years ago by wschee

After restarting computer, the USB connection worked properly. Please ignore USB problem mentioned above.

comment:18 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use