VirtualBox

Ticket #6392 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Crash when allocating more than 1500MB of memory for guest

Reported by: s.illes79 Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I'm using Windows XP 32 bit host, I;ve added /3GB parameter to boot.ini. Virtual box can see 3567MB RAM of ram, but when I allocated 2000MB of memory with VBoxManage to my Ubuntu 32bit host than vbox keeps crashing frequently. I think it happens after the guest reached 1500MB of memory usage.

Steps to reproduces:

  1. added /3GB to boot.ini, reboot windows
  2. change memory for guest to 2000MB ( also tried 2500, 1950 )
  3. use a memtester in the guest to stress memory usage.

VBox works fine with 1500MB - which is the maximum can be set with the UI.

Thanks, Szabolcs

Attachments

Kubuntu.xml Download (6.3 KB) - added by s.illes79 4 years ago.
config file for guest
VBox.log Download (162.2 KB) - added by s.illes79 4 years ago.
Log file
Windows2000DC_Logs_VBox.log.txt Download (38.4 KB) - added by cduerr 4 years ago.

Change History

Changed 4 years ago by s.illes79

config file for guest

Changed 4 years ago by s.illes79

Log file

comment:1 in reply to: ↑ description Changed 4 years ago by cduerr

Replying to s.illes79:

I have the same problem, but using a 64bit Ubuntu Karmic Koala 9.10 server and Windows 2000 Server guest (32bit). Allocating 2048MB to guest, W2k crashes with Kmode exception not handled. With 1Gig, the guest starts up and works fine. Increasing memory allocation step by step I found that around 1,5gig the guest crashes. Decreasing again, I was able to reproduce that with less than 1.5gig the guest works fine. It didn't make any difference what other settings I chose, but disabling VT-x and thus working in software makes it slow but working.

I am using a Xeon L3360 in a Asus P5BP-E/4l with 8GB ECC DDR2 (Crucial), Virtualbox 3.1.6. The host itself is stable, Memtest86+ was fine.

Changed 4 years ago by cduerr

comment:2 Changed 4 years ago by frank

cduerr, you are using 2.6.34rc2 as host kernel which is not a stable kernel.

comment:3 Changed 4 years ago by frank

But I can confirm the problem with a more stable kernel. Disabling VT-x in the VM settings seems to workaround the problem.

comment:4 Changed 4 years ago by frank

cduerr, your problem is actually a duplicate of #5800 so lets continue the discussion there. This ticket is for 32-bit Windows hosts.

comment:5 Changed 4 years ago by s.illes79

I thought this was fixed as part of  http://www.virtualbox.org/ticket/5800, but this crash still happens with latest vbox(3.1.8).

comment:6 Changed 4 years ago by s.illes79

This is still happing in 3.2.0. :(

The maximum memory I managed to use without crashing is 1750 MB.

comment:7 Changed 4 years ago by s.illes79

and bug is still there with 3.2.2. :(

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

We are aware of this limit but the GUI will prevent you to assign more than 1500MB to a VM on a Windows 32-bit host -- and this is by intension. If you need more guest memory then switch to a 64-bit OS. I will close this ticket as duplicate of #6982 because I added a more detailed comment there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use