VirtualBox

Ticket #5800 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

Enabling VT-x/AMD-V results in guest W2K BSOD (regression) -> fixed in SVN

Reported by: Kurt_Aust Owned by:
Component: other Version: VirtualBox 3.1.6
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Host: Windows XP pro x64 (Intel Q9450 CPU)

Guest: Windows 2000

If hardware virtualization (VT-x/AMD-V)is enabled then Windows 2000 will BSOD when booting up with a "Page Fault in Nonpaged Area" message.

Note that W2K will in fact install through both textmode and GUI aspects of setup, failure only occurs once it is fully installed and tries to do a "normal" boot.

This problem is new with the 3.1.x series, 3.0.12 did not have this problem.

Attachments

VBox.log.1 Download (60.1 KB) - added by Kurt_Aust 11 years ago.

Change History

Changed 11 years ago by Kurt_Aust

comment:1 Changed 11 years ago by sandervl73

Which service pack for the win2k guest?

comment:2 Changed 11 years ago by Kurt_Aust

Fully updated install medium (SP4 + all updates, slipstreamed disk)

I can use the image if I turn off VT-x, turn it on and it go boom.

comment:3 Changed 10 years ago by Kurt_Aust

Problem still exists in 3.1.6

comment:4 Changed 10 years ago by frank

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.1.6

comment:5 Changed 10 years ago by frank

Problem confirmed. Another workaround would be to decrease the amount of guest RAM to 1024MB or less. We are investigating.

comment:6 Changed 10 years ago by sandervl73

  • Summary changed from Enabling VT-x/AMD-V results in guest W2K BSOD (regression) to Enabling VT-x/AMD-V results in guest W2K BSOD (regression) -> fixed in SVN

comment:7 Changed 10 years ago by sandervl73

Problem fixed and will be included in the next release.

comment:8 Changed 10 years ago by frank

This fix is not included in VBox 3.1.8 since the fix is not risk-free.

comment:9 Changed 10 years ago by Kurt_Aust

So hold off until 3.1.10 then?

comment:10 Changed 10 years ago by sandervl73

It will be in 3.2.

comment:11 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please verify that it works with 3.2.0.

comment:12 Changed 10 years ago by Kurt_Aust

It appears that the problem has been fixed, that is my W2K VM boots without problems.

comment:13 Changed 10 years ago by frank

Thank you for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use