VirtualBox

Opened 16 years ago

Closed 12 years ago

#639 closed defect (invalid)

OpenBSD guests... still not quite usable (VT-x/AMD-V works)

Reported by: François-Denis Gonthier Owned by:
Component: VMM Version: VirtualBox 2.2.2
Keywords: openbsd segfault Cc:
Guest type: BSD Host type: other

Description

I'm having annoying problems with an OpenBSD 4.1 guest on Ubuntu Feisty AMD64 host. The install went fine, unlike with previous version, but when using the installed quest, I'm having regular segmentation fault while using various programs inside that OS.

On a regular computer, I would immediately suspect an hardware problem.

The crashes are occasional and random, and I can't reproduce them with regularity. The only way I can get a reliable crash is by extracting OpenBSD sources from CVS.

I will attach the last few lines of a ktrace dump, done by calling cvs.

I'm not BSD expert. I've installed this guest to learn about OpenBSD, but I believe those crash make VBox unfit for that OS as a guest, and that is why I honnestly believe this is a major bug.

Attachments (5)

cvs.trace (1.6 KB ) - added by François-Denis Gonthier 16 years ago.
VirtualBox_vs_OpenBSD.png (28.2 KB ) - added by Rafał Zawadzki 16 years ago.
OpenBSD 4.1 problem
VirtualBox-OpenBSD-segfault-2007-11-16-13-12-50.log (32.3 KB ) - added by Technologov 16 years ago.
OpenBSD 4.2 segfault log, by Technologov.
VirtualBox-OpenBSD-segfault.PNG (30.1 KB ) - added by Technologov 16 years ago.
OpenBSD 4.2 segfault screenshot. by Technologov.
segfault-obsd-2010-07-13-06-58-53.log (50.9 KB ) - added by Joseph Hansen 14 years ago.

Download all attachments as: .zip

Change History (50)

by François-Denis Gonthier, 16 years ago

Attachment: cvs.trace added

comment:1 by Rafał Zawadzki, 16 years ago

I cannot even install OpenBDS - during installation i have many segfaults and disk is full issues. :(

by Rafał Zawadzki, 16 years ago

Attachment: VirtualBox_vs_OpenBSD.png added

OpenBSD 4.1 problem

comment:2 by Technologov, 16 years ago

Well, I can definitely say that I experience same problems. Except in my case, the segfault happened *during* the install.

Host: Core 2 Quad Q6600, 4GB RAM, Win XP SP2, VirtualBox 1.5.2.

Guest: OpenBSD 4.2

Settings: 128MB of RAM, 8 GB HDD, ACPI=on, IO APIC=off, VT=off.

-Technologov. 16.11.2007.

by Technologov, 16 years ago

OpenBSD 4.2 segfault log, by Technologov.

by Technologov, 16 years ago

OpenBSD 4.2 segfault screenshot. by Technologov.

comment:3 by Technologov, 16 years ago

Please increase bug priority to critical.

comment:4 by jensp, 16 years ago

I'd also like to see this bug fixed :)

comment:5 by Wijnand, 16 years ago

I really need this to be fixed urgently since we are planning a large scale setup with the software provided within the Qlayer virtualisation system which uses Virtualbox. It is not just a 4.1 issue, it happens with 4.2 and the latest -CURRENT versions too. Segfaults like this sound like bad or misbehaving hardware so something is fishy with the virtualisation provided by Virtualbox.

comment:6 by skibrianski, 16 years ago

Just want to add a "me too" - OpenBSD is broken for me, and it's a major drag.

comment:7 by skibrianski, 16 years ago

Just a note - enabling VT-x fixes this problem for me. If your CPU supports it, I highly recommend it. From the main screen, select your VM, click on General -> Advanced -> Extended features -> Enable VT-x/AMD-V (make sure it's an X, not gray or with horizontal stripes, which inherits from the global config). More on VT-x in virtualbox: http://www.virtualbox.org/wiki/VirtualBox_architecture

Good luck!

comment:8 by Wijnand, 16 years ago

It does seem to work a lot better with VT-x enabled, I was able to do a clean install without problems now and there were not segfaults during startup of the installed system.

comment:9 by Siddi, 16 years ago

This odd behavior seems sticky to VirtualBox a long time now.

My solve with non VT-x capable Machines to that is to disable raw0, i.e. create your OS vdi, get the ID of the VM with the command line 'VBoxManage list vms' and then start the VM from the command line instead from the GUI while disable raw0:

VBoxSDL -norawr0 -vm 6e96dbfa-45a8-42ec-9dab-6638031fd1da

You are still able to adjust VM settings like network or attached CDROM via GUI prior starting so you could mount a CDROM or ISO without bothering with VBoxManage. A GUI option to disable raw0 would be perfect solution to this issue for most users.

comment:10 by Frank Mehnert, 16 years ago

1.5.6 was only a maintenance release. Expect more help from the next major release 1.6.

comment:11 by Technologov, 16 years ago

update - there is some interesting info: http://forums.virtualbox.org/viewtopic.php?p=17930

-Technologov

in reply to:  description comment:12 by sv75, 16 years ago

Same here: i386, VB from fresh SVN, works fine with FreeBSD, NexentaCore and Linux, but OpenBSD 4.2 prints 'Segmentation faults' way too often. Getting kernel sources from cvs and building it comes to one segfault every 30sec.

comment:13 by kgardas, 16 years ago

Hello,

I'm using VBox on Solaris (SXDE 1/08) happily (I started with VBox 1.5.x beta1), but this issue also hit me. I'd like to use OpenBSD guest but tried 4.0, 4.1, 4.2 and 4.3 without success. Various segfaults happen all over the time even if I switch VT-x support on. I've also tested VBox 1.6 release with OpenBSD 4.3 i386 release and the behavior is still the same.

What surprises me more is even that Qemu runs well with OpenBSD 4.3, although painfully slow thanks to missing kqemu support on Solaris host.

Please consider fixing this issue,

Thanks!

Karel

comment:14 by Frank Mehnert, 16 years ago

Guest type: otherBSD

comment:15 by Frank Mehnert, 15 years ago

Component: otherVMM

comment:16 by alexhq, 15 years ago

Still can't use OpenBSD guests with VBox 2.2

comment:17 by François-Denis Gonthier, 15 years ago

I can't reproduce this bug with OpenBSD 4.5 and VirtualBox 2.2.

I'm currently extracting OpenBSD sources from CVS. It's been running steadily for over 15 minutes without crashing.

comment:18 by Sander van Leeuwen, 15 years ago

Comment from alexhq with a certain four letter word and other complaints removed. If you are unable to remain civilized, then please don't comment at all.

comment:19 by François-Denis Gonthier, 15 years ago

Quoting a part of the message from alexhq, unfortunately removed.

A you in parallel universe? I dunno how it runs on VT-x/AMD-V, but on
plain old P4 2.6 with Debian host OS installation fails with "disk full"
and also there are random segfaults during install. It works somehow, I
can boot it, but random segfaults are still there.

I admit I retried it but not on the computer I used when I reported this was not working.

I'll try to find the time to reproduce it with different configurations.

comment:20 by Wijnand, 15 years ago

I can confirm this is not a issue anymore when VT-x/AMD-V is enabled. My Macbook runs OpenBSD -CURRENT just fine.

comment:21 by François-Denis Gonthier, 15 years ago

I remembered I still had around the virtual HD I used to test OpenBSD, so I tried to disable VT-x/AMD-V.

The segmentation faults are back in force: cvs up in /usr/src crashes after a few seconds.

I would also like to add that the filesystem checking at the boot reportedly "fixed" many errors.

Maybe alexhq was rude, but he was right. This bug is important. A virtualization software should not be optimized for Windows or Linux but, by definition, should be able to support anything.

comment:22 by Sander van Leeuwen, 15 years ago

Summary: OpenBSD guests... still not quite usableOpenBSD guests... still not quite usable (VT-x/AMD-V works)
Version: VirtualBox 1.5.0VirtualBox 2.2.2

in reply to:  20 comment:23 by alexhq, 15 years ago

Replying to Wijnand:

I can confirm this is not a issue anymore when VT-x/AMD-V is enabled. My Macbook runs OpenBSD -CURRENT just fine.

It's cool, but not all legacy CPUs support VT-x/AMD-V. Also, yes, I was rude. Emotions, ain't we all people?!

comment:24 by Alexandre Dulaunoy, 15 years ago

User-land software in OpenBSD (4.5 release) is still segfaulting while using Virtual Box 2.2.4 r47978.

Even if VT-X is enabled... Where is the source of the problem?

comment:25 by Frank Mehnert, 15 years ago

adulau, are you sure that VT-x is really enabled? Please attach a VBox.log file for such a VM session.

comment:26 by François-Denis Gonthier, 15 years ago

The same OpenBSD VM fails spectacularily with VirtualBox 3.0, with VT-x/AMD-V enabled or not.

http://www.lostwebsite.net/links/vbox3_openbsd.png

Not sure if its because my VM is broken or not so I would be happy if some other commenters would confirm.

comment:27 by gpatrick, 15 years ago

Have OpenBSD 4.5 running in VirtualBox 3.0.2 in a non-global zone. It is running, but on startup and shutdown OpenBSD gets many segmentation faults.

comment:28 by gpatrick, 15 years ago

OpenBSD 4.5 on VirtualBox 3.0.4 on an OpenSolaris 0906 host has installed and is running successfully. No disk full or segmentation faults occurred during installation or upon booting.

Using an Acer Aspire 5515 laptop. Used VirtualBox defaults (e.g., Enable VT-x/AMD-v).

comment:29 by bviktor, 14 years ago

it seems that generic.mp became default in 4.6 amd64. i had to do an

echo 'set image bsd.sp' > /etc/boot.conf

coz it crashed randomly with the MP kernel.

comment:30 by François-Denis Gonthier, 14 years ago

Interesting bviktor. Was it with or without the VT-x/AMD-V option set?

comment:31 by bviktor, 14 years ago

AMD-V, 5600+, and i give 2 CPUs to guests.

anyway, it's not the change in defaults... i first compiled the i386 (GENERIC) kernel and then installed it. that caused openbsd to use the SP kernel after reboot. the difference between i386 and amd64 is that i386 compiled the kernel before it ended up in a kernel trap... amd64 started to crash during kernel compilation, but it worked with the previous release. but i may have been just lucky earlier, donno...

what i know is that now i have to use the sp kernel explicitly (on amd64), and then the problems go away...

comment:32 by MuffinFlavored, 14 years ago

New > OpenBSD 4.6 > boot install46.iso > setup a user > set password for user > verify password > segmentation fault > installation continued > auto-format disk? > yes > segmentation fault

comment:33 by robur, 14 years ago

+1

SUN VirtualBox v.3.1.2r56127
HostOS: Windows XP SP3

GuestOS: OpenBSD 4.2, OpenBSD 4.6

segmentation fault :-(

comment:34 by Derek J. Hunt, 14 years ago

I have this working under an Ubuntu 9.10 (64bit) host running 3.1.2.r56127

I have "Enable VT-x/AMD-V" and "Enable Nested Paging" enabled, "Enable PAE/NX" enabled.

I am using the ICH6 ide controller and "Intel PRO/1000 MT Desktop (8254OEM)" network adapter.

the install proceeds under OpenBSD 4.6 i386 and OpenBSD 4.6. amd64.

comment:35 by François-Denis Gonthier, 14 years ago

I think we have mostly established that it should run well with VT-x/AMD-V.

in reply to:  35 ; comment:36 by Derek J. Hunt, 14 years ago

Replying to fdgonthier:

I think we have mostly established that it should run well with VT-x/AMD-V.

Actually we are testing on another machine right now (Windows 7 host) and it is seg faulting regardless of which options are enabled.

So I suspect there is something else going on as well.

comment:37 by Shinkan, 14 years ago

CPU : Intel Core 2 Duo P7350 Host : Windows 7 Business Guest : OpenBSD 4.6

Many "Segmentation fault", which are kinda randomly spread. I can NOT finish the install process. I have no odd settings (1 proc, 512 Mb RAM, 1 bridge NET, 1 IDE Disk, 1 IDE CD).

Please note that my CPU doesn't handle VT-x, but that VirtualBox greys check that control this parameter in GUI, and that it is checked by default.

in reply to:  36 ; comment:38 by Casey Allen Shobe, 14 years ago

I'm running VirtualBox 3.0.6 OSE on a Debian 5.0 host.

Tried installing OpenBSD 4.6 and 4.7, with all different hardware choices and use of VT-x on or off. None of the possible settings make any difference - I have a very difficult time even getting through the install process. Sometimes, it will hang or start erroring out near the end of the boot process, and when it doesn't, then there are random segfaults all the time that interrupt the install process. I actually can manage to usually make it through the install process by ignoring many segfaults, but it doesn't often result in a cleanly-bootable system afterwards.

It gets REALLY UGLY if you try running two VM's at once - I initially tried before hearing about this problem to install both 4.6 and 4.7 parallel. Do that, and you'll get not only segfaults, but kernel panics. Seems that something is leaking the scope of virtualization or vice versa...

in reply to:  38 comment:39 by Casey Allen Shobe, 14 years ago

Replying to Raptelan:

I'm running VirtualBox 3.0.6 OSE on a Debian 5.0 host.

I should also mention it's a 64-bit x86 host and 32-bit x86 guests. The host CPU is an Intel Core 2 6300, and here are the CPU flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm

comment:40 by Bayard Bell, 14 years ago

Is this bug still alive? There don't look to be requisite levels of information (log files) to allow follow-up. If there are problems, perhaps those might be better detailed to allow for meaningful resolution. If no such information is forthcoming, might this issue be closed, with distinct tickets opened afresh if and where further problems arise?

comment:41 by Joseph Hansen, 14 years ago

This bug should probably remain open.

Just tried installing OpenBSD 4.7 into a new VM on VBox 3.2.6. Segfaults start almost immediately.

Tried startup of vm with -norawr0 per following blog post, but this did not fix the issue. http://jreypo.wordpress.com/2009/12/14/openbsd-and-virtualbox/

My cpu doesn't support VT-x extensions.

Will attach session log as "segfault-obsd-2010-07-13-06-58-53.log"

by Joseph Hansen, 14 years ago

comment:42 by Joseph Hansen, 14 years ago

Interesting addition to my last comment.

A seemingly unrelated problem that I hope might be applicable (Or at least useful) to others that have updated this bug.

Installing either Virtual Box or VMWare Player led to BSOD on my Windows 7 system. My initial workaround was to use windows boot menu to "restore last known good configuration".

Got tired of that, and loaded the crashdump it had been producing into the windows debugger, which blamed the BSOD on athrx.sys, which is the atheros wireless adapter.

Searched on that, and found comment from another virtualbox user who'd avoided the BSOD by installing VB without bridged network support. This has been similarly successful for me.

*In addition* to this, I am now able to openbsd 4.7 without getting any segfaults. (So far.)

regards jeh

comment:43 by lover, 13 years ago

In my case...

================

No SEGFAULTS in OpenBSD: ARC=AMD Athlon 64 Host=Windows 7 Guest=OpenBSD 4.7

Lots of scattered SEGFAULTS in OpenBSD I can't even run its installer ARC=Intel Core 2 Duo (Obviously no VT-x) Host=Windows XP Guest=OpenBSD 4.7

================

Is VT-x required for OpenBSD guest? Or it's a bug?

comment:44 by Bayard Bell, 13 years ago

It's documented that OpenBSD guests require VT-x (see http://www.virtualbox.org/manual/ch03.html#id457899).

comment:45 by Frank Mehnert, 12 years ago

Resolution: invalid
Status: newclosed

Exactly.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use