VirtualBox

Ticket #6235 (closed task: fixed)

Opened 4 years ago

Last modified 4 years ago

Unable to update repository from Ubuntu 9.10 amd64

Reported by: momcilo Owned by:
Priority: major Component: other
Version: Keywords:
Cc: Guest type: other
Host type: Linux

Description

The installation contains valid pgp key used for verifing of repository. However, I found it impossible to update the repository information.

The synaptic reports the following:

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error:  http://download.virtualbox.org karmic Release: The following signatures were invalid: BADSIG DCF9F87B6DFBCBAE Sun Microsystems, Inc. (xVM VirtualBox archive signing key) <info@…>

W: Failed to fetch  http://download.virtualbox.org/virtualbox/debian/dists/karmic/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.

Can you please regenerate repository signature?

Attachments

Deb-fail.log Download (2.3 KB) - added by Perryg 4 years ago.
Error of upgrade

Change History

comment:1 Changed 4 years ago by frank

The repository signature is correct. Does it still fail after doing

apt-get clean
apt-get update
apt-get upgrade

?

comment:2 Changed 4 years ago by momcilo

The problem was resolved. I wonder what happened, it may be due to the corrupted packages information?

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I've seen it several times that at the client side some file was broken. We definitely didn't change anything at the server side...

Changed 4 years ago by Perryg

Error of upgrade

comment:4 Changed 4 years ago by Perryg

  • Status changed from closed to reopened
  • Resolution fixed deleted

Frank, I tried this today on my Debian-5.02 server because there are a lot of complaints on the forum  http://forums.virtualbox.org/viewtopic.php?f=7&t=28581&start=0 and it does fail to down load

I deleted the third party repo and re-entered it as stated on the download page. deb  http://download.virtualbox.org/virtualbox/debian lenny non-free

Attached deb-fail.log is what gets reported

comment:5 Changed 4 years ago by frank

Finally confirmed. This only happens via apt-get install ..., the current workaround is to download and install the package manually. The reason is that apt has normally no support for HTTP redirection -- they added support for it in apt 0.7.21. Ubuntu Karmic still has apt 0.7.20, Lucid has currently 0.7.23 (so redirection works fine with Lucid). We will try to disable redirection for the debian/ directory.

comment:6 Changed 4 years ago by frank

Should be fixed now!

comment:7 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:8 Changed 4 years ago by itismike

Maybe this is unrelated because it's on 32-bit, but I've been seeing this in Lucid (beta) for several weeks:

Failed to fetch http://download.virtualbox.org/virtualbox/debian/dists/lucid/non-free/binary-i386/Packages.gz  404  Not found

/etc/apt/sources.list contains:

deb http://download.virtualbox.org/virtualbox/debian lucid non-free

comment:9 Changed 4 years ago by frank

Sure, Lucid Lynx is not released yet. There will be a package available shortly. Just use karmic in your sources.list for the time being, the karmic package should work fine -- except USB which we are about to fix.

comment:10 Changed 4 years ago by itismike

Thank you Frank!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use