VirtualBox

Ticket #6215 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Mouse hover events not sent to the VM -> assumed fixed post-3.1.4

Reported by: atoponce Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Since upgrading to 3.1.2, mouse hover events are not happening. I upgraded to 3.1.4, noticing some Linux guest additions improvements, hoping to see a fix, but nothing. I am running Debian GNU/Linux unstable as the guest operating system, and Windows XP SP3 as the host operating system. Attached is my VBox.log.

A description of the problem I'm facing is this: After GDM is loaded, and I'm sitting at a login prompt, hovering the mouse over the username field does not change the cursor to an I-bar. I must click the field to change the cursor. Which, of course, it will stay the I-bar until I click somewhere else to change the cursor back to an arrow.

Same after logging in. Hovering the mouse over menu items does not change the highlighted item until I click the mouse button. Hovering the mouse over images on the web does not display the title or alt text of the image, and so forth.

Mouse hover events are completely missing.

I've removed and reinstalled guest additions. This happened when I upgraded to 3.1.2. The vboxmouse driver is enabled in the Debian X11 xorg.config. I've downgraded VirtualBox to 3.1.0, and it seems to have kept the issue. I've even removed, and reinstalled, and no dice. Mouse hover events do not work, no matter what I throw at it.

Thanks.

Attachments

VBox.log Download (52.2 KB) - added by atoponce 4 years ago.
Xorg.0.log Download (23.6 KB) - added by atoponce 4 years ago.
xorg.conf Download (711 bytes) - added by atoponce 4 years ago.
lines commented out will keep the mouse hover from working

Change History

Changed 4 years ago by atoponce

comment:1 Changed 4 years ago by atoponce

Curious, I created a new Linux virtual guest and installed guest additions, and the mouse hover bug did not exist, although the load was exceptionally high (unrelated, I'm sure). All currently installed Linux guests are affected. New virtual guests are not affected.

I've also tried creating a new virtual machine, and attaching the old disk image to the new machine, and the bug remains.

To make it clear, I've removed, downgraded and upgraded guest additions in the guest. I've removed, downgraded and upgraded VirtualBox itself on the host. Nothing is working.

If any additional logs are needed, please let me know. These virtual machines are used for production development on my corporate laptop, so I've very crippled without them (although I guess I could go with VMWare- productivity is better than nothing).

Let me know.

Thanks!

comment:2 Changed 4 years ago by frank

Please attach the file /var/log/Xorg.0.log of your guest.

Changed 4 years ago by atoponce

comment:3 Changed 4 years ago by pampa

I had the same issue with Vista 32 as a host and debian squeeze/testing as guest.

I erased the whole contents of xorg.conf and put those few lines instead:

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver       "vboxmouse"
   Option       "CorePointer"
EndSection

With nothing else in the file.

After restarting GDM, mouse hovering worked just fine again.

comment:4 Changed 4 years ago by atoponce

@pampa That worked! Now, I want to close the ticket, but I want to know why having extra lines in the config for the video keeps the mouse hover from working. And, why the hover was working before a VirtualBox upgrade, and stopped working after the upgrade.

comment:5 Changed 4 years ago by michael

Could the people seeing this please attach the xorg.conf files which *failed* to work as they should? That is, the ones that caused the problem?

By the way, the reason for the problem will be that we have to make automatic adjustments in xorg.conf to compensate for changes in the Additions between different versions, and we occasionally get it wrong :) Sorry for the inconvenience.

Changed 4 years ago by atoponce

lines commented out will keep the mouse hover from working

comment:6 Changed 4 years ago by atoponce

@michael, Sorry for not attaching the file, but I want to know someone is working on the problem, so if they request things, then I know it's being looked at. Otherwise how can I tell? No one has been assigned to the ticket, so for all I know, no one is interested.

There is also an xorg.conf.vbox file that is dated Jan 19, which seems about right when I performed the upgrade from 3.1.0 to 3.1.2. If you want that file attached as well, let me know. But I would imagine this file should be enough.

comment:7 Changed 4 years ago by michael

You might want to try this test build of the Additions from the stable 3.1 branch (disclaimer  here)

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r58098.iso

to see if it fixes the issue.

comment:8 Changed 4 years ago by atoponce

So, the offending line in my xorg.conf is:

Option "Device" "/dev/input/mouse0"

With that line enabled, mouse hover events are not called. With it commented out, they are.

comment:9 Changed 4 years ago by michael

Was that with or without the Additions test build I linked to?

comment:10 Changed 4 years ago by atoponce

Without. That is using the same stable guest additions version that corresponds with the current stable release of VirtualBox.

comment:11 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to worksforme
  • Summary changed from Mouse hover events not sent to the VM to Mouse hover events not sent to the VM -> assumed fixed post-3.1.4

Without you testing it is a bit hard for me to know if the problem is fixed, but since you know what to fix in xorg.conf I presume that the issue is no longer very important for you. I can just see if other people run into it, and if they don't I will assume that it is no longer relevant.

comment:12 Changed 4 years ago by atoponce

Yeah, I'm not really interested in testing an alpha release of guest additions, with the possibility of something else breaking. While maybe I shouldn't be using Virtual Box in a production environment, I am, and I just can't take any risks. When I upgrade to the latest stable release, I'm hoping it's stable.

However, all isn't a loss for you. Clearly specifying the input device as "/dev/input/mouse0" breaks the hover event. I've verified this on Debian GNU/Linux, openSUSE and now Fedora 12. So, that is a starting point for you to see what in the code is causing that break.

Good luck!

comment:13 Changed 4 years ago by michael

We certainly think that VirtualBox is suitable for a production environment. And I understand perfectly if you don't feel like testing the Additions I sent you (rather beta than alpha, but still...) If this issue is not fixed there then we will fix it when it becomes a problem for someone again, and in the mean time we will concentrate on more immediate things.

And thanks :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use