VirtualBox

Ticket #6186 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Crash on Guest Shutdown => related to the 3D host driver

Reported by: spoilerhead Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.4 Keywords: crash
Cc: Guest type: Windows
Host type: Linux

Description (last modified by sandervl73) (diff)

When Shutting down a XP guest, my Host system (Ubuntu, x64) crashed. i'm using the PUEL version of virtualbox.

i've experienced this in 3.1.0 but it went away in 3.1.2

got this piece from the syslog:

Feb 13 22:48:38 localhost kernel: [27250.921419] divide error: 0000 [#1] SMP 
Feb 13 22:48:38 localhost kernel: [27250.921423] last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
Feb 13 22:48:38 localhost kernel: [27250.921425] CPU 2 
Feb 13 22:48:38 localhost kernel: [27250.921427] Modules linked in: binfmt_misc vboxnetadp vboxnetflt vboxdrv snd_hda_codec_atihdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_pcm_oss snd_mixer_oss snd_hwdep snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event it87 hwmon_vid snd_seq snd_timer sbp2 snd_seq_device iptable_filter ip_tables snd soundcore nls_iso8859_1 ppdev amd64_edac_mod snd_page_alloc x_tables i2c_piix4 nls_cp437 edac_core lp fglrx(P) k10temp vfat parport_pc fat parport raid10 raid1 raid0 multipath linear dm_raid45 raid456 raid6_pq async_xor async_memcpy async_tx xor usbhid ohci1394 ieee1394 r8169 mii
Feb 13 22:48:38 localhost kernel: [27250.921456] Pid: 20824, comm: VirtualBox Tainted: P           2.6.31-19-generic #56-Ubuntu GA-MA790GP-DS4H
Feb 13 22:48:38 localhost kernel: [27250.921458] RIP: 0010:[<ffffffffa017b784>]  [<ffffffffa017b784>] _ZN15CMMSurface_CORE20setSurfaceAttributesEP16MSF_SURF_ATTRIBSj+0x64/0xe0 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921512] RSP: 0018:ffff8801bf575a60  EFLAGS: 00010256
Feb 13 22:48:38 localhost kernel: [27250.921514] RAX: 0000000000000100 RBX: 0000000000003308 RCX: 0000000000000000
Feb 13 22:48:38 localhost kernel: [27250.921515] RDX: 0000000000000000 RSI: ffff8801bf575c18 RDI: ffffc900122fb420
Feb 13 22:48:38 localhost kernel: [27250.921517] RBP: ffffc900122fb420 R08: 0000000000000001 R09: 0000000000000000
Feb 13 22:48:38 localhost kernel: [27250.921518] R10: 0000000000000000 R11: 0000000000000001 R12: ffff8801bf575c18
Feb 13 22:48:38 localhost kernel: [27250.921520] R13: ffff8801bf575b28 R14: ffffc90011a37c00 R15: ffffc9001231cb00
Feb 13 22:48:38 localhost kernel: [27250.921521] FS:  00007f998669c710(0000) GS:ffff880028070000(0000) knlGS:0000000000000000
Feb 13 22:48:38 localhost kernel: [27250.921523] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Feb 13 22:48:38 localhost kernel: [27250.921524] CR2: 00007f994eea1000 CR3: 000000018a8f7000 CR4: 00000000000006e0
Feb 13 22:48:38 localhost kernel: [27250.921526] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Feb 13 22:48:38 localhost kernel: [27250.921528] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Feb 13 22:48:38 localhost kernel: [27250.921530] Process VirtualBox (pid: 20824, threadinfo ffff8801bf574000, task ffff880202a496b0)
Feb 13 22:48:38 localhost kernel: [27250.921531] Stack:
Feb 13 22:48:38 localhost kernel: [27250.921532]  ffffffffa0169917 ffff880100000000 ffffc90011a37c00 ffffffffa01f92f0
Feb 13 22:48:38 localhost kernel: [27250.921534] <0> ffff8801bf575c18 ffffc9001231d660 ffff8801bf575b28 ffff8801bf575c4c
Feb 13 22:48:38 localhost kernel: [27250.921536] <0> ffffffffa0169f69 0000000000000001 ffffffffa018dd87 0100000000000000
Feb 13 22:48:38 localhost kernel: [27250.921539] Call Trace:
Feb 13 22:48:38 localhost kernel: [27250.921571]  [<ffffffffa0169917>] ? _ZN3MSF11create_surfEP9CMMClientP9CMMDriverPvRA4_K14CMM_ALLOCATIONP16MSF_SURF_ATTRIBS+0x97/0x1c0 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921601]  [<ffffffffa0169f69>] ? _ZN3MSF10alloc_surfEP9CMMClientP9CMMDriverP21MEMHEAP_ADDR_RESTRICTjP16MSF_SURF_ATTRIBSP15_CMM_RETURNCODE+0x529/0x570 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921636]  [<ffffffffa018dd87>] ? _ZN8AsicR60025getOffsetAlignmentAndSizeEP16MSF_SURF_ATTRIBSjj+0x197/0x340 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921665]  [<ffffffffa0164f6c>] ? CMMAllocSurface_WA+0x7fc/0x980 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921688]  [<ffffffffa012e302>] ? firegl_trace+0x72/0x1e0 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921718]  [<ffffffffa0176057>] ? _Z8uCWDDEQCmjjPvjS_+0xb17/0x10c0 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921723]  [<ffffffff8107d549>] ? down+0x29/0x50
Feb 13 22:48:38 localhost kernel: [27250.921745]  [<ffffffffa0130774>] ? firegl_cmmqs_CWDDE_32+0x334/0x440 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921767]  [<ffffffffa012f220>] ? firegl_cmmqs_CWDDE32+0x70/0x100 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921789]  [<ffffffffa012f1b0>] ? firegl_cmmqs_CWDDE32+0x0/0x100 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921809]  [<ffffffffa010e35a>] ? firegl_ioctl+0x1ea/0x250 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921827]  [<ffffffffa0104471>] ? ip_firegl_ioctl+0x11/0x20 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921830]  [<ffffffff8112e4dc>] ? vfs_ioctl+0x7c/0xa0
Feb 13 22:48:38 localhost kernel: [27250.921832]  [<ffffffff8112eaa9>] ? do_vfs_ioctl+0x79/0x370
Feb 13 22:48:38 localhost kernel: [27250.921836]  [<ffffffff8111f8d1>] ? vfs_read+0x181/0x1a0
Feb 13 22:48:38 localhost kernel: [27250.921837]  [<ffffffff8112ee21>] ? sys_ioctl+0x81/0xa0
Feb 13 22:48:38 localhost kernel: [27250.921842]  [<ffffffff81012002>] ? system_call_fastpath+0x16/0x1b
Feb 13 22:48:38 localhost kernel: [27250.921844] Code: 4c 89 97 e0 00 00 00 44 8b 4e 20 44 89 8f e8 00 00 00 48 8b 56 28 48 89 97 f0 00 00 00 31 d2 8b 46 24 c1 e8 03 89 c1 48 8b 46 28 <48> f7 f1 48 89 87 d0 00 00 00 44 8b 5e 30 44 89 9f f8 00 00 00 
Feb 13 22:48:38 localhost kernel: [27250.921861] RIP  [<ffffffffa017b784>] _ZN15CMMSurface_CORE20setSurfaceAttributesEP16MSF_SURF_ATTRIBSj+0x64/0xe0 [fglrx]
Feb 13 22:48:38 localhost kernel: [27250.921892]  RSP <ffff8801bf575a60>
Feb 13 22:48:38 localhost kernel: [27250.921894] ---[ end trace 74b2da89c42ad13d ]---

Change History

comment:1 Changed 4 years ago by sandervl73

  • Description modified (diff)

comment:2 Changed 4 years ago by sandervl73

Looks like a bug in your opengl driver. Try disabling 3d support in the VM settings.

comment:3 Changed 4 years ago by spoilerhead

thanks. 3d acceleration was disabled, but disabling 2d seems to have fixed it. I still suspect that this is a regression as it worked for me in 3.1.2 and nothing changed on my graphics stack in the mean time

comment:4 Changed 4 years ago by frank

  • Component changed from other to 3D support

Setting component to 3D support as guest-2D is emulated by host-3D.

comment:5 Changed 4 years ago by frank

  • Summary changed from Crash on Guest Shutdown to Crash on Guest Shutdown => related to the 3D host driver

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #6038.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use