VirtualBox

Ticket #6079 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Second Guest VM crashes (ATA_AIO_) => fixed in SVN/next release

Reported by: BLiNKx86 Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 3.1.6 Keywords: guest crash ATA_AIO_ABORT ATA_AIO_RESET_CLEARED ATA_AIO_RESET_ASSERTED
Cc: Guest type: Linux
Host type: other

Description

Running VirtualBox 3.1.2 r56127 on Fedora 12. I have 2 guests machines. Windows XP is up and running. I created a 2nd guest which is type Linux/RedHat and began the CENTOS 5.4 install procedure. The 2nd guest will crash consistently within 5 minutes of starting up. If I shutdown the Windows XP guest and run only the CENTOS 5.4 guest, it runs fine.

Attachments

VBox.log Download (35.7 KB) - added by BLiNKx86 4 years ago.
VBox.2.log Download (44.0 KB) - added by hafthor 4 years ago.
Guest mysteriously died while unattended. Host: Mac OSX, Guest Win7 x86

Change History

Changed 4 years ago by BLiNKx86

comment:1 Changed 4 years ago by frank

  • Component changed from host support to virtual disk
  • Summary changed from Second Guest VM crashes to Second Guest VM crashes (ATA_AIO_)

Changed 4 years ago by hafthor

Guest mysteriously died while unattended. Host: Mac OSX, Guest Win7 x86

comment:2 Changed 4 years ago by hafthor

Same Assertion failing: DevATA.cpp(4574)

comment:3 Changed 4 years ago by klaus

  • Keywords multiple running removed
  • Host type changed from Linux to other
  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.1.6

The initial reporter can work around the crash by putting the cd drive as secondary master in the VM config. This is definitely not related in any way to how many VMs are running or some such, it happens if there is both a hard disk and a cd drive on the same IDE channel and one is (un)lucky enough to get the guest to do transfers with the right timing. Host OS is irrelevant.

The other reporter already has this configuration, and right now I have no idea how that assertion can happen with this kind of setup. Maybe I can make more sense out of this once I find time to debug the initially reported problem, which is easy to reproduce.

The issue is definitely not related to

comment:4 Changed 4 years ago by klaus

  • Summary changed from Second Guest VM crashes (ATA_AIO_) to Second Guest VM crashes (ATA_AIO_) => fixed in SVN/next release

The original bug is fixed. It gave no clues whatsoever for the other issue, so please open a separate bug report for that one.

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.8

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use