VirtualBox

Ticket #6055 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

Virtualbox hacks into host's xterm and crashes host while playing sound

Reported by: Deever Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I'm not sure wether it is related that a virtual machine ran out of swap in the meantime, but suddenly the host's xterms stayed back some characters typed, also when I typed very slowly. It also didn't help to pause or shutdown the VMs, I needed to reboot the host.

Probably related: After installing VirtualBox, everything immediately freezes up when I pause a file in an audioplayer and then try to resume.

Change History

comment:1 Changed 4 years ago by frank

Regarding the second problem: If you configured a sound device for your guest then VBox will try to open an audio backend when the VM is started. If your audio backend cannot share multiple streams, then the paused stream will not resume because the VM process is now using the stream. I suggest to use the PulseAudio backend which shouldn't have such problems.

Regarding the first problem: I highly doubt that this problem is directly related with VirtualBox. Such problems are most often caused by buggy video drivers on the host.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use