VirtualBox

Ticket #6034 (closed defect: obsolete)

Opened 4 years ago

Last modified 5 months ago

Incompatibility betweens guest addition 2.1.4 and guest additions 3.1.2

Reported by: agonzalezro Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 3.1.2 Keywords: guest additions incompatibility 2.1.4 3.1.2
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I've copy a windows xp sp2 image with guests addition 2.1.4 and created with Virtual Box 2.1.4 to a machine with Virtual Box 3.1.2 and after this I can't move my mouse or resize my window (no fullscreend allowed).

To rescue my mouse I must install the new guest additions (3.1.2) in the migrated windows xp image, after that, all works perfectly.

Change History

comment:1 Changed 4 years ago by Technologov

VBox never guaranteed a compatibility of Guest Additions across VBox versions.

-Technologov

comment:2 Changed 4 years ago by klaus

Guest additions are intended to be "backwards compatible", i.e. they should continue to work if you upgrade the VirtualBox version on the host. You're right that we make no guarantees (to non-paying customers), however there are not that many versions where we heard of severe problems.

Users must be able to upgrade, and a broken mouse can be a major problem.

comment:3 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use