VirtualBox

Ticket #6004 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

x64 Guest will not run on Windows 7 x64 -> HP BIOS bug

Reported by: TheTechninja Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.1.2 Keywords: 64-bit guests
Cc: Guest type: other
Host type: Windows

Description

I am running Windows 7 Enterprise x64 (Fresh install, no other virtualization products installed) on a Core2quad Q6600, 8 GB RAM

VirtualBox will not detect VT-x extensions, although they are enabled (I dual boot the system with Windows Hyper-V Server 2008 R2 without any problems running 64-bit guests)

VirtualBox reports

"VirtualBox - Error | VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot. Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer."

Attachments

VirtualBox-6004-01.png Download (117.4 KB) - added by TheTechninja 4 years ago.
Error message upon starting guest
VBox.log Download (33.1 KB) - added by TheTechninja 4 years ago.
Session VBox.Log

Change History

Changed 4 years ago by TheTechninja

Error message upon starting guest

comment:1 Changed 4 years ago by sandervl73

Only the VBox.log of the session will show the real problem.

Changed 4 years ago by TheTechninja

Session VBox.Log

comment:2 Changed 4 years ago by Technologov

hmmm.... very interesting...

-Technologov

comment:3 Changed 4 years ago by XeNeS

I do have same issue here... Virtualbox 3.1.2r56127 + Windows 7 64bit + Intel T9600 CPU

As far I rememeber it was working on older VBox release.

64bit guest doesn't start at all just reboots in loop, same error message as above.

Is that known issue?

comment:4 Changed 4 years ago by sandervl73

XeNeS: A 'me too' message is useful if you add your log file.

comment:5 follow-up: ↓ 6 Changed 4 years ago by sandervl73

TheTechninja:

HWACCM: No VT-x or AMD-V CPU extension found. Reason VERR_VMX_MSR_LOCKED_OR_DISABLED
HWACCM: VMX MSR_IA32_FEATURE_CONTROL=1

Shows your BIOS has not turned on VT-x properly. I don't know why Hyper-V doesn't complain, but the Intel manual is very clear. Either you haven't turned it on or you need to find a BIOS update.

comment:6 in reply to: ↑ 5 Changed 4 years ago by TheTechninja

I found a solution, it seems that the VT-x will only work properly if you fully shut down the system (not just a restart) in order to work. I had assumed that a restart would work, perhaps this is a bug in the Intel VT-x implementation? I was also able to reproduce this error on HP DL320 / 360 / 380 G6s. Solution is the same on these.

Perhaps a message should be placed in the Setup program to recommend Fully shutting down the systems rather than a restart? I also believe we should track processors and models that have this problem and perhaps submit this to Intel.

comment:7 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme
  • Summary changed from x64 Guest will not run on Windows 7 x64 to x64 Guest will not run on Windows 7 x64 -> HP BIOS bug

Not really as it's a BIOS bug. It has nothing to do with Intel.

comment:8 Changed 4 years ago by Technologov

Well, I have a similar problem with my Toshiba Qosmio Laptop X300.

Intel VT-x spec requires full shutdown after BIOS change, and my desktop (GIGABYTE) does it correctly, after I change VT-x setting in the BIOS, my Laptop does not ! (buggy BIOS) -- That is my Desktop BIOS automatically powers off my PC. I talked to Toshiba, but they refused to modify their BIOS due to bureaucracy, but after full shutdown Laptops works too...

I suggest modifying VBox text message:

"Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer."

---> "Please ensure that you have enabled VT-x/AMD-V properly in the BIOS, and cold-booted your host computer."

-Technologov

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use