VirtualBox

Ticket #5990 (closed defect: fixed)

Opened 4 years ago

Last modified 13 months ago

Snapshot VHD is not a valid file format => fixed in SVN

Reported by: atpetro Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 3.1.2 Keywords: VHD, Differencing, Snapshot
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

I have a VHD that I can configure and boot from VirtualBox without any issues. I can also create a snapshot and boot that from VirtualBox without any issues. I want to port the parent and child VHDs to MS technologies - Virtual PC for 32-bit or Hyper-V for 64-bit. Unfortunately, the VHD that VirtualBox creates for the differencing drive is not a valid VHD format. Nothing but VirtualBox can load the differencing file - WinImage, VirtualPC Disk Wizard and Hyper-V Edit Disk all fail to load the snapshot VHD. If I create a differencing disk using Virtual PC, then all three of those tools can read both the parent and the child VHD. I can also use the diff drives created by VirtualPC as valid snapshot files in VirtualBox (after manual xml manipulation). Please fix the VHD diff drive format so our work can be portable and we can recover files with tools like WinImage when corruption occurs. This is possibly related to why merge isn't working for VHD snapshots - ticket #5981.

Attachments

Hyper-V - Inspect Disk.png Download (7.6 KB) - added by atpetro 4 years ago.
Hyper-V Inspect Disk error
Hyper-V - NewVM.png Download (19.1 KB) - added by atpetro 4 years ago.
Hyper-V New Virtual Machine error

Change History

comment:1 Changed 4 years ago by aeichner

  • Summary changed from Snapshot VHD is not a valid file format to Snapshot VHD is not a valid file format => fixed in SVN

Thanks for the report. The issue is fixed in svn and will appear in the next maintenance release of VirtualBox.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Changed 4 years ago by atpetro

Hyper-V Inspect Disk error

Changed 4 years ago by atpetro

Hyper-V New Virtual Machine error

comment:3 Changed 4 years ago by atpetro

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've downloaded 3.1.4 and it does appear to fix the VHD file format compatibility for MS Virtual PC. However, the VHD created by snapshots is still invalid when using Inspect Disk, Edit Disk or new virtual machine with Existing Disk via Hyper-V. I've attached the screenshots of the errors I get in Hyper-V. My original bug mentioned both Virtual PC and Hyper-V yet only one was fixed. I believe this instability of the VHD file format is also leading to my merge issues (see #5981).

comment:4 Changed 4 years ago by atpetro

I see that this resolution is "DELETED" with no explanation. Can someone tell me if the VHD differencing drives will be created correctly so that all MS technologies, specifically Hyper-V, can recognize them? This becomes increasingly more important when building 64-bit snapshots.

comment:5 Changed 14 months ago by frank

  • Description modified (diff)

The incompatibility of VHD snapshot images is most likely fixed in the next maintenance release.

comment:6 Changed 14 months ago by frank

There is a fix in VBox 4.2.8 but the fix is unfortunately not complete, this will have to wait for the next maintenance release. I can provide a test build if necessary (please tell me which host in that case).

comment:7 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Finally fixed in 4.2.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use