VirtualBox

Ticket #5981 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

VHD corrupted after Delete Snapshot

Reported by: atpetro Owned by:
Priority: blocker Component: virtual disk
Version: VirtualBox 3.1.2 Keywords: VHD
Cc: Guest type: Windows
Host type: Windows

Description

Delete Snapshot causes the resulting VHD to become corrupt, unrepairable and unbootable. I’ve tested creating multiple snapshots (2-3 levels deep) by adding files to the desktop. I can then delete all those snapshots and end up with a single VHD that contains all the changes of the now merged snapshots (all the files on the desktop). This works great for small snapshot diff drives (< 1GB). However, once I start doing any significant work in the snapshots causing the diff drive to be > 1GB (sometimes as big as 10GB), the merge process ends up corrupting the resulting VHD. One time I had CHKDSK run on the resulting VHD – it found lots of corrupt files but couldn’t restore them – this broke IIS, SharePoint, Office, etc when Windows finally booted. I deleted that VHD and started over - creating snapshots again, and then deleting/merging them down to a single VHD. Now windows won’t even boot – it just hangs on crcdisk.sys – safe mode won't boot and repair can't find anything to fix. The VHD is Windows 2008 32-bit. I’ve also experienced the same corruption with snapshots using Windows 2008 R2 64-bit VHD. Snapshots are unsuable if they corrupt the root VHD. I’ve attached the log.

Attachments

VBox.log Download (52.5 KB) - added by atpetro 4 years ago.

Change History

Changed 4 years ago by atpetro

comment:1 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to duplicate

Unfortunately I wasn't able to reproduce this problem so far. Merging snapshots works here. This defect looks like a duplicate of #6023 (or a part of #6023 is a duplicate of this defect ;)). Because the other defect contains another problem which is not described here I'll close this one. Please comment there or reopen if this is a different problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use