Ticket #5870 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

VRDP does not support RDP5.2

Reported by: goldeneyexs Owned by:
Priority: major Component: RDP
Version: VirtualBox 3.1.2 Keywords: RDP5.1, RDP5.2, Man in the middle
Cc: Guest type: other
Host type: other


According to the VBox manual vrdp section at:

VBox only support RDP5.1, as no configuration options for RDP5.2 are exposed to the user.

RDP5.1 as the manual says is not secure and is vulnerable to a MITM attack (detailed here:

Please add RDP5.2 support to VBox to provide some sort of machine authentication.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

RDP 5.2 was implemented some time ago. VBox 4.1.6 has it.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use