VirtualBox

Ticket #5871 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Internal networks stop passing traffic

Reported by: ionosphere80 Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.2 Keywords: internal network stop hang
Cc: Guest type: Linux
Host type: Mac OS X

Description

I'm attempting to simulate a dynamically routed network environment by running Quagga on several minimal Ubuntu 9.10 64-bit Linux guests hosted on MacOS X 10.5.8. Each guest uses a handful of internal networks to simulate point-to-point links between routers and to provide connectivity for clients which generate traffic on stub networks. Shortly after the guests boot up and routing converges, the internal networks either become incredibly sluggish or completely fail to pass traffic. Running "ping" between guests shows considerable packet loss and "tcpdump" on each side shows packets egressing but few, if any, returning from the remote end. Sometimes I'll see "bursts" of packets, but in general very few successfully complete the round trip in a reasonable time. Strangely, keeping the internal network links busy after the guests boot up with something like a 1-second interval ping maintains connectivity. However, the internal networks will stop passing traffic shortly after terminating the ping. None of the guest log files show any problems. I'm also experiencing this issue with guests not associated with this particular project, but running under the same instance of VirtualBox.

Attachments

VBox.log Download (45.6 KB) - added by boecko 4 years ago.
VBox.log with broken host-only adapter
vminfo.txt Download (2.8 KB) - added by boecko 4 years ago.
output of "VBoxManage showvminfo darkside --details"

Change History

comment:1 Changed 4 years ago by boecko

I have the same issue with 3.1.4

host only networking stops working without a error: I've mounted my /Users from HOST--OS X 10.6.2 on a Debian32bit-VM via NFS.

Suddenly the network locks up. NO PING .. nothing is working

VBoxManage controlvm ... setlinkstate2 on/off has no effect (but is seen from the virtual machine)

comment:2 Changed 4 years ago by frank

Please attach a VBox.log file of such a session. How easy to reproduce is the problem and how long does it take until the network does not respond anymore?

comment:3 Changed 4 years ago by boecko

Hi,

it seems to be a problem with e1000-Emulation. I've removed the e1000 driver from the linux/kernel and loaded it again. Problem was still there.

I've switched to virtio and the problem is gone.

Changed 4 years ago by boecko

VBox.log with broken host-only adapter

comment:4 Changed 4 years ago by boecko

the problem still arise: Setup: debian-vm on osx 10.6.2 eth0 -> bridged en1 (airport) - type virtio-net eth1 -> hostonly - type virtio-net eth2 -> bridged en0 (ethernet) - typo virtio-net

eth1 stops working after some time (can be 10 minutes or more)

  • /sbin/reboot of guest doesn't help for interface eth1 guest sees following at reboot

DHCPDISCOVER on eth1 DHCPOFFER FROM x.x.x.x DHCPREQUEST on eth1 <repeating forever>

comment:5 Changed 4 years ago by frank

Your suspicion of the E1000 device still holds, correct? We have other reports that switching to PCNet solves this problem as well.

comment:6 Changed 4 years ago by boecko

I don't know ... all 3 devices are virtio-net now and it happens too.

Now it seems stable since for 8 hours, but the i didn't switch on the eth2-interface (en0-ethernet on host)

An observation: The ethernet-Interface on the macmini is connected (without a switch) to a sat-Set-Top-Box, which is not always on. When the set-top-box is switched off, the cable is not connected for the macmini -> bridged networking stops on eth2. But this shouldn't interfere with eth1 (which is the hostonly network), should it?

Changed 4 years ago by boecko

output of "VBoxManage showvminfo darkside --details"

comment:7 Changed 4 years ago by henrik242

This looks like a dupe of #5254

comment:8 Changed 3 years ago by frank

Still relevant with VBox 4.0.4?

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use