VirtualBox

Ticket #5842 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

X can't start - unable to find initial modes -> duplicate of #5731

Reported by: greenrd Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I installed Fedora Linux 12 in VirtualBox, and this seemed to work as long as I didn't use Full Screen mode. When I switched to Full Screen mode with Host+F and then shut down the virtual machine, changed the network configuration and powered up the virtual machine again, X wouldn't start in the guest.

I repeatedly tried to start X as root, and every time I got these kind of messages:

(II) VBoxVideo(0): Output VBOX1 has no monitor section (II) VBoxVideo(0): Output VBOX1 has no monitor section (II) VBoxVideo(0): Not using built-in mode "1440x900" (unknown reason) (II) VBoxVideo(0): No remaining probed modes for output VBOX1 (II) VBoxVideo(0): Output VBOX1 connected (WW) VBoxVideo(0): Unable to find initial modes (EE) VBoxVideo(0): Output VBOX1 enabled but has no modes (EE) VBoxVideo(0): Initial CRTC configuration failed! (II) UnloadModule: "vboxvideo" (II) UnloadModule: "vgahw" (II) Unloading /usr/lib64/xorg/modules/libvgahw.so (II) UnloadModule: "shadowfb" (II) Unloading /usr/lib64/xorg/modules/libshadowfb.so (II) UnloadModule: "fb" (II) Unloading /usr/lib64/xorg/modules/libfb.so (II) UnloadModule: "int10" (II) Unloading /usr/lib64/xorg/modules/libint10.so (II) UnloadModule: "vbe" (II) Unloading /usr/lib64/xorg/modules/libvbe.so (EE) Screen(s) found, but none have a usable configuration.

Fatal server error: no screens found

Attachments

Xorg.0.log Download (9.7 KB) - added by greenrd 4 years ago.
Xorg log file
VBox.log Download (43.6 KB) - added by greenrd 4 years ago.
vbox log
xorg.conf Download (1.8 KB) - added by greenrd 4 years ago.
WORKAROUND - as root, copy to /etc/X11/xorg.conf

Change History

Changed 4 years ago by greenrd

Xorg log file

Changed 4 years ago by greenrd

vbox log

Changed 4 years ago by greenrd

WORKAROUND - as root, copy to /etc/X11/xorg.conf

comment:1 Changed 4 years ago by greenrd

Oops, that file is in Windows format, so anyone wishing to use that workaround needs to run the following command first on that attachment:

dos2unix xorg.conf

comment:2 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from X can't start - unable to find initial modes to X can't start - unable to find initial modes -> duplicate of #5731

Marking this a duplicate of #5731.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use