VirtualBox

Ticket #5839 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

OpenGL module segfaults on Fedora 12 64bit

Reported by: Technologov Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: other

Description

Besides OpenGL fails to start due to SELinux issues, after SELinux gets disabled the OpenGL module segfaults.

Host OS: Windows XP, 32bit, Core 2 Q6600, VBox 3.1.0 (and 3.1.2)

Guest OS: Fedora 12, 64bit

Steps to reproduce:

  1. Start Fedora 12/x64 with 3D enabled and guest additions v3.1.2 installed.
  1. Disable SELinux in VM
  1. run "glxgears"

Glxgears will crash due to segfault in VBox OpenGL module. Disabling 3D acceleration will make glxgears work.

-Technologov, 25.dec.2009.

Attachments

Fedora12 64-bit-2009-12-17-21-08-30.log Download (65.1 KB) - added by Technologov 4 years ago.
vbox log

Change History

Changed 4 years ago by Technologov

vbox log

comment:1 Changed 4 years ago by frank

Still relevant? Note that for recent F12 guests you need the fix from #6198.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use