VirtualBox

Ticket #6198 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Guest Fedora 12 hangs during login in graphic mode => Fixed in SVN

Reported by: philo Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Guest hangs during login step in Gnome desktop. The host run under last update Fedora 8 on a PC.

VirtualBox version is 3.1.4. Fedora 12 guest is up to date. I can use it in terminal mode. The latest Linux VirtualBox additions are installed.

Best regards.

Attachments

Fedora-12-2010-02-14-15-30-16.log Download (65.1 KB) - added by philo 4 years ago.
xorg.conf Download (925 bytes) - added by philo 4 years ago.
Xorg.conf

Change History

Changed 4 years ago by philo

comment:1 Changed 4 years ago by frank

Do you know if this is a regression, that is, did you test the same guest with an older release of VirtualBox on the same host?

comment:2 Changed 4 years ago by philo

I don't know if it is a regression because i have done migration from F11 -> F12 and VB from 3.0 to 3.1.4 a the same time.

But in that configuration, i have a very curious ugly experiment :

Last sunday, i have done those things in that order :

-a) Start the host (FC8 intel Core duo 1)
-b) Start a user account under Gnome.
-c) Start VirtualBox 3.1.4
-d) Start guest F12 + LinuxAdditions.
-e) Log root in console mode (Ctrl + F2), not under Gnome.
-f) Update F12 with yum, in particular xorg.
-g) logout
-h) Log under Gnome in graphic mode.
-i) IT WORKS FINE.
-j) doing some little works.
-k) Shutdown F12 correctly
-l) Start again F12
-m) Try to log in graphic mode under Gnome.
-n) IT HANGS ???
-o) Force a shutdown (=> Guest status : aborted)
-p) Start again F12
-q) Log in console mode (Ctrl + F2)
-r) Logout
-s) Try to log in graphic mode under Gnome.
-t) IT HANGS ???? !!!!

So i am a little bit disappointed.

Hope that help you.

Regards

comment:3 follow-up: ↓ 4 Changed 4 years ago by michael

Could you try removing the Guest Additions ("VBoxLinuxAdditions-x86.run uninstall") to see if that makes a difference?

comment:4 in reply to: ↑ 3 Changed 4 years ago by philo

Replying to michael:

Could you try removing the Guest Additions ("VBoxLinuxAdditions-x86.run uninstall") to see if that makes a difference?

After uninstalling the Guest Additions with the uninstall.sh script in /opt and restoring the original (vesa) xorg.conf file and restarting the F12 guest, I have the same hang.

comment:5 follow-ups: ↓ 7 ↓ 18 ↓ 20 Changed 4 years ago by frank

  • Summary changed from Guest Fedora 12 hangs during login in graphic mode on PC with Fedora 8. to Guest Fedora 12 hangs during login in graphic mode => Fixed in SVN

Confirmed. The fix can be found in r27248. You can manually apply this fix after you installed the guest additions (but before you rebooted the guest!) by changing /usr/src/vboxvideo-3.1.4/vboxvideo_drm.c in your guest and then re-compile the kernel modules with

/etc/init.d/vboxadd setup

. This fix will be included in the next maintenance release.

comment:6 Changed 4 years ago by frank

Applies to Ubuntu/Lucid as well.

comment:7 in reply to: ↑ 5 Changed 4 years ago by philo

Replying to frank:

Confirmed. The fix can be found in r27248. You can manually apply this fix after you installed the guest additions (but before you rebooted the guest!) by changing /usr/src/vboxvideo-3.1.4/vboxvideo_drm.c in your guest and then re-compile the kernel modules with

/etc/init.d/vboxadd setup

. This fix will be included in the next maintenance release.

Well, I have tried your patch, exactly as you explain to me, and it does not changes anything. I have the same error with the same code. On the guest F12, I am using the 2.6.31.12-174.2.22.fc12.i686 kernel and your patch is for version >= 2.6.33.

comment:8 follow-up: ↓ 9 Changed 4 years ago by frank

Look at the patch, it applies to the Fedora 12 kernels as well as DRM_UNLOCKED is defined. I guess you did something wrong. Are you sure that you recompiled and re-loaded the guest kernel module?

comment:9 in reply to: ↑ 8 Changed 4 years ago by philo

Replying to frank:

Look at the patch, it applies to the Fedora 12 kernels as well as DRM_UNLOCKED is defined. I guess you did something wrong. Are you sure that you recompiled and re-loaded the guest kernel module?

I have done the things exactly as you wrote it two days ago, and it doesn't work.

The command : "find /usr/include -name '*' -exec grep -l DRM_UNLOCKED {} \;" doesn't print any line, so the define DRM_UNLOCKED doesn't exist in this directory. So the test in vbox fails. For me the question is : where DRM_UNLOCKED is defined ?

I find only the macro DRM_LOCK in /usr/include/xf86drm.h. Obviously, compilation of the additions succeeds.

comment:10 follow-up: ↓ 11 Changed 4 years ago by frank

You can find DRM_UNLOCKED in include/drm/drmP.h in the linux kernel sources.

comment:11 in reply to: ↑ 10 Changed 4 years ago by philo

Replying to frank:

You can find DRM_UNLOCKED in include/drm/drmP.h in the linux kernel sources.

Finding command : "find /usr/src/kernels/2.6.31.12-174.2.22.fc12.i686 -name '*' -exec grep -l DRM_UNLOCKED {} \;" gives nothing !!!

comment:12 follow-up: ↓ 13 Changed 4 years ago by frank

That's correct but the latest Fedora 12 kernel is 2.6.32. To be specific: 2.6.32.9-70.fc12.i686

comment:13 in reply to: ↑ 12 ; follow-up: ↓ 14 Changed 4 years ago by philo

Replying to frank:

That's correct but the latest Fedora 12 kernel is 2.6.32. To be specific: 2.6.32.9-70.fc12.i686

So we must assume that : -1) VirtualBox 3.1.4 + LinuxAddition doesn't work on F12 with kernel version < 2.6.32 -2) Consequently i must upgrade the kernel.

Is that right ?

comment:14 in reply to: ↑ 13 Changed 4 years ago by philo

Replying to philo:

Replying to frank:

That's correct but the latest Fedora 12 kernel is 2.6.32. To be specific: 2.6.32.9-70.fc12.i686

So we must assume that : -1) VirtualBox 3.1.4 + LinuxAddition doesn't work on F12 with kernel version < 2.6.32 -2) Consequently i must upgrade the kernel.

Is that right ?

Well i have tried with the latest kernel 2.6.32.9-70.fc12.i686 and it hang again with the same error. Those time i have found the define DRM_UNLOCKED in the h file. I have proceeded in this order :

  1. Upgrade the kernel.
  2. Uninstall LinuxAdditions.
  3. Reboot the guest. Use the terminal F2.
  4. Install LinuxAdditions.
  5. Apply the patch.
  6. Compile the modules with /etc/init.d/vboxadd setup.
  7. Shutdown the guest.
  8. Restart the guest.
  9. Try to log in graphic mode.
  10. Hang.

comment:15 follow-up: ↓ 16 Changed 4 years ago by frank

Hmm, in that case I cannot reproduce your problem. There was definitely a problem with Linux 2.6.32 / Fedora kernels but your problem seem to be different. Can you describe the hang in more detail, that is, does 'only' the guest hang or is even the guest VM window frozen? Can you shutdown the VM using the shutdown dialog or do you have to kill the VM process?

Can you try if disabling the clipboard helps (use the VM settings please)?

Changed 4 years ago by philo

Xorg.conf

comment:16 in reply to: ↑ 15 Changed 4 years ago by philo

Replying to frank:

Hmm, in that case I cannot reproduce your problem. There was definitely a problem with Linux 2.6.32 / Fedora kernels but your problem seem to be different. Can you describe the hang in more detail, that is, does 'only' the guest hang or is even the guest VM window frozen? Can you shutdown the VM using the shutdown dialog or do you have to kill the VM process?

Can you try if disabling the clipboard helps (use the VM settings please)?

-1) After the hang, on the server /opt/VirtualBox/VirtualBox process runs continuously (TIME column of ps). Ont the guest "Host + Q" doesn't terminate. I have to close the main guest F12 windows which close immediately after i press the terminate button of the dialogBox.

-2) After disabling the clipboard, i have the same symptom.

-3) Other thins on guest f12 :

-a) No error with dmesg. -b) No error in VirtualBox log (/var/log) -c) No error in the Xorg.log. -d) Note that i set a xorg.conf file for screen resolution (See the Xorg.conf above as attachment file).

Anyway, if it doesn't work on my laptop with guest F12 on Host F8, i shall try in a few weeks with F13 beta as guest.

comment:17 Changed 4 years ago by umina

I've got the same problem with a system that was working.

Host is FC12, Guest is FC12. After clean install on a guest of FC12, all upgrades completed, FC12 guest works fine without the GuestAdditions. After installing the GuestAdditions the Guest reboots and has an X11 problem, appearing to hang.

I can load the FC12 CD and boot to a rescue shell, edit inittab for init 3 and I get the system back but so far I have been unable to recover X once GuestAdditions has been run.

The procedures I am using worked before the most recent kernel upgrades, so something broke recently. I've got 3 guests and they are all exhibiting the exact same problem (all FC12 guests running on a FC12 host).

I thought I had broken my FC12 guest when I ran the GuestAdditions after a kernel upgrade so I did a complete clean reinstall and got to the same problem a few hours later after the upgrades.

/Len

comment:18 in reply to: ↑ 5 Changed 4 years ago by jorara77

Replying to frank:

Confirmed. The fix can be found in r27248. You can manually apply this fix after you installed the guest additions (but before you rebooted the guest!) by changing /usr/src/vboxvideo-3.1.4/vboxvideo_drm.c in your guest and then re-compile the kernel modules with

/etc/init.d/vboxadd setup

. This fix will be included in the next maintenance release.

I had the exact same problem with a black screen after updating the kernel to 2.6.32.9-70 and the guest additions to 3.1.4. Your instructions on how to change vboxvideo_drm.c did the trick for me on the first attempt. Thanks.

comment:19 Changed 4 years ago by michael

Ticket #6404 has been marked a duplicate of this one.

comment:20 in reply to: ↑ 5 Changed 4 years ago by mbiggerstaff

I can reconfirm this problem with the latest Fedora 12 kernel + updates and I can confirm the fix listed in comment 5. Thanks!

Replying to frank:

Confirmed. The fix can be found in r27248. You can manually apply this fix after you installed the guest additions (but before you rebooted the guest!) by changing /usr/src/vboxvideo-3.1.4/vboxvideo_drm.c in your guest and then re-compile the kernel modules with

/etc/init.d/vboxadd setup

. This fix will be included in the next maintenance release.

comment:21 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.6. philo, if your problem still exists please open another ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use