VirtualBox

Ticket #5838 (reopened defect)

Opened 4 years ago

Last modified 4 years ago

Time runs slow in FreeBSD guests

Reported by: deece Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: BSD
Host type: Solaris

Description

Time runs slow in FreeBSD x64 guests, I am running multiple FreeBSD x64 guests and multiple Windows XP guests on the same host.

Tested with 7-STABLE, 8-RELEASE & 8-STABLE - the problem occurs in all versions.

This problem has been around since at least Virtualbox 2.1 (when I started using it).

I have tried all available timekeeping options in the guest (ACPI-safe, TSC & i8254), but none are accurate.

I did notice that the time was tracked accurately when I brought up a single machine after performing a fresh install of OpenSolaris b129 on the host, however, this was lost as I brought more machines up.

Attachments

VBox.log Download (140.4 KB) - added by deece 4 years ago.

Change History

Changed 4 years ago by deece

comment:1 Changed 4 years ago by bauer40

Did you install the guest additions? They are used to keep the time im sync.

comment:2 Changed 4 years ago by deece

Guest additions are not available for FreeBSD.

comment:3 Changed 4 years ago by deece

I built the guest additions for FreeBSD using  https://svn.bluelife.at/nightlies/blueports-r640.tar.gz (3.1.51r25618) against FreeBSD 8.0-STABLE.

The server is running 3.1.2 on OpenSolaris b130.

I started the guest using the supplied scripts and confirmed that the vboxguest module was loaded.

Unfortunately, the time still runs slowly.

comment:4 Changed 4 years ago by bauer40

Same problem with Debian 5 and the VBox-shipped guest additions.

comment:5 Changed 4 years ago by bauer40

I just found out that the kernel source of my debian systems did not match the installed kernel, thus the vbox kernel modules did not match the kernel.

Currently I recompile the modules and assume everything is well again.

comment:6 follow-up: ↓ 7 Changed 4 years ago by frank

bauer40, there is a known problem with Linux guest additions of VBox 3.1.2. The guest time will be out of sync after some minutes. This will be fixed in VBox 3.1.4. You can apply r25853 to all files time.h in /usr/src/vbox* in your guest. After recompiling the guest modules (/etc/init.d/vboxadd setup) and restarting the guest, the time should be well-synchronized with the host.

comment:7 in reply to: ↑ 6 Changed 4 years ago by bauer40

Replying to frank:

bauer40, there is a known problem with Linux guest additions of VBox 3.1.2. The guest time will be out of sync after some minutes. This will be fixed in VBox 3.1.4. You can apply r25853 to all files time.h in /usr/src/vbox* in your guest. After recompiling the guest modules (/etc/init.d/vboxadd setup) and restarting the guest, the time should be well-synchronized with the host.

That was definetly not enough. I installed this patch on two of the VMs (not all), and I still have a time drift of roughly 15 minutes per 12h.

I installed a cron job running ntpdate every five minutes and wait for the next release of VBox.

comment:8 Changed 4 years ago by frank

Well, if you still observe a time drift with installed guest additions then either you did something wrong when installing the patch or your additions are not active for any reason. You could try installing the additions from VBox 3.1.4 Beta 2 (can be found  here).

comment:9 Changed 4 years ago by deece

Linux digression aside...

The problem still occurs in FreeBSD guests using VBox 3.1.4 on OpenSolaris snv_132 and virtualbox-ose-additions port version 3.1.51r25618.

comment:10 Changed 4 years ago by frank

The additions are too old. There was a fix in r25853 (which is included in VBox 3.1.4 OSE).

comment:11 Changed 4 years ago by deece

Confirmed fixed using FreeBSD 8.0-STABLE from Feb 26th, and virtualbox-ose-additions-3.1.51.r25618_1 from ports, using OpenSolaris snv_133 & VirtualBox 3.1.4 on the host.

Thanks for persevering with this issue.

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

comment:13 Changed 4 years ago by deece

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hmm, looks like I spoke too soon. After configuring a second VM with the updated tools and leaving both running for a day, the time is now lagging by about 6 hours.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use