VirtualBox

Ticket #5686 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

vboxdrv and vboxguest export the same symbols causing conflict on a host that is also used as a guest => Fixed in SVN

Reported by: sethrandall Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords: linux module
Cc: Guest type: other
Host type: other

Description

I run a Ubuntu Linux install as my primary desktop. I also run it as a guest from my Windows partition. When running as a host the install can't load the vboxnetflt module because it tries to load vboxguest as a dependency, but vboxdrv is already loaded with the exported symbols vboxguest tries to register.

Perhaps there should be a separate module that they all rely on called vboxcommon that has the functions that are common to both.

Change History

comment:1 Changed 4 years ago by frank

Confirmed but so far no satisfying resolution in sight.

comment:2 Changed 4 years ago by frank

And, unfortunately your proposal of a separate module does not work because the version of the Guest Additions might be different from the version of VBox you want to install in the guest.

comment:3 Changed 4 years ago by sethrandall

If the versions are different, then you'll still run into the same issue of two modules exporting the same symbols. Either way, it's not going to work. With the common functions in a separate module, they would at least work in one of the situations (and possibly both if the common functions haven't changed).

comment:4 Changed 4 years ago by frank

I already said that the same issue applies even if both module sets (guest and host) are from a different VBox version.

comment:5 Changed 3 years ago by frank

  • Summary changed from vboxdrv and vboxguest export the same symbols causing conflict on a host that is also used as a guest to vboxdrv and vboxguest export the same symbols causing conflict on a host that is also used as a guest => Fixed in SVN

This will be fixed in the next maintenance release.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use