VirtualBox

Ticket #5685 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 months ago

Windows 7 64-bit guest network connectivity issue

Reported by: ulogic Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Running Windows 7 64-bit host with 8GB RAM and Windows 7 64-bit guest with 2GB RAM on an ASRock P45R2000-Wifi motherboard with an E8500 CPU. It has a P45 North Bridge and an ICH10R South Bridge. The Wifi module is not installed. It has dual NICs which are RealTek RTL8111B/RTL811C, one of which is disabled. The guest NIC is a bridged Intel Pro 1000/MT adapter. In VirtualBox 3.1.0, a 64-bit guest does not acquire a DHCP address, but a 32-bit guest will. Using a static IP address doesn't work either. Changing the guest mode to NAT or Host-only Adapter doesn't help either. The host driver for the NIC is provided by Microsoft, so I also tried installing the latest driver from RealTek, but there was no change. If I roll back to 3.0.12 or 3.0.10, the guest acquires a DHCP address and has a default gateway, but still has no connectivity. Even though it has acquired an IP address, I can't even ping the gateway.

A few days ago, I copied the Virtual Disk Image to a portable drive and took it to my home machine which is similar. It has an MSI MS-7519 P45 Neo-F motherboard with a Q9550S CPU with 8GB of RAM, also running Windows 7 64 bit. It has a P45 North Bridge and an ICH10 South Bridge, and also has (a single) Realtek RTL811C NIC. With the same virtual machine settings as my office computer, that configuration runs fine under 3.0.12.

I reinstalled 3.1.0 and now my office computer is acquiring a DHCP address, but still can't ping the default gateway.

I know it doesn't make any sense. Let me know what other information you need.

Attachments

VBox-3.0.12.log Download (54.7 KB) - added by ulogic 4 years ago.
VBox-3.1.0.log Download (62.9 KB) - added by ulogic 4 years ago.

Change History

Changed 4 years ago by ulogic

Changed 4 years ago by ulogic

comment:1 in reply to: ↑ description Changed 4 years ago by ulogic

New information - I set the virtual machine to use a single core running on a dual core host, and now the networking is functioning correctly.

comment:2 Changed 4 years ago by ulogic

I spoke too soon--it still is not working. After some more investigation, it turns out that there was a vestige of COMODO internet security interfering with the TCP/IP stack. It was not available for uninstall, but there were two non plug-and-play drivers associated with COMODO. After removing them via the device manager, it did work correctly. I tried reinstalling COMODO internet security again and the virtual machine froze during installation. This is how the drivers got installed, but because the installation never completed, it did not show up in the uninstall list.

Problem solved.

comment:3 Changed 4 years ago by Technologov

I have opened a related wish #6057

-Technologov

comment:4 Changed 3 years ago by Technologov

Duplicate of bug #2496

-Technologov

comment:5 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use