VirtualBox

Ticket #5659 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Windows (XP, 7) hosts: Menus do not appear if main window uses OpenGL -> Fixed in SVN

Reported by: marciano Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.0 Keywords: opengl
Cc: Guest type: Windows
Host type: Mac OS X

Description

I noticed a regression in OpenGL support going from 3.0.12 to 3.1.0. The Sublime Text editor:

www.sublimetext.com

uses either DirectX or OpenGL for rendering. Up until 3.0.12, despite some (significant but tolerable) visual flaws and general slowness, it was usable. The main problem was that, when switching to a different open program via ALT-TAB, the content of the main OpenGL widget ? (where the edited text is displayed) did not go to the background; however, moving the other program's window with the mouse resolved the problem. Again, not ideal, but workable in the short run.

Unfortunately, beginning with 3.1.0, there is a more serious issue. The menus in Sublime Text are no longer displayed. I think that, for some reason, the menu gets displayed "below" the main OpenGL widget, so it is never visible, except for a couple lines (of pixels, not text!) right below the menu bar.

This is on both Win7 and WinXP guests, on a Mac OSX host running Snow Leopard 10.6.2. The version of Sublime Text does not seem to matter, i.e. this is not a bug introduced by Sublime Text (the exact same versions I tried did not have the menu problem in VBox 3.0.12). Also, I did install the 3.1.0 vbox extensions.

Change History

comment:1 Changed 4 years ago by marciano

I can unfortunately confirm that the bug persists in 3.1.4. Any ideas?

comment:2 Changed 4 years ago by leonid

  • Summary changed from Windows (XP, 7) hosts: Menus do not appear if main window uses OpenGL to Windows (XP, 7) hosts: Menus do not appear if main window uses OpenGL -> Fixed in SVN

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use