VirtualBox

Opened 14 years ago

Closed 12 years ago

#5625 closed defect (fixed)

linux kernel oops with vbox 3.1.0 (3.0.12 regression?)

Reported by: jhw Owned by:
Component: other Version: VirtualBox 3.1.0
Keywords: linux NULL pointer Cc:
Guest type: Windows Host type: Linux

Description (last modified by Frank Mehnert)

vbox 3.1.0 for windows guest on linux host dies due to kernel oops while starting windows. vm worked ok with vbox 3.0.10. BUG: unable to handle kernel NULL pointer dereference at 00000410

Attachments (13)

vbox.log (6.8 KB ) - added by jhw 14 years ago.
oops
VBox.log (41.5 KB ) - added by jhw 14 years ago.
vbox log
dmesg (51.7 KB ) - added by jhw 14 years ago.
requested complete kernel log up to vbox failure
VBox.2.log (41.2 KB ) - added by jhw 14 years ago.
latest VBox.log with 3.1.6
VBox.3.2.2.log (45.8 KB ) - added by jhw 14 years ago.
VBox.log with 3.2.2
oops.3.2.2 (3.0 KB ) - added by jhw 14 years ago.
oops with 3.2.2
dmesg.3.2.2 (42.7 KB ) - added by jhw 14 years ago.
dmesg with 3.2.2
config-2.6.33.5-rt22-1jhw (91.7 KB ) - added by jhw 14 years ago.
kernel config for 2.6.33.5-rt22
VBox.log.3.2.10 (46.7 KB ) - added by jhw 14 years ago.
oops.3.2.10 (4.8 KB ) - added by jhw 14 years ago.
dmesg.3.2.10 (42.4 KB ) - added by jhw 14 years ago.
VBoxSysInfo.list.3.2.10 (160 bytes ) - added by jhw 14 years ago.
config-2.6.36-tmb-desktop-2mdv (119.6 KB ) - added by jhw 14 years ago.

Download all attachments as: .zip

Change History (31)

comment:1 by Technologov, 14 years ago

Please re-upload oops and vbox.log over here.

-Technologov

by jhw, 14 years ago

Attachment: vbox.log added

oops

by jhw, 14 years ago

Attachment: VBox.log added

vbox log

comment:2 by Jaap Dijkshoorn, 14 years ago

I had the same issue with a linux guest on a linux host. As soon as i put a lot of load on the network for example rsync of a filesystem, the kernel of the guest does an oops and dies.

comment:3 by Jaap Dijkshoorn, 14 years ago

some logs:

Dec  2 10:28:40 mapserver kernel: Oops: 0000 [#1] SMP 
Dec  2 10:28:40 mapserver kernel: last sysfs file: /sys/class/net/lo/operstate
Dec  2 10:28:40 mapserver kernel: CPU 2 
Dec  2 10:28:40 mapserver kernel: Modules linked in: autofs4 fuse dm_snapshot dm_mirror dm_region_hash dm_log dm_mod mptctl rdma_ucm rdma_cm iw_cm ib_addr ib_ipoib ib_ucm ib_cm ib_sa ib_uverbs ib_umad mlx4_ib mlx4_core ib_mad ib_core ohci_hcd ehci_hcd e1000 sg sr_mod cdrom [last unloaded: ipmi_msghandler]
Dec  2 10:28:40 mapserver kernel: Pid: 4414, comm: sshd Not tainted 2.6.31.5-sara #1 VirtualBox
Dec  2 10:28:40 mapserver kernel: RIP: 0010:[<ffffffff8102fc8c>]  [<ffffffff8102fc8c>] __wake_up_common+0x2c/0x90
Dec  2 10:28:40 mapserver kernel: RSP: 0018:ffff880115545c98  EFLAGS: 00010006
Dec  2 10:28:40 mapserver kernel: RAX: ffff880115557be0 RBX: 0000000000000286 RCX: 0000000000000001
Dec  2 10:28:40 mapserver kernel: RDX: 0000000000000001 RSI: 0000000000000001 RDI: ffff88011e436000
Dec  2 10:28:40 mapserver kernel: RBP: ffff880115545cc8 R08: ffff880115557bc8 R09: ffff88011dda0cc0
Dec  2 10:28:40 mapserver kernel: R10: 0000000000000000 R11: 0000000000000001 R12: ffff88011e436000
Dec  2 10:28:40 mapserver kernel: R13: 0000000000000001 R14: ffff88011e436008 R15: 0000000000000000
Dec  2 10:28:40 mapserver kernel: FS:  00007f71f57a9790(0000) GS:ffff880028055000(0000) knlGS:0000000000000000
Dec  2 10:28:40 mapserver kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Dec  2 10:28:40 mapserver kernel: CR2: ffff880115557be0 CR3: 00000001154dc000 CR4: 00000000000006e0
Dec  2 10:28:40 mapserver kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Dec  2 10:28:40 mapserver kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Dec  2 10:28:40 mapserver kernel: Process sshd (pid: 4414, threadinfo ffff880115544000, task ffff88011f060cd0)
Dec  2 10:28:40 mapserver kernel: Stack:
Dec  2 10:28:40 mapserver kernel: 0000000100000001 0000000000000286 ffff88011e436000 0000000000000001
Dec  2 10:28:40 mapserver kernel: <0> 0000000000000000 0000000000000001 ffff880115545d08 ffffffff8103287e
Dec  2 10:28:40 mapserver kernel: <0> ffff880115545d08 0000000000000001 0000000000000001 ffff88011e436000
Dec  2 10:28:40 mapserver kernel: Call Trace:
Dec  2 10:28:40 mapserver kernel: [<ffffffff8103287e>] __wake_up_sync_key+0x4e/0x70
Dec  2 10:28:40 mapserver kernel: [<ffffffff810328ab>] __wake_up_sync+0xb/0x10
Dec  2 10:28:40 mapserver kernel: [<ffffffff810d5bbb>] pipe_write+0x4bb/0x620
Dec  2 10:28:40 mapserver kernel: [<ffffffff810de678>] ? core_sys_select+0x208/0x2e0
Dec  2 10:28:40 mapserver kernel: [<ffffffff810cd961>] do_sync_write+0xf1/0x140
Dec  2 10:28:40 mapserver kernel: [<ffffffff810595c0>] ? autoremove_wake_function+0x0/0x40
Dec  2 10:28:40 mapserver kernel: [<ffffffff813ccf77>] ? thread_return+0x3e/0x667
Dec  2 10:28:40 mapserver kernel: [<ffffffff810ce46b>] vfs_write+0xcb/0x180
Dec  2 10:28:40 mapserver kernel: [<ffffffff810ce610>] sys_write+0x50/0x90
Dec  2 10:28:40 mapserver kernel: [<ffffffff8100bdab>] system_call_fastpath+0x16/0x1b
Dec  2 10:28:40 mapserver kernel: Code: 48 89 e5 41 57 4d 89 c7 41 56 4c 8d 77 08 41 55 41 89 d5 41 54 53 48 83 ec 08 89 75 d4 89 4d d0 48 8b 47 08 4c 8d 40 e8 49 39 c6 <49> 8b 50 18 74 45 48 8d 5a e8 eb 0f 0f 1f 84 00 00 00 00 00 49 
Dec  2 10:28:40 mapserver kernel: RIP  [<ffffffff8102fc8c>] __wake_up_common+0x2c/0x90
Dec  2 10:28:40 mapserver kernel: RSP <ffff880115545c98>
Dec  2 10:28:40 mapserver kernel: CR2: ffff880115557be0
Dec  2 10:28:40 mapserver kernel: ---[ end trace fe420dcc4f7f233e ]---

comment:4 by kev, 14 years ago

I'm also seeing the same. Host OS is openSuSE 11.2 (64-bit), Guest OS is Windows XP. This VM worked on VirtualBox 3.0.10, but didn't work with 3.0.12

uname -a: Linux kj-desktop 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux rpm -qa|grep VirtualBox: VirtualBox-3.1-3.1.0_55467_openSUSE111-1.x86_64

comment:5 by jhw, 14 years ago

same problem in vbox 3.1.2

comment:6 by Frank Mehnert, 14 years ago

Summary: linux kernel oops with vbox 3.1.0linux kernel oops with vbox 3.1.0 (3.0.12 regression?)

comment:7 by Frank Mehnert, 14 years ago

Any change with VBox 3.1.6? Actually these kernel oopses are not really related. If you can reproduce such a host kernel oops with VBox 3.1.6 then please attach the whole host kernel log.

comment:8 by jhw, 14 years ago

problem still occurs with 3.1.4 & 3.1.6; it also occurred with 3.0.12; the latest version in which it did not occur was 3.0.10

by jhw, 14 years ago

Attachment: dmesg added

requested complete kernel log up to vbox failure

by jhw, 14 years ago

Attachment: VBox.2.log added

latest VBox.log with 3.1.6

comment:9 by Technologov, 14 years ago

You running Mandriva Linux 2010 32-bit host ?

I have Mandriva Linux 2010 64-bit host + VBox 3.2.0, and all is great.

-Technologov

comment:10 by jhw, 14 years ago

problem still occurs with vbox 3.2.2 on kernel 2.6.33.5-rt22 ( 32 bit machine )

by jhw, 14 years ago

Attachment: VBox.3.2.2.log added

VBox.log with 3.2.2

by jhw, 14 years ago

Attachment: oops.3.2.2 added

oops with 3.2.2

by jhw, 14 years ago

Attachment: dmesg.3.2.2 added

dmesg with 3.2.2

comment:11 by Frank Mehnert, 14 years ago

Please could you attach your host kernel config? Does the host kernel crash as well if you start the guest with NAT?

by jhw, 14 years ago

Attachment: config-2.6.33.5-rt22-1jhw added

kernel config for 2.6.33.5-rt22

comment:12 by jhw, 14 years ago

i have never used NAT: i use only static ip addresses in my LAN: it makes managing firewalls and communication among the various hosts easier if they have definite addresses

by jhw, 14 years ago

Attachment: VBox.log.3.2.10 added

by jhw, 14 years ago

Attachment: oops.3.2.10 added

by jhw, 14 years ago

Attachment: dmesg.3.2.10 added

by jhw, 14 years ago

Attachment: VBoxSysInfo.list.3.2.10 added

comment:13 by jhw, 14 years ago

problem still occurs with VBox 3.2.10 & kernel 2.6.36 ( from Mandriva ); since bitrot has affected 3.0.10, it fails to compile with 2.6.36, so i no longer have a usable version of VBox

comment:14 by Frank Mehnert, 14 years ago

Is this a self-compiled kernel or do you use a self-compiled kernel?

comment:15 by jhw, 14 years ago

the latest kernel is from mandriva: kernel-tmb-desktop-2.6.36-2mdv-1-1mdv2011.0.i586.rpm, kernel-tmb-desktop-devel-2.6.36-2mdv-1-1mdv2011.0.i586.rpm; i compile the vbox modules ( dkms ): gcc-4.5.1-1mnb2.i586.rpm, etc

comment:16 by Frank Mehnert, 13 years ago

Still relevant with VBox 4.0.12?

comment:17 by jhw, 13 years ago

problem still occurs with vbox 4.1.0 on kernel 2.6.38.8-tmb-desktop-1.mga2 #1 SMP PREEMPT Mon Jun 20 11:06:38 UTC 2011 i686 i686 i386 GNU/Linux ( from Mageia ); testing is a nuisance because after the oops, the vboxdrv module is left holding onto something, and cant be removed without causing a panic; leaving it causes a panic on shutdown

comment:18 by Frank Mehnert, 12 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use