VirtualBox

Ticket #5620 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

new version slow and crashing

Reported by: joy Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Using VirtualBox since version 2.x and I am happy with that most of the time, thanks. Version 3.0.8 was the first one that allowed running SMP (dual CPU) guest (WinXP 32bit on AMD 64bit Ubuntu Karmic Koala host) stable enough (previous versions were BSODing randomly) although the graphics performance was about 50% of single CPU guest. Version 3.0.12 increased 2D graphics performance so it was only about 30% slower than single CPU guest (still weird that it's slower than single CPU guest but I could live with that).

Version 3.1.0 is WAY SLOWER in graphics performance compared to even 3.0.8 (and far far slower than 3.0.12), contrary to enabled 2D graphics acceleration. Worse is that WinXP keeps crashing during boot to BSOD roughly four times from five runs. It's unusable. I am going to downgrade now hoping that it's possible (given that I already installed 3.1.0 host tools in WinXP).

Attaching some logs, maybe you'll find them useful.

Attachments

3.1.0crashing Download (44.1 KB) - added by joy 4 years ago.
some logs of 3.0.10, 3.0.12 and 3.1.0
BenchmarkResults.htm Download (14.6 KB) - added by joy 4 years ago.
benchmark of 3.0.10 (both single and dual CPU) and 3.1.0

Change History

Changed 4 years ago by joy

some logs of 3.0.10, 3.0.12 and 3.1.0

comment:1 Changed 4 years ago by frank

Well, if 2D is slow, did you try to disable the 2D/3D acceleration in the VM settings?

Changed 4 years ago by joy

benchmark of 3.0.10 (both single and dual CPU) and 3.1.0

comment:2 Changed 4 years ago by joy

yes, tried enabling and disabling that, no apparent change (maybe it's crashing less with 3D disabled). The BenchmarkResults.htm (just attached) has been run with 2D acceleration enabled (and 3D disabled). It's so much slower, see for yourself.

comment:3 Changed 4 years ago by joy

I have just rerun the benchmark with 2D acceleration disabled and the results were roughly the same as with 2D accel. enabled.

comment:4 Changed 4 years ago by joy

great, after downgrading to 3.0.12 it behaves the same slow way. So either the guest is corrupted somehow or the host has changed during recent 2.6.31-14 to 2.6.31-15 kernel security update (that happened just before upgrading the VirtualBox).

I don't have any VDI backup prior to 3.1.0 upgrade so I am lost.

comment:5 Changed 4 years ago by sandervl73

Looks like a duplicate of #5501

comment:6 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

comment:7 Changed 4 years ago by frank

joy, please go to #6250 and do the fix which is proposed there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use