VirtualBox

Ticket #5522 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Windows XP hangs during booting via grub from virtual SATA disk with VT-x

Reported by: geep Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Guest: Windows XP2b slipstreamed with SATA drivers on Virtual SATA(AHCI) SATA Port 0 booting via grub 0.97 Host: Slackware 12.2, Intel Core2Duo Duo CPU E6550, Kernel 2.6.27.7-smp

My problem is a bit similar to Ticket #5504, but I am using a single SATA virtual disk with several partitions.

My guest installation is:

Dual-boot Windows XP2b and Linux Slackware-Current. ACPI - Yes, IO APIC - No, 1 CPU, PAE/NX - No, Nested Paging - No. 3D Acceleration - No

Linux works fine.

But when I boot XP via grub, then XP crashes with VT-x/AMD-V enabled. The point at which it crashed varies a bit. Sometimes it starts and crashes with the VirtualBox "Critical Error" popup. Sometimes it starts, some Windows blue screen messages flash past and I get the choice to reboot to safe mode. Rebooting to safe mode it sometimes crashes just after listing ....\Drivers\Mup.sys

If I disable VT-x/AMD-V then XP boots via grub and runs fine.

I can disable booting via grub by using the Windows Recovery Console and the commands FIXBOOT FIXMBR Then the XP installation boots and runs fine with or without VT-x/AMD-V enabled.

Re-enabling booting via grub and the problem returns.

Cheers, Peter

Disk configuration:

/dev/sda1 NTFS XP 10Gb
/dev/sda5 NTFS Data 10Gb
/dev/sda6 Reiserfs /boot/grub 100Mb
/dev/sda7 Linux Swap 250Mb
/dev/sda8 Reiserfs Slackware 10Gb

grub's menu.lst:

# general configuration:
timeout  30
default   0
fallback  1
#color     light-gray/blue  red/light-gray

# boot stanzas follow
# each is implicitly numbered from 0
# in the order of appearance below

# (0) Windows (default boot):
title Microsoft Windows XP                    /dev/sda1
rootnoverify  (hd0,0)
makeactive
chainloader +1

#++++++++++++++++++++++++++++++++++Ruler++++++++++++++++++++++++++++++++++#
# (1) sda8 (hd0,7)
title Slackware Current                       /dev/sda8
root   (hd0,7)
kernel /boot/vmlinuz root=/dev/sda8 ro vga=788

grub setup commands:
# grub> device (hd0) /dev/sda
# grub> root (hd0,5)
# grub> setup (hd0)
# grub> quit

Attachments

VBox.png.crash.1.png Download (1.6 KB) - added by geep 4 years ago.
VBox.log.crash.1 Download (154.6 KB) - added by geep 4 years ago.
VBoxTestWin7withXPandLinux.xml Download (3.9 KB) - added by geep 4 years ago.
winxp_02.xml Download (3.5 KB) - added by larytet 4 years ago.
larytet vm

Change History

Changed 4 years ago by geep

Changed 4 years ago by geep

Changed 4 years ago by geep

comment:1 Changed 4 years ago by larytet

I confirm the problem for Ubuntu host/WinXP guest. My boot is Grub (Ubuntu)

Scenario: I have a dual boot machine. I am running WinXP under VM directly from the partition where the WinXP installed. For some period of time I executed the VM without hardware acceleration. The acceleration (in my case Intel VT-x) was disabled in BIOS.

I enabled the acceleration in BIOS, enabled acceleration in VM and tried to fire up the VM. Windows boot hangs in Mup.sys. When I disable acceleration WinXP boots well.

I did not try to replace Grub.

Changed 4 years ago by larytet

larytet vm

comment:2 Changed 4 years ago by larytet

more details. I tried VMWare and WinXP boots just fine under VMWare. The boot is rather quick and I think that VMWare employs VT-x

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use