VirtualBox

Ticket #5504 (closed defect: obsolete)

Opened 4 years ago

Last modified 5 months ago

Windows XP hangs during booting from real HD with VT-x (SATA)

Reported by: firehead Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Guest: Windows XP, x32, SP3
Host: Ubuntu 9.10, x32, Intel Core2Duo CPU, SATA HDD.

I am using my Windows XP OS, which is installed on _real_ HD parition, as guest OS from Ubuntu. But guest OS will hang during booting if VT-x option is enabled. And at the same time it will boot perfectly if i disable this option. Guest will hang just after selecting Windows from GRUB menu. This issue is reproduced in the latest version of VirtualBox (3.0.12) and i also saw it in 3.0.10 version.

NB: if i try to boot Windows XP from virtual disk, everything will be fine. I am just interesting what is wrong in booting from _real_ HD, i.e. why enabling of VT-x causes freezing of guest!

Attachments

VBox.log Download (40.3 KB) - added by firehead 4 years ago.
WinXP.xml Download (8.3 KB) - added by firehead 4 years ago.
Guest configuration
WinXP-HD.vmdk Download (628 bytes) - added by firehead 4 years ago.
screen.jpg Download (135.5 KB) - added by firehead 4 years ago.
screenshot
Windows XP-2010-01-08-02-56-16.log Download (59.3 KB) - added by Passe 4 years ago.

Change History

Changed 4 years ago by firehead

Changed 4 years ago by firehead

Guest configuration

Changed 4 years ago by firehead

Changed 4 years ago by firehead

screenshot

comment:1 in reply to: ↑ description Changed 4 years ago by Passe

I experience the same behaviour as you in more or less the same setup. I'm using VBOX 3.1.2-56127-Linux_x86 on a core 2 duo VT-x capable.

If VT-x set to "off" but IO APIC to "on" it will boot. Mine will never boot if IO APIC is not set to on, but it is another known problem.

When setting VT-x to "on" (with IO APIC "on") the Windows XP SP3 guest hangs just after loading various drivers, it can be seen when booting in Safe Mode.

I also attached my vbox.log. I also have to say that I use a SATA controller in the VB configuration.

If a developer can give any comments on this issue...

Changed 4 years ago by Passe

comment:2 Changed 4 years ago by sandervl73

  • Component changed from other to VMM/HWACCM
  • Summary changed from Windows XP hangs during booting from real HD with VT-x to Windows XP hangs during booting from real HD with VT-x (SATA)

comment:3 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use