VirtualBox

Ticket #5463 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Audio input is choppy on Windows XP guest on Ubuntu 9.10 64 bit host.

Reported by: martinpisz Owned by:
Priority: major Component: audio
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I installed a windows XP SP3 guest inside virtualbox insde Ubuntu 9.10 64 bit hostrunning on X48 intel chipset on Q9450 cpu. Everything seems to work fine except whne I use the sound recorder it records choppy sound in Windows XP. I am trying to run Dragon naturally speaking 10.1 and it says that audio quality is too low. Dragon works in Vista on same mahcine dual boot and it works partially in wine on the Ubuntu 9.10. The audio and recoginition part work, It seems the problem is with choppy sound inside virtual box as sound recorder records choppy sound whne I play it back. Ubuntu is using pulseaudio and virtual box is setup to use it as well. Output playback does seem to work, its the microsphone which is not of the usb type that the virtual machine has porblems recordeding. Audio input is choppy. I have attached the recordeed sound file.

Attachments

sound recording.wav Download (75.4 KB) - added by martinpisz 4 years ago.
Sound file recorded to show how choppy it is.

Change History

Changed 4 years ago by martinpisz

Sound file recorded to show how choppy it is.

comment:1 Changed 4 years ago by crimsonflame123

I was just going through the open bugs in VB. This one is a duplicate of  http://www.virtualbox.org/ticket/215 ... Now that ticket #215 is fixed in SVN, this can be closed or DUPed.

comment:2 Changed 4 years ago by lori.sparks

I don't believe that ticket #215 covers this bug. It's still a problem. I am using Dragon v10 on a WinXP guest with a Win7 host. I can get Dragon (and even just the simple Windows sound recorder) to work with a microphone that is connected using the mic in jack. However, using a bluetooth headset (with a USB adapter and the appropriate USB filters set for the VM), I experience a similar choppy quality on record and playback (again, both using the bluetooth headset). The sound, for me, is akin to playing streaming media over a dial-up connection or audio clipping.

The fix for me has obviously been to use a microphone that isn't USB/bluetooth (not sure which is the problem for virtualbox).

VirtualBox is a wonderful application. I've used it quite a bit to create testbeds to evaluate software. The issues I've had with VirtualBox are few and minor. But this still seems like a valid bug worth looking into. Thanks!

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 3.2.10 please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use