VirtualBox

Ticket #215 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Can not record audio

Reported by: xerces8 Owned by:
Priority: major Component: audio
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

vbox 1.3.8 on Windows 2000 pro SP4

When I start a VM :

  • I can not record sound in the host, for example Windows Sound Recorder gives an error, that the sound format is not supported (if no VM is running, the this works)
  • In the guest (Windows 2003), no sound can be recorded. There is no error, but only silence is recorded.

The VM has audio activated and the type is Windows DirectSound.

I also tried another PC with Windows XP Pro SP2, vbox 1.3.8. There only the second problem is present.

Change History

comment:1 Changed 7 years ago by Technologov

The second problem is easily explainable:

VirtualBox emulates only sound output (what most users do), not what rare users do.

Rare uses include: using many sound cards simulataneously, 8:1 surround, audio input, ... VBox cannot handle all the possible rare uses.

The first thing must be seen more deeply: What version of DirectX you use on your host systems ? (do start->run->dxdiag to know)

-Alexey

comment:2 Changed 7 years ago by xerces8

Both hosts have DirectX 9.0c

I did not know, that sound input is not supported. If this is so, why is there an emulated input ? That is confusing. I mean, it does not do anything anyway...

comment:3 Changed 7 years ago by xerces8

Strange, the GUI Settings shows "Windows DirectSound", but in the VM XML file it is :

<AudioAdapter driver="winmm" enabled="true"/>

I also saw the "Audio: set_record_source ars=0 als=0 (not implemented)" lines in the log.

I suggest popping up a warning the first time audio recording is tried by the user, which then he can disable, just like the keyboard and mouse warnings.

comment:4 Changed 7 years ago by frank

Actually sound input is supported but rarely tested. Regarding dsound/winmm: Please try to disable, then save, then enable the windows sound device setting. 1.3.8 should definitely should dsound. And even if winmm was shown for previous version the internal dsound engine was used.

comment:5 Changed 7 years ago by xerces8

I tried that and now in the XML file it is "dsound", but still both problems persist. This is on my Windows 2000 host.

comment:6 Changed 7 years ago by peremen

Sound input works flawlessly on Linux host with ALSA driver. When I fired up Google talk on Windows guest on Linux host with VirtualBox 1.4.0, I can listen other's voice and vice versa. Maybe that looks like Windows host only problem.

comment:7 Changed 6 years ago by frank

  • Component changed from other to audio

comment:8 Changed 5 years ago by balaji

Can someone confirm if any changes have been made to sound recording. The last I see here is that someone has got sound recording working flawlessly on a Linux host with ALSA driver. Is this only with ALSA. What happens with PulseAudio and what is the status now for Mac users?

I am planning on moving to Ubuntu Linux fully and the only reason I am considering removing Microsoft Windows altogether is that virtualization can bridge the little gaps that Google has left out in their computing - google talk namely. Google talk works only for Windows, so I want to virtualize Windows through a Linux host and use Google talk. Can peremen and other Virtualbox users confirm that this is true please? If yes, how can this be done? I have a Mac book too and on that virtualization did not allow sound recording. How do I do this?

comment:9 Changed 5 years ago by frank

No changes were applied to ALSA since some month. In general, PulseAudio is the preferred audio backend as the modern Linux distributions use PulseAudio as their standard sound system.

Regarding Linux on Mac OS X: Other users please.

comment:10 Changed 5 years ago by poetzsch

Sound recording isn't possible on the Mac OS X port yet.

comment:11 Changed 5 years ago by balaji

The confirmation is not very clear. Is sound recording working in a Windows guest running on Linux through VirtualBox? If yes, this is a major breakthrough and I don't see any reason why I should not use this feature and completely remove any Windows partitions from my machine. Can someone please confirm that sound recording does work for a Windows guest running on a Linux host? Also, what needs to be done for this to occur? Do we need to install any particular thing?

comment:12 Changed 5 years ago by talaos

This report needs some cleanup.

  1. xerces8, are you still reading this?
  2. In VirtualBox 2.x, it appears that audio input/recording does not work when you select PulseAudio in the Virtual machine settings.

However, if you select 'Alsa', then it works. There might be some issues with audio input quality, but the important issue is it works.

What I suggest is to change the report by

  1. add 'Pulseaudio' in the title.
  2. Mention WindowsXP as the Host (it's WinXP we all talk about, isn't it?)

comment:13 Changed 5 years ago by balaji

Yes, it's mostly a WinXP guest on Linux host. I don't know about others, but in both the laptops I have used, VirtualBox with ALSA player worked flawlessly. As you say PulseAudio does not work. Both laptops are from HP. One has an AMD X2 and the other is Intel Centrino.

This is on Ubuntu Intrepid Ibex (I have used both the release kernel and the new 2.6.27-8) I think this holds for both 2.0.4 and 2.0.6, though I have not yet tested PulseAudio with 2.0.6.

comment:14 Changed 5 years ago by rcrath

I am running virtualbox 2.1.2 on an xp SP3 host with an ubuntu studio 8.1 on a lenovo r61 (intel)laptop.

I have the same trouble described in the initial post but with a different host/guest combo. I can play back sound fine in host and guest using OSS as the driver in ubuntu. ALSA does not work. I can record using the sound recorder in windows (host) no problem, but when I try to record in Audacity in ubuntu, it does not record. There is no error message, just no signal getting in to the computer. Does this mean that the hardware emulation still does not support audio input? That seems kind of basic rather than a "rare" use.

comment:15 Changed 5 years ago by bvidinli

I have same problem:

Using on Ubuntu Linux 9.04 host, Windows xp guest,

audio input not working, I cannot record sound inside windows, or cannot use my microphone...

Using on Virtualbox 3.0 beta 2 I installed on Ubuntu using deb package of beta 2

comment:16 Changed 5 years ago by bvidinli

normally, sound on host of Ubuntu working,

comment:17 Changed 5 years ago by crimsonflame123

Facing exactly the same problem on a Fedora 11 with VB 3.0.6.

Host uses pulseaudio and the recording works fine there.

Guest(WinXP) is configured with ICH AC97 controller for audio.

comment:18 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The original report was about a Windows 2000 host which isn't supported anymore. There is another ticket for Linux/PulseAudio and there will be a fix for recording in VBox 3.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use