VirtualBox

Ticket #5345 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Cannot activate USB-Printer with VirtualBox 3.0.8 and 3.0.10 -> fixed as of 2010.11.29

Reported by: chessweb Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I cannot activate my USB Printer since the corresponding control (Devices -> USB Devices) is greyed out. USB stick and USB scanner are not affected and work normally.

VirtualBox 3.0.8 and 3.0.10 Host: Ubuntu 9.10 Guest: Windows XP

Regards, Ralf

Change History

comment:1 follow-up: ↓ 9 Changed 4 years ago by michael

Make sure that your user is in the "vboxusers" group. You need to log out and back in again for this to take effect. If in doubt, reboot.

comment:2 Changed 4 years ago by alizard

I have the same problem under the same circumstances. (XP guest, Kubuntu Karmic host, a virtualbox just upgraded by repository) Printing worked just fine before I upgraded to Kubuntu 9.10.

I am indeed a member of vboxusers, the original poster I can't speak for.

A.Lizard

comment:3 Changed 4 years ago by siegie

I have exactly the same problem. I can connect to other usb devices like external hard drives, smart card reader. But my printer samsung ml-1640 is grayed out.

I've also tested on a clean install off ubuntu.

comment:4 Changed 4 years ago by fcojbb

I had the same problem, I'm in the vboxusers group and the problem continues. I've tried the older methods but the problem continues.

My usb printer is a Brother HL-2140. And my distribution is Ubuntu 9.10.

Regards,

fcojbb

comment:5 Changed 4 years ago by ASKer

You should add your user in "lp" group. Device /dev/usb/lpX has owner "root" and group "lp", so to grant access you should be either root, or in "lp" group. Remember, that you need to relogin, after adding yourself in group.

So, it's not virtualbox issue.

Sorry for my English.

comment:6 Changed 4 years ago by siegie

Thanks this was the solution. I didn't believe it first, because i thought, if one usb device work they should all work.

Again thanks.

comment:7 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

comment:8 Changed 4 years ago by michael

FYI, our way of managing USB device permissions on Linux is currently not optimal, and liable to break in ways like this. We are trying to get in touch with the Ubuntu and other distribution people to work out a better way in cooperation with the distributions.

comment:9 in reply to: ↑ 1 Changed 4 years ago by alizard

The fix works for me, too. I recommend adding "add user to lp" to the help documentation next to where "add user to vboxusers" already is.

comment:10 Changed 4 years ago by markus_ba

  • Status changed from closed to reopened
  • Resolution invalid deleted

I ran into the same problem. This should be documented in the Users Guide chapter 11.5.7 'USB not working'. That's where you end up if you have the problem.

comment:11 Changed 3 years ago by michael

  • Summary changed from Cannot activate USB-Printer with VirtualBox 3.0.8 and 3.0.10 to Cannot activate USB-Printer with VirtualBox 3.0.8 and 3.0.10 -> fixed as of 2010.11.29

We have switched to a less invasive way of handling USB device permissions in the development code. See ticket #7759 for the gory details. The fix will not be backported to the 3.2 series though.

comment:12 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should be fixed in 4.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use