VirtualBox

Ticket #5168 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Virtual Box 3.0.8 (Mac) Aborts after about 4 hours of working with OpenSolaris 2009.06 -> fixed in SVN/3.0.10

Reported by: constantin Owned by:
Priority: critical Component: VMM
Version: VirtualBox 3.0.8 Keywords: crash, abort
Cc: Guest type: Solaris
Host type: Mac OS X

Description (last modified by frank) (diff)

I use OpenSolaris 2009.06 running on Mac OS X 10.5.8 as my regular work environment.

With versions 3.0.6, I've been seeing regular Virtual Machine aborts about one or two times a day. I hoped this would go away with 3.0.8, but after upgrading today, I experienced another abort.

Here are the symptoms.

  • Everything works great for a couple of hours (4 hours in the last case).
  • All of a sudden, the VM freezes, I see the Mac OS X beachball, the VM screen vanishes and VirtualBox shows the machine to be in "Aborted" stage.
  • I don't see any errors in the log (my latest log file is attched).
  • When restarting the machine, there's about a 30% chance that the restarting process freezes and I need to Force Quit Virtual Box.

This seems to hurt the rest of OS X: I can't regularly "Quit" other apps, but must resort to "Force Quit" them. Only a restart fixes this issue and after a restart I can also restart my VM.

  • In the other, more lucky cases, the machine just starts from scratch and I can work again for about 4-5 hours.

Attachments

VBox.log Download (50.8 KB) - added by constantin 5 years ago.
VBox.2.log Download (52.1 KB) - added by constantin 5 years ago.
New VBox log file
VirtualBoxVM_2009-10-08-173208_Constantins-Mac.crash Download (43.1 KB) - added by constantin 5 years ago.
Example Crash report from the described VBox crash on Mac OS X Leopard (10.5)
VirtualBoxVM_2009-10-12-111648_localhost.crash Download (45.0 KB) - added by constantin 5 years ago.
Example Crash report from the described VBox crash on Mac OS X Snow Leopard (10.6)
VirtualBoxVM_2009-10-12-135507_localhost.crash Download (52.2 KB) - added by constantin 5 years ago.
Example Crash report from the described VBox crash on Mac OS X Snow Leopard (10.6), this is the instance with the memory alloc problems.

Change History

Changed 5 years ago by constantin

comment:1 Changed 5 years ago by sandervl73

  • Description modified (diff)

comment:2 Changed 5 years ago by sandervl73

  • Description modified (diff)

comment:3 Changed 5 years ago by frank

  • Description modified (diff)

comment:4 Changed 5 years ago by frank

Your VM seems to crash. Is there any crash report available?

comment:5 Changed 5 years ago by constantin

I haven't seen any crash reports in the VirtualBox folder in Libraries. Where else can I look for a crash report?

comment:6 Changed 5 years ago by andy.hall@…

On the Mac, crash reports live in /Library/logs/CrashReporter and have a name that indicates date/time/process.

Changed 5 years ago by constantin

New VBox log file

comment:7 Changed 5 years ago by constantin

I've upgraded the system to Mac OS X Snow Leopard. The crashes are now more often: About once per hour :(.

I've attached a new VBox log file. It shows memory allocation problems. This time, VBox didn't crash hard, but suspended the machine and showed a white window with white letters. Unreadable. But it wrote about memory allocation issues in the log file, which is now attached.

My machine has 4GB of physical RAM and my Opensolaris instance was configured with 2GB. I only had Safari, Adium, Tweetie and Colloquium (IRC client) running, so no possibility of having any real memory problems (I usually have also iTunes and other stuff running and never saw memory problems before).

This is all starting to look like a memory leak to me, but I'm not a VBox programmer.

Changed 5 years ago by constantin

Example Crash report from the described VBox crash on Mac OS X Leopard (10.5)

Changed 5 years ago by constantin

Example Crash report from the described VBox crash on Mac OS X Snow Leopard (10.6)

comment:8 Changed 5 years ago by constantin

Thanks for the pointer to the crash reports. I found lots of them there :). I've attached a crash report from a typical crash of the described nature under Mac OS X 10.5 (Leopard) and another under Mac OS X 10.6 (Snow Leo). The crashed under Snow Leo are more often (about 1 per hour).

The memory allocation problem described above only happened once and doesn't seem related to the other problems, but I'll attach the crash report from that as well.

Changed 5 years ago by constantin

Example Crash report from the described VBox crash on Mac OS X Snow Leopard (10.6), this is the instance with the memory alloc problems.

comment:9 Changed 5 years ago by constantin

Just to provide another data point: Just tried running without VT-X but the VM still crashed after about an hour. So it doesn't seem to be related to VT-X code.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5084.

comment:11 Changed 5 years ago by sandervl73

  • Summary changed from Virtual Box 3.0.8 (Mac) Aborts after about 4 hours of working with OpenSolaris 2009.06 to Virtual Box 3.0.8 (Mac) Aborts after about 4 hours of working with OpenSolaris 2009.06 -> fixed in SVN/3.0.10
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use