VirtualBox

Ticket #5084 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VBox on Mac OSX Snow Leopard regularly crashes -> fixed in SVN/3.0.10

Reported by: Lou Cipher Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I believe that either ever since I updated to the latest Virtual Box 3.0.6 r52128 and/or Snow Leopard, that my VM session regularly gets aborted for almost ANY reason on a DAILY basis and sometimes two or three times a day.

This is the most unstable version of VBox I have used since January 2009 unfortunately and wish I did not do the upgrade.

I am running Office 2007 (always have) along with Google Chrome and have 1.4GB of RAM allocated to the VM.

SOmetimes if I am scrolling in Outlook, or using Excel, or clicking a link in the browser the VM will just ABORT and I have to start it all over again.

Attachments

Windows XP (Aug 29, 2009)-2009-09-28-11-14-08.log Download (39.6 KB) - added by Lou Cipher 5 years ago.
VirtualBoxVM_2009-09-28-193823_localhost.crash Download (48.4 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs
VirtualBoxVM_2009-09-28-110828_localhost.crash Download (42.3 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 28 11:08AM)
VirtualBoxVM_2009-09-27-132701_localhost.crash Download (45.1 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 27)
VirtualBoxVM_2009-09-26-005309_localhost.crash Download (45.4 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 26)
VirtualBoxVM_2009-09-24-184641_localhost.crash Download (48.6 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 24)
VirtualBoxVM_2009-09-24-113321_localhost.crash Download (45.1 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 24 11:33AM)
VirtualBoxVM_2009-09-22-112403_localhost.crash Download (46.8 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 22)
VirtualBoxVM_2009-09-18-032431_localhost.crash Download (34.7 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 18)
VirtualBoxVM_2009-09-17-135914_localhost.crash Download (45.0 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 17)
VirtualBoxVM_2009-09-15-123643_localhost.crash Download (46.2 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 15)
spindump_symbolicator_2009-09-25-114418_localhost.crash Download (11.6 KB) - added by Lou Cipher 5 years ago.
SpinDump Symbolicator (Sep 25)
VirtualBox_2009-09-28-114139_localhost.crash Download (31.6 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 28 11:41AM)
Logic Pro_2009-09-17-162433_localhost.crash Download (62.8 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 17 4:24PM)
VirtualBoxVM_2009-09-29-223530_localhost.crash Download (43.7 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 29)
VirtualBoxVM_2009-09-29-234606_localhost.crash Download (55.1 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 29 again)
VirtualBoxVM_2009-09-30-132335_localhost.crash Download (45.6 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Sep 30)
VirtualBoxVM_2009-10-01-223112_localhost.crash Download (44.8 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 1)
VirtualBoxVM_2009-10-04-000027_localhost.crash Download (46.4 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 4)
VirtualBoxVM_2009-10-02-150348_localhost.crash Download (37.3 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 2)
VirtualBoxVM_2009-10-04-235902_localhost.crash Download (43.3 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 4 11:59PM)
VirtualBoxVM_2009-10-07-012452_localhost.crash Download (44.8 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 7 1:24AM)
VirtualBoxVM_2009-10-07-012531_localhost.crash Download (29.4 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 7 1:25AM)
VirtualBoxVM_2009-10-07-163542_localhost.crash Download (40.6 KB) - added by Lou Cipher 5 years ago.
CrashReporter Logs (Oct 7 4:34PM)

Change History

Changed 5 years ago by Lou Cipher

comment:1 Changed 5 years ago by frank

  • Summary changed from VBox on Mac OSX Snow Leopard regularly gets ABORTED to VBox on Mac OSX Snow Leopard regularly crashes

Any crash report available?

comment:2 Changed 5 years ago by Lou Cipher

Hi There,

I tried to email Frank back and it did not work so will add here.

Mac OS X never provides a crash report and simply the VM is aborted for some reason - so no crash report ever.

I did submit the VBox Log with this bug tracker - did you get that and is that what you need...?

comment:3 Changed 5 years ago by poetzsch

Hi,

can you have a look into ~/Library/Logs/CrashReporter/ or /Library/Logs/CrashReporter/. Search for files with VirtualBoxVM or VBoxSVC in the name. Also /var/log/system.log may contain some info about VirtualBox related problems.

comment:4 Changed 5 years ago by Hachiman

Hi, Are any  core dumps available?

Changed 5 years ago by Lou Cipher

CrashReporter Logs

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 28 11:08AM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 27)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 26)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 24)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 24 11:33AM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 22)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 18)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 17)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 15)

Changed 5 years ago by Lou Cipher

SpinDump Symbolicator (Sep 25)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 28 11:41AM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 17 4:24PM)

comment:5 Changed 5 years ago by Lou Cipher

Hi Guys,

OK - I added all the crash reports that were relevant and they started Sep 15, 2009.

There were two other crash reports from Aug 2 and Aug 11 however I do not think they were relevant to this problem.

I could add them if you want though...

I installed Snow Leopard the day it came out on August 28 and these crashes started on Sep 15 it appears from these logs.

However, I believe that 3.0.6 r52128 came out Sept 14 and my crashes started on the 15th so it seems there is a conflict with this code base and perhaps Snow Leopard as I am sure that the coding process was more focused on Mac OS X before Snow Leopard...I should have known better...

The good thing is that I can reboot the system at this point - it's just a real pain when you are working and then suddenly your Universe disappears in a flash on you - LOL! :)

If you guys need anything else at all please let me know and I will get it for you!

Lou

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 29)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 29 again)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Sep 30)

comment:6 Changed 5 years ago by poetzsch

This are all crashs on different locations which is strange. Some of them are related to out of memory situations. Can you please regular check if the VM process is using more & more RAM over the time. According to your config you have 1.5Gig assigned to the VM. In principle this should be ok, but try to reduce this a bit.

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 1)

comment:7 Changed 5 years ago by Lou Cipher

Hi Guys,

I checked the memory and it says 2.27GB as used for Real Memory and 2.24GB for virtual memory.

I have 1.5GB allocated to it so wondering if it is leaking memory or using more than it should like you suggest...? I have 10GB of RAM on this machine.

Also, it says the CPU % is at 101.4 which is strange...how would it be more than 100%???

I'm confused...

Lou

comment:8 Changed 5 years ago by Lou Cipher

Hey Guys,

During my last crash I got this message from Microsoft since I am running Windows XP in the VM:

Consider BIOS upgrade Microsoft is unable to determine the exact cause of this error. However, this problem was most likely caused by an error in your computer’s random access memory (RAM). RAM is the main internal storage area the computer uses to run programs and store data.

During the crash analysis, we noticed the basic input/output system (BIOS) version on this computer does not match the specifications for the central processing unit (CPU), also known as a processor, that is installed on your computer. This can occur when a newer processor is installed on an older system board or older BIOS. Using a BIOS that does not support the installed processor can result in Windows system crashes. Contact your computer manufacturer or motherboard manufacturer for an updated version of BIOS for your computer's processor.

So, thought you guys may want to consider that and the conflict with VBox and Snow Leopard...

Lou

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 4)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 2)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 4 11:59PM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 7 1:24AM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 7 1:25AM)

Changed 5 years ago by Lou Cipher

CrashReporter Logs (Oct 7 4:34PM)

comment:9 Changed 5 years ago by Lou Cipher

Hey Guys,

I upgrade to the new VBox thinking some problems would be resolved and I got three crashes within 1 day so far.

I am now using 3.0.8 r53138

If you need anything at all please let me know and I am happy to help.

Lou

comment:10 Changed 5 years ago by Lou Cipher

Hey Guys,

You know I do notice memory leaks with VBox.

The session started at 1.67GB real memory and I looked now and it is at 2.12GB...

OK - 30 minutes later and now it is at 2.49GB so seems to be leaking as you thought...right...?

Lou

comment:11 Changed 5 years ago by sandervl73

  • Priority changed from major to blocker

Tickets marked as duplicate: #5214, #4970, #5168.

comment:12 Changed 5 years ago by constantin

Hi,

first of all, many thanks to the VirtualBox team for taking this issue so seriously and elevating it to blocker status. As someone who likes to work withing VBox for whole work days, I really appreciate that :).

As the author of #1568 which was closed as a duplicate of this, here are some additional data points:

  • I too see the same kind of crashes as described above, with OpenSolaris as guest.
  • Upgraded from Mac OS X 10.6.0 to 10.6.1 and still see the same issues.
  • Crash probability seems to be related to activity: The more intensive work I do with the guest, the earlier the crash comes. As an example, boot OpenSolaris, start OpenOffice, work on a presentation by importing many new pictures into a slide etc. and it is very likely to crash within half an hour.

Hope this helps.

Cheers,

Constantin

comment:13 Changed 5 years ago by sandervl73

We're currently investigating the issue and will report back asap (might take a few days though).

comment:14 Changed 5 years ago by sandervl73

  • Summary changed from VBox on Mac OSX Snow Leopard regularly crashes to VBox on Mac OSX Snow Leopard regularly crashes -> fixed in SVN/3.0.10

We've located and fixed the problem. The next maintenance release will contain the fix. (due out soon)

comment:15 Changed 5 years ago by constantin

Thanks, this is great news!

Looking forward to 3.0.10. Meanwhile, I'm on 2.4.4. with 3.0.8 guest additions and it seems to work. Crossing my fingers that it will hold out just a while longer 'til 3.0.10 :).

comment:16 Changed 5 years ago by Lou Cipher

The VBox team ROCKS!

I'm very happy I took the time to report this bug as you guys were all over it very professionally and attacked the problem quickly!!

WOOO HOOO!!!

I have been preaching VirtualBox to everyone I know and will continue to do so!

Thanks again guys and looking forward to installing the update!

Lou

comment:17 Changed 5 years ago by constantin

I just finished a whole working day on OpenSolaris on VirtualBox 2.2.4 with the 3.0.8 guest additions (which worked better with OpenSolaris than the 2.2.4 ones) on Mac OS X 10.6.1 and it all worked fine.

To Lou and the others: This looks like a good workaround until we get to 3.0.10.

Thanks again to the awesome VBox team and have a nice weekend,

Constantin

comment:18 follow-up: ↓ 27 Changed 4 years ago by sandervl73

Let me know if you want to try a test build and I'll mail you the link.

comment:19 Changed 4 years ago by kgreenway

I am experiencing this issue as well.

I'm using XP, VB 3.0.8, and OSX 10.6.1 in a production role as a UNIX sys admin. This really ONLY interferes with my use of Outlook and Visio, but the regular interruptions are annoying at best. If I don't keep an eye on memory and make a preemptive strike (as has happened a time or two) I can loose data.

Under the circumstances, I would be more than happy to run a test build and possibly get involved more directly with the VB community.

Thanks for all the quick work on this.

  • Kyle

comment:20 Changed 4 years ago by constantin

Yes, I'd love to try out a test build. Thanks!

comment:21 Changed 4 years ago by Lou Cipher

Hi - sure, I'll try a test build!

I'll definitely back up my virtual drive first too :)

Lou

comment:22 Changed 4 years ago by kgreenway

Thanks a million Sander.

I installed and so far so good. The memory leak seems to be plugged and I have noticed no further issues at this time.

comment:23 Changed 4 years ago by constantin

Installed the 3.0.9 prerelease and it seems stable. Thanks a lot!

I saw some drawing glitches (black boxes when windows refreshed, black screen after switching StarOffice to fullscreen mode) but they seemed to go away after installing the 3.0.9 guest additions and rebooting.

So far, everything seems good. Thanks!

Cheers,

Constantin

comment:24 Changed 4 years ago by Lou Cipher

This has been running VERY well since I installed it - thank you!!!

I also had the drawing problems and then installed the guest additions update and that seems to have helped.

So, it took about a month to fix the problem and that was very decent timing considering the error was a MEDIUM issue.

Great work guys - I love the Virtual Box team!!

Lou

comment:25 Changed 4 years ago by swarwick

Hi - I'm also having the same problem. It's getting extremely frustrating. Would it be possible for me to get test build as well?

Thanks,

Steve

comment:26 Changed 4 years ago by Lou Cipher

Hey Everyone,

The only thing I notice is that I am unable to copy text from the host (i.e. Snow Leopard) to the Guest (Windows XP).

It works the other way however.

I did check my settings and even reset them and bidirectional copy and paste is turned on so unsure why this is happening - anyone else having this problem...?

Lou

comment:27 in reply to: ↑ 18 Changed 4 years ago by rmuetze

Replying to sandervl73:

Let me know if you want to try a test build and I'll mail you the link.

Sorry, to just send a "me too", but I'd love to test the next build as well. I'm using 3.0.8 on OS X and experience the same problem with a XP guest. Thanks a lot! Love VBox, that's another "me too" ;o)

comment:28 Changed 4 years ago by rkarise

I have noticed the same behavior with Snow Leopard and virtualbox 3.0.6r52128. Memory will continue to be consumed until the vm aborts. I currently monitor the memory and proactively reset it when memory runs out but would love to try a test build of 3.0.9 or 3.0.10 if that is available. Thanks!

comment:29 Changed 4 years ago by jesspepper

I have quite frequent crashes of the 3.0.8 VM with snow leopard. I would also like to try a new test build.

comment:30 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Better: Check the 3.0.10 release :=)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use