VirtualBox

Ticket #5146 (new defect)

Opened 5 years ago

Last modified 5 years ago

Aborted if USB device attached during shutdown or saving state

Reported by: john.doe Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.8 Keywords: Aborted machine state USB shutdown save MacOS WindowsXP
Cc: Guest type: Windows
Host type: Mac OS X

Description

When attempting to shut down the virtual machine (from inside the guest or by clicking "Send the Shutdown signal"), or when performing "Save the machine state", the machine status becomes Aborted. I will attach logs, one of the Aborted result during "Send shutdown signal" and one from "Save machine state".

Similar symptoms were listed in #5042 and #4020, however these appear to be fixed since VirtualBox 3.0.8 (fixed as in now the machine saves state properly if no USB device is connected, where as in those tickets the problem occurred regardless of whether a USB device was present or ever attached). Many thanks again to anyone that worked on the fix so this at least it now saves state without USB devices attached.

I have only confirmed this bug with MacOS 10.5.8 host and Windows XP SP3 guest, but forum posts suggest it may occur in other situations, hopefully someone else will post a log also.

Attachments

Windows XP (virtual disk)-2009-10-06-19-20-40.log Download (63.5 KB) - added by john.doe 5 years ago.
Windows XP (virtual disk)-2009-10-06-19-22-14.log Download (63.7 KB) - added by john.doe 5 years ago.
VBox.log Download (55.1 KB) - added by ChipMcK 5 years ago.
Log from XP Guest, v308 USB Aborted - Crash Report to be attached
VirtualBoxVM_2009-10-07-112535_localhost.crash Download (31.1 KB) - added by ChipMcK 5 years ago.
Crash Report> XP Guest, v308 USB Aborted; Log already attached

Change History

Changed 5 years ago by john.doe

Changed 5 years ago by john.doe

Changed 5 years ago by ChipMcK

Log from XP Guest, v308 USB Aborted - Crash Report to be attached

Changed 5 years ago by ChipMcK

Crash Report> XP Guest, v308 USB Aborted; Log already attached

comment:1 Changed 5 years ago by schivmeister

Is this not a regression?

I can confirm, albeit without proper version citation, that saving states used to work seamlessly regardless of whatever hardware/software was involved with the operating system. This is approximately the behaviour from at least 12 months ago; I could save the state while booting, while downloading, and even when installing software!

All that used to happen fast, and now even "powering off" the machine takes a short while when before it was instantaneous.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use