VirtualBox

Ticket #5085 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Ubuntu 9.04 GUEST looses network connectivity on a Windows XP HOST after changing the HOST network connection (ETH->WLAN/3G)

Reported by: mawadre Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

My VirtualBox 3.0.6 r52128 (german) is installed on a Toshiba A600 Laptop with Windows XP SP3. The computer has ethernet, WIFI/WLAN and 3G network connectors. The installed Ubuntu 9.04 Desktop guest runs fine with full network connectivity via NAT through the host's connection. But when I change the connection type on the host (e.g. ethernet -> WIFI or 3G -> ethernet) then the Ubuntu 9.04 guest looses its network connectivity. I did run wireshark on the hosts network device "SUN (Microsoft Packet Scheduler)" which apppears to be a NAT device or something else installed by VirtualBox. The only data I can see on this device after lost connectivity are lots of MDNS messages targeting 224.0.0.251 or NBNS messages targeting 224.0.0.255.

So it seams that some data is traveling from the guest Linux to the host VirtualBox network connector but nothing else.

Restart of any of the network connectors didn't change anything (Linux eth1, Windows ethernet, wlan, 3G, SUN (Microsoft Packet Scheduler)

Thanks for any help.

Change History

comment:1 Changed 5 years ago by Hachiman

Could you please attach Log files? Could you please send  pcap files to me [vasily _dot_ levchenko _at_ Sun _dot_ COM]

comment:2 Changed 4 years ago by drumbaby

Had a somewhat similar problem with a very similar setup: virtual box 3.0.8 on a Lonovo ThinkPad T50 with windows XP SP3. After WIFI -> etherner -> WIFI the guest Ubuntu 9.04 lost the DNS (but could still ping if given a numeric IP address). Restarts did not help. Upgrading to 3.0.10 did.

comment:3 Changed 4 years ago by tjd2002

The loss of DNS (but not network) on change of connection looks like a duplicate of 3847. Does restarting Vbox on the host fix the problem?

comment:4 Changed 4 years ago by drumbaby

Sorry I can't help with that - I almost stopped working in the location where I used both ethernet and wireless. So I haven't seen this problem in many months, but that doesn't mean much.

comment:5 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #3847

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use