VirtualBox

Ticket #5058 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows guest crashes on Linux host if VT-x/AMD-V enabled

Reported by: f.hoefling Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords: VT-x/AMD-V
Cc: Guest type: Windows
Host type: Linux

Description

Booting Windows XP Prof. (32 bit) in Virtualbox 3.0.6 with VT-x/AMD-V results in a crash of the virtual machine. The problem is solved by disabeling the VT-x/AMD-V option.

Booting and running memtest86 with the same configuration works without problems.

Host configuration: Ubuntu Linux (Jaunty, kernel 2.6.28), AMD PhenomII X4. Virtualization is enabled in the Bios.

Attachments

VBox.png Download (938 bytes) - added by f.hoefling 5 years ago.
Log file
VBox.log Download (114.4 KB) - added by f.hoefling 5 years ago.
Log file
VBox.log.1 Download (129.9 KB) - added by f.hoefling 5 years ago.
Log file for version 3.0.8 with VT-x/AMD-V enabled
VBox.2.log Download (43.7 KB) - added by f.hoefling 5 years ago.
Log file for version 3.0.8 with VT-x/AMD-V disabled
2009-10-23-20-16-03.060-VirtualBox-9999.log Download (267 bytes) - added by carlesgs 4 years ago.
Log "fatal error in recompiler cpu"
VBox6.log Download (115.7 KB) - added by carlesgs 4 years ago.
Full log in .virtualbox

Change History

Changed 5 years ago by f.hoefling

Log file

Changed 5 years ago by f.hoefling

Log file

comment:1 Changed 5 years ago by f.hoefling

the relevant error message might be this:

fatal error in recompiler cpu: triple fault

comment:2 Changed 5 years ago by sandervl73

  • Summary changed from Windows guest crashes on Linux host if VT-x/AMD-V enabled to Windows guest crashes on Linux host if VT-x/AMD-V enabled -> fixed in SVN/3.0.8

Right and I happened to be working on a similar bug. Fixed now.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Changed 5 years ago by f.hoefling

Log file for version 3.0.8 with VT-x/AMD-V enabled

comment:4 Changed 5 years ago by f.hoefling

  • Status changed from closed to reopened
  • Resolution fixed deleted

The bug persists in version 3.0.8.

I've updated to virtualbox-3.0_3.0.8-53138_Ubuntu_jaunty, enabled the VT-x/AMD-V option, and Windows still crashes.

comment:5 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 3.0.6 to VirtualBox 3.0.8

Which service pack level of Windows XP? Any unusual programs installed (virus scanners)?

comment:6 Changed 5 years ago by f.hoefling

Thanks for the quick reply. I'm running Windows XP Prof. SP3. The crash occurs during the boot procedure, presumably when Windows switches to graphics mode for the first time. (When the Windows logo appears.) Before, I can select the hardware configuration (text mode). I'm booting from a raw disk (AHCI) - not sure, whether this makes a difference.

My graphics card is nVidia GeForce 8500 GT. The VM has 48 MB graphics memory and 3D acceleration enabled.

For comparison, I have attached the log-file without the VT-x/AMD-V option.

Changed 5 years ago by f.hoefling

Log file for version 3.0.8 with VT-x/AMD-V disabled

comment:7 Changed 5 years ago by sandervl73

  • Summary changed from Windows guest crashes on Linux host if VT-x/AMD-V enabled -> fixed in SVN/3.0.8 to Windows guest crashes on Linux host if VT-x/AMD-V enabled

comment:8 Changed 5 years ago by sandervl73

Did you install SATA drivers in the VM?

comment:9 Changed 5 years ago by f.hoefling

The disks are running in SATA mode, and I've installed SATA drivers in the native boot configuration of Windows.

In the VM, I can't find that SATA drivers are installed. But there is an unconfigured PCI device: 0x2829 AHCI Controller 0x8086 Intel Corporation

comment:10 Changed 5 years ago by f.hoefling

I've updated the Virtualbox GuestAdditions, but nothing has changed.

I've installed the driver for the Intel AHCI controller, no change - it still crashes with virtualization enabled.

comment:11 Changed 5 years ago by carlesgs

Confirm the situation in Virtualbox 3.0.8 and earlier. If enabled VT-x/AMD-V on a disk with two installations, windows xp professional sp3 and Linux, when Windows starts we get the following error: fatal error in recompiler cpu: triple fault

If not enabled the VT-x/AMD-V, windows xp working properly. This error occurs both with a virtual IDE and SATA disk. I think the system can not access the NTFS partition of wind, and therefore, load the NT loader.

Excuse my poor English

Thanks

Changed 4 years ago by carlesgs

Log "fatal error in recompiler cpu"

Changed 4 years ago by carlesgs

Full log in .virtualbox

comment:12 follow-up: ↓ 13 Changed 4 years ago by kaatmanduu

I was experiencing the same issue, XP would crash with VT-x/AMD-V enabled, and boot without it. I installed the Intel SATA drivers from  http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17882&lang=eng, and I can boot with VT-x/AMD-V enabled. I now have a multi-processor enabled guest, very nice!

comment:13 in reply to: ↑ 12 Changed 4 years ago by f.hoefling

Replying to kaatmanduu:

I was experiencing the same issue, XP would crash with VT-x/AMD-V enabled, and boot without it. I installed the Intel SATA drivers from  http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17882&lang=eng, and I can boot with VT-x/AMD-V enabled. I now have a multi-processor enabled guest, very nice!

I just wanted to confirm that the Intel driver (version 8.9.0.1023) doesn't solve the problem for me - but big surprise! Now it works for me too, even with 2 processors enabled :-) But I don't know why.

I'd installed the Intel driver already two weeks ago, and it kept crashing. (See my previous post.) The only thing I've changed since is that Windows boots directly with its standard boot loader, not via Grub. (I'm using raw disk access with "virtual" MBR.)

comment:14 follow-up: ↓ 15 Changed 4 years ago by carlesgs

Replying to kaatmanduu:

From the Windows MBR bootloader starts correctly with VT-X enabled or not enabled. With GRUB starts well without VT-X enabled, with VT-X enabled does not start. Linux works always with or without VT-X from GRUB.

Greetings

comment:15 in reply to: ↑ 14 Changed 4 years ago by kaatmanduu

Replying to carlesgs:

From the Windows MBR bootloader starts correctly with VT-X enabled or not enabled. With GRUB starts well without VT-X enabled, with VT-X enabled does not start.

I'd changed to use the native Windows boot loader a few days before I installed the drivers. It never occurred to me that this might have an affect on a crash that late in the boot process. I booted using grub, and XP indeed crashes again when AMD-V is enabled.

comment:16 Changed 4 years ago by carlesgs

I confirm that this error occurs in the new version 3.0.10

comment:18 Changed 4 years ago by carlesgs

This error occurs in grub, grub2 and lilo, confirmed and tested

comment:19 Changed 4 years ago by carlesgs

Even if the computer does not have a processor with hardware virtualization, grub can not boot windows xp with enabled VT-x extension. If this extension is not enabled, it starts correctly.

Curious ...

comment:20 Changed 4 years ago by schabi

I can also reproduce that problem here in 3.10 - it also happened with the 3.0.6 OSE edition coming with debian. I can assist in debugging (provide logfiles, doing diagnostics etc.) if wanted.

As non-virtualized booting is unconsiderably slow, I'll try to find out infos about the direct boot (virtual mbr) mentioned here.

comment:21 Changed 4 years ago by carlesgs

The error also occurs in version 3.1.0 beta

comment:22 Changed 4 years ago by carlesgs

Solution "temporary" to the malfunctioning of grub and VT-X

Situation: 1 disk virtualbox ide or sata, with 2 operating systems installed: Windows and Linux. Grub, Grub 2 and Lilo not function properly if you enable VT-X on the virtual machine, Windows does not start with VT-x enabled.

Solution: Modify boot.ini in windows to start linux. I used Wingrub ( http://sourceforge.net/projects/grub4dos/files/) to create the grub file to use boot.ini . Wingrub has a graphical interface, and options are virtually identical to the grub menu.lst file in linux, indicate: kernel, partition and initrd. Finally, modify boot.ini to start linux, example:

[boot loader] timeout=-1 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows" /noexecute=optin /fastdetect C:\GRLDR="my linux"

Note: The binary file created with wingrub must be located in c: , and is called by the entry GRLDR in boot.ini .

Excuse my English

comment:23 Changed 4 years ago by carlesgs

Sorry, boot.ini has to be well

[boot loader] timeout=-1 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows" /noexecute=optin /fastdetect
C:\GRLDR="my linux" <---new line

comment:24 Changed 4 years ago by schabi

It still happens with 3.1.0-55467_Debian_lenny

comment:25 Changed 4 years ago by frank

Well, if the VM crashes (unexpected process termination), then please try to generate a  core dump and contact me via frank _dot_ mehnert _at_ sun _dot_ com, then I can provide you a server for uploading the file.

comment:26 Changed 4 years ago by frank

schabi, thanks for the core dump. Actually this was a guru mediation and therefore no real process crash (segfault or something like that). Therefore the core dump is not helpful in that case, sorry. Just another (unsolved) fatal error in recompiler cpu: triple fault problem ...

comment:27 Changed 4 years ago by schabi

Anything I can do do help debugging?

comment:28 Changed 4 years ago by sandervl73

#6017 has been marked as a duplicate.

comment:29 Changed 4 years ago by sandervl73

Still unable to reproduce. Windows XP SP3 with SMP enabled boots fine here. The instruction that causes the problem in the attached logs is executed properly here.

Access to a disk image that always causes the guru meditation might be helpful.

comment:30 Changed 4 years ago by schabi

In my case, it is not a disk image, but a native partition which is booted. I don't know whether I'm in the position to provide you with that native partition, as it contains some copyrighted and some private contents.

I tried to create a dual-boot scenario (booting the same windows installation both natively and in VirtualBox), and while I know that this is not officially supported, a guru meditation is not what I expect :-)

comment:31 follow-up: ↓ 33 Changed 4 years ago by schabi

Maybe one relevant fact is that my Host is a 64 bit lenny version from download.virtualbox.org on a debian testing system on a Intel(R) Core(TM)2 Duo CPU, while the guest is 32 bit.

There is no download version for debian testing, and the one for unstable is broken.

If I can do anything help you tracing down the problem, please tell me. A packed dump of my windows partition is about 25 gig, but as it might be that the bootloader is also part of the problem, and I don't know whether I'm allowed to give you the windows partition (it contains copyright protected software), I don't know whether that will suffice. But I also could run some debug version of virtualbox, or create some trace files, etc...

comment:32 follow-up: ↓ 34 Changed 4 years ago by sandervl73

schabi: 25 GB is rather large and then there's the matter of privacy and copyright, so that's not really an option.

Could you also attach a log file of a session that crashed?

comment:33 in reply to: ↑ 31 ; follow-up: ↓ 35 Changed 4 years ago by frank

Replying to schabi:

There is no download version for debian testing, and the one for unstable is broken.

I'm sorry? There are packages for Etch and Lenny, both should work. For Debian/testing and Debian/unstable use the corresponding Lenny package of course.

comment:34 in reply to: ↑ 32 Changed 4 years ago by schabi

Hi,

Replying to sandervl73:

schabi: 25 GB is rather large and then there's the matter of privacy and copyright, so that's not really an option.

Could you also attach a log file of a session that crashed?

I was in contact with Frank, and uploaded all the log files he wanted. His Conclusion was that it was no crash, but a Guru Meditation - which reminds me of my good, old Amiga times long ago, but seemingly does not help.

comment:35 in reply to: ↑ 33 Changed 4 years ago by schabi

Replying to frank:

Replying to schabi:

There is no download version for debian testing, and the one for unstable is broken.

I'm sorry? There are packages for Etch and Lenny, both should work. For Debian/testing and Debian/unstable use the corresponding Lenny package of course.

Sorry, I meant that the download for unstable does not work (at least not with debian testing from today): sarge (aka unstable) as mentioned on  http://www.virtualbox.org/wiki/Linux_Downloads gives the following error: W: Failed to fetch  http://download.virtualbox.org/virtualbox/debian/dists/sarge/Release Unable to find expected entry non-free/binary-amd64/Packages in Meta-index file (malformed Release file?)

E: Some index files failed to download, they have been ignored, or old ones used instead.

The lenny one is the one I use: 3.1.2-56127_Debian_lenny. Debian testing is squeeze which is not available as a repository. And I thought that running a lenny version on squeeze might be the reason for the bug.

comment:36 Changed 4 years ago by frank

schabi, Debian/unstable is sid not sarge. And no, running lenny on squeeze or sid should be fine.

comment:37 Changed 4 years ago by frank

Oh, and sarge is Debian 3.1 so outdated.

comment:38 Changed 4 years ago by schabi

Yes, you're right, sorry. But you might consider removing the sarge link from your download page then.

comment:39 Changed 4 years ago by frank

Could you check if VBox 3.1.6 changes anything?

comment:40 Changed 4 years ago by schabi

I just tried, and it worked - I booted into the login screen, and after login the activation message came, no Guru mediation any more.

I cannot guarantee that there were no other relevant changes (GRUB updates or windows updates) in the meantime, but the problem is fixed for me.

Thanks!

comment:41 Changed 4 years ago by Technologov

should be CLOSED as FIXED

-Technologov

comment:42 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use