VirtualBox

Ticket #4962 (reopened defect)

Opened 5 years ago

Last modified 4 years ago

Crash of OpenGL extension Viewer on run => Fixed in SVN/3.1.6

Reported by: koppermind@… Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I setuped OpenGL Extension Viewer v.3.0 to test the opengl 3d acceleration possibilities of my vm. Guest Windows XP 3d enabled. OpenGL mostly works Host: linux amd64 , VirtualBox 3.0.6 with guest additions

I get the following exception in running OpenGL Viewer:

See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.

Exception Text System.ArgumentOutOfRangeException: Index and length must refer to a location within the string. Parameter name: length

at System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy) at openglex.oevMain.GetForcewareVersion(String szDriverVersion) at openglex.oevMain.SetRenderer(Assembly m_Assembly, Int32 renderer, Boolean bFast) at openglex.oevMain.OnFormLoad(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Windows.Forms.Form.OnLoad(EventArgs e) at System.Windows.Forms.Form.OnCreateControl() at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible) at System.Windows.Forms.Control.CreateControl() at System.Windows.Forms.Control.WmShowWindow(Message& m) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ScrollableControl.WndProc(Message& m) at System.Windows.Forms.ContainerControl.WndProc(Message& m) at System.Windows.Forms.Form.WmShowWindow(Message& m) at System.Windows.Forms.Form.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Loaded Assemblies mscorlib

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll


openglex

Assembly Version: 21.0.0.0 Win32 Version: 3.12 CodeBase:  file:///C:/Program%20Files/realtech%20VR/OpenGL%20Extensions%20Viewer%203.0/openglex.exe


System.Windows.Forms

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


System

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Drawing

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


Accessibility

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll


System.Configuration

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


System.Xml

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll


System.Deployment

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll


System.Management

Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase:  file:///C:/WINDOWS/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll


JIT Debugging To enable just-in-time (JIT) debugging, the .config file for this application or computer (machine.config) must have the jitDebugging value set in the system.windows.forms section. The application must also be compiled with debugging enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception will be sent to the JIT debugger registered on the computer rather than be handled by this dialog box.

Attachments

WinXP Full 3D-2009-11-14-21-09-41.log Download (55.7 KB) - added by Technologov 4 years ago.
GL Extension Viewer Crash on XP VM. (Technologov)
VBox.log.2 Download (64.6 KB) - added by BertN45 4 years ago.
Guest Ubunt 10.4
VBox.log.3 Download (54.7 KB) - added by BertN45 4 years ago.
Guest Windows XP

Change History

comment:1 Changed 4 years ago by Technologov

Added myself as CC.

-Technologov

comment:2 Changed 4 years ago by Technologov

This is similar to bug #2797

Problem still exists. Both GL Extensions Viewver v2.0 and v3.0 crash soon after test started.

Host: Windows Vista, 32-bit, GeForce 9700M GTS, Core 2 P8600. VBox 3.0.10

Guest: Windows XP

-Technologov

Changed 4 years ago by Technologov

GL Extension Viewer Crash on XP VM. (Technologov)

comment:3 Changed 4 years ago by Technologov

NOTE: VM stays alive. (after both GL Extensions Viewer v2 and v3)

comment:4 Changed 4 years ago by leonid

Rather strange bug which happens on NVidia cards only. OpenGLEV is trying to get nvidia drivers information...but ofc it's not present on the guest.

comment:5 Changed 4 years ago by Technologov

This is why I don't recommend calling the virtual card in guest as "NVIDIA".

I have other physical cards at home too... ATI, Intel and even... 3Dfx !

Better to use neutral name such as "VirtualBox Direct3D Accelerator".

-Technologov

comment:6 Changed 4 years ago by leonid

Well, the reason you see NVIDIA is because OpenGLEV is using both DirectX and OpenGL APIs at the time it queries card information.

And after some discussion with wine folks we've agreed that wine really want to know host card name and driver version to apply some quirks if necessary.

In fact the easy workaround would be to disable that for this applicaton, but I'm still thinking about a different solution.

comment:7 Changed 4 years ago by Technologov

How about "VirtualBox 3D Accelerator" -- both for OpenGL and Direct3D ?

comment:8 Changed 4 years ago by leonid

Wine is checking card name and drivers version to workaroung certain GPU bugs...

comment:9 Changed 4 years ago by frank

  • Summary changed from Crash of OpenGL extension Viewer on run to Crash of OpenGL extension Viewer on run => Fixed in SVN/3.1.6

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Changed 4 years ago by BertN45

Guest Ubunt 10.4

Changed 4 years ago by BertN45

Guest Windows XP

comment:11 Changed 4 years ago by BertN45

  • Status changed from closed to reopened
  • Resolution fixed deleted

See log file attachment for two different guest OSes (XP and Ubuntu): Virtualbox crashes the host as soon as I enable the AMD-V setting for the Virtualbox guest on my Dell Inspiron 1521 notebook. The crash/dump is started in OpenGL. It even crashes/freezes during the install of a new VM. It works fine without the AMD-V settings. I have checked the BIOS, it is the latest version A06 and it has AMD-V enabled. One of the machines has 3D acceleration enabled and the other disabled and that does not make a difference. I upgraded to 10.4 because I had the same type of problem with Ubuntu 9.10, only there it froze more often and 10.4 more often reboots the host. Full screen mode crashes faster than when I start it in a window. XP once reached the log-in screen and froze there, I had to push the power button for 4 seconds to get out, I did notice that the V icon was active in the corner of the window around XP. Shared paging has no or only minimal effect. I have tried to find a solution for 2 days on the internet, but did not find anything useful. I have used the hardware with Vista, Windows 7 RC, older version of Ubuntu and MS Virtual PC 2007 without any problems, so I do not think it is a hardware problem. I am new to Ubuntu and Virtualbox, 4 weeks now, but if you need more information I will try to get it. I am not new to OS design/debugging, there I have some 15 years of dated experience (1975-1990). That why I think it might be a bug caused by an error related to the concurrency, that shows up in my specific configuration. The difference in moment of occurrence and behaviour (in window/full screen and freeze or crash) might also be explained by timing issues.

comment:12 Changed 4 years ago by BertN45

I realised that I attached the wrong logs, since I noticed that: SVM - AMD VM Extensions = 0 (1), so the logs are created when I turned off SVM. At least you have detailed information about my configurations now. Your CFGM dump confused me, because I thought that is the place where the error occurred.

I have deleted all the logs and tried again, XP froze in the first Windows screen. The log file was empty and I had to power off the machine. The guest was running in a window, with the guest in full screen mode the host rebooted. Ubuntu shows the same behaviour, it show two different sizes black screens and freezes on the last one, I see the V icon enabled and a cursor on the screen in the left top corner. In full screen mode it reboots too. I try XP with SVM enabled in a window:

  • it showed the XP login screen for a second or 2 and rebooted.
  • it froze in the first XP screen.
  • it rebooted directly
  • it showed a 2/3 black and 1/3 white window and froze and I cannot see the icons in the lower right corner, that is white too.

comment:13 Changed 4 years ago by Technologov

SVM - AMD VM Extensions = 0 (1)

does not means SVM is disabled, it simply means that it is not nested. VirtualBox does not support nested SVM. See Wish #4032

You need to search for "VT-x" string, like this:

HWACCM: VT-x/AMD-V init method: GLOBAL

-Technologov

comment:14 Changed 4 years ago by leonid

I don't understand how is this problem related to "Crash of OpenGL extension Viewer on run"? As you say host crashes while you install guest OS or before it's launched... and you also wrote that "The crash/dump is started in OpenGL". That's confusing.

comment:15 Changed 4 years ago by BertN45

Leonid you are right, like I said I got confused by the CFGM dump after OpenGL in the log. I am new to Linux.

comment:16 Changed 4 years ago by BertN45

Technologov. my interpretation was that SVM is present and enabled for the host, but that it is disabled for the guest. Which seemed to make sense since I did attach the wrong log in my naivety. In the run creating those logs AMD-V have been disabled for the guest, that is probably also why I cannot find anything about HWACCM or AMD-V in the attached virtualbox log file. The log with AMD-V enabled for the guest in Virtualbox were completely empty, apparently the system crashed or froze before it could log anything.

The bottom line is that independent of the guest OS the host rebooted or froze before anything could be logged. Disabling AMD-V for the guests runs without any problem. I have used Ubuntu 9.10 and 10.4 (updated yesterday) as host. In full screen mode it rebooted directly after the SUN "BIOS" screen disappeared. With the guest in a window it sometimes reboots and sometimes freezes on different moments in the process. The "best result" is that it entered the XP log-in screen and froze or rebooted there after 2 seconds or so. The V-Icon in the right lower corner of the window is "on". I am using the SUN version 3.1.16 of Virtualbox with USB support and VM Guest additions 3.1.17, but I also used 3.1.16 thereof to no avail. The guest are Ubuntu 10.4 (a couple of days since the last update) and Windows XP Home SP3 completely up to date. Every OS is 32 bits, while the AMD Athlon X2 1.8 mHz TK55 is 64 bits with AMD-V enabled by Dell from the start (see also the attached log files).

I have created the VDIs on a Pentium 4, but that should not be a problem, also because it also occurs early during the install of a new OS in Virtualbox on the Dell Inspiron with the default settings (AMD-V enabled) for the guest.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use