VirtualBox

Ticket #4961 (new defect)

Opened 5 years ago

Last modified 5 years ago

Mouse wheel scrolling broken in Ubuntu 32 bit guest / Windows 7 host since 3.06

Reported by: carlill Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.6 Keywords: mouse wheel
Cc: Guest type: Linux
Host type: Windows

Description

Subject says it all really - since upgrading to 3.06 I can no longer use the mouse wheel to scroll in an Ubuntu guest.

Ceri

Attachments

VBox.log Download (44.0 KB) - added by carlill 5 years ago.
Log file

Change History

comment:1 Changed 5 years ago by michael

A few questions about this. Which version of Ubuntu is this? Have you tried it in other guests? Did you update the Guest Additions to the version supplied with 3.0.6, and if so, did this problem only appear then? Can you try with a freshly installed guest, or the Ubuntu live CD to see if they are also affected? (In fact, the mouse wheel should work whether or not the Guest Additions are installed). And just in case it contains useful information, could you attach a log file from the guest?

Changed 5 years ago by carlill

Log file

comment:2 Changed 5 years ago by carlill

Hi,

Here are some answers:

  1. Ubuntu 9.04 32 bit, all updates done
  2. Yes - works in Windows 7 64 bit guest
  3. Yes I did update guest additions, and it was broken before and after the update
  4. Just tried Ubuntu Live CD and scroll wheel works!
  5. THIS IS ODD - have just run the test with a different setup (docked at work with a wired mouse) and mouse scrolling works fine in Ubuntu

So... this appears to be a bug connected to a specific Windows 7 mouse driver on the host, rather than Virtualbox itself.

Does this help?

I attach a log in any case.

Thanks for your help.

Ceri

comment:3 Changed 5 years ago by carlill

Hi,

Further update.

I am now testing again on the setup that caused the problem in the first place (Microsoft Wireless Laser Mouse 6000) and have found the following:

  • Scrolling DOES work, but only just. It seems as though many scroll events get lost so scrolling only happens in the guest if you REALLY persist.

Does this help?

It is definitely new behaviour in 3.0.6 and I have used all releases of VirtualBox back to 1.5.x.

Ceri

comment:4 Changed 5 years ago by michael

Could the mouse driver you are using have got updated? I have heard of similar issues the the Microsoft IntelliPoint driver which could be made to go away by adjusting the driver settings using the application which comes with the driver.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use