VirtualBox

Ticket #4942 (reopened defect)

Opened 5 years ago

Last modified 11 months ago

Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6

Reported by: umbra5885 Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

My Virtual Box was working Fine yesterday and for months before today (even the upgrade to Snow Leopard didn't effect VB) however when upgrading to 3.0.6 I found that when I have my XP Guest on my second monitor (whether full screen or not) if I move focus from that screen back to my first monitor, the XP Guest screen goes black. When returning to the Guest, everything is still black and the only fix is to either get out and back into full screen (push HOST F twice) or highlight the whole screen and click around a lot.

Attachments

VBox.log Download (52.5 KB) - added by poolam02 5 years ago.
virtualbox log file for ticket #4942

Change History

comment:1 Changed 5 years ago by webjunk

comment:2 Changed 5 years ago by mikearthur

I can also reproduce this bug.

comment:3 Changed 5 years ago by aquarius

me too ... it's a pity this bug made it into 3.0.6 cause dual screen is almost a "must" with virtualisation. I would volunteer to test more thorougly if there was a supported way of testing the beta and still keeping the old version.

comment:4 Changed 5 years ago by darkblue_b

yes, I as well... VBox 3.0.6 r52128 -- Mac OS 10.6 HOST

Model Name: MacBook Pro Model Identifier: MacBookPro5,1 Processor Name: Intel Core 2 Duo Processor Speed: 2.4 GHz Boot ROM Version: MBP51.0074.B00

-- Ubuntu 8.10 virtual machine

Changed 5 years ago by poolam02

virtualbox log file for ticket #4942

comment:5 Changed 5 years ago by poolam02

I also have the same bug. Vbox 3.0.6. Host - OS X 10.6.1. Guest - Win XP SP3.

comment:6 Changed 5 years ago by gwynevans

Just to make sure it's clear, the issue appears when the Guest is displaying on the secondary monitor (where the presence of the menu bar/dock defines the primary monitor), rather than it being an internal/external monitor issue.

comment:7 follow-up: ↓ 8 Changed 5 years ago by drewformica

Just wanted to add another point of reference. I am (along with 2 other co-workers) experiencing the same issue since upgrading to Snow Leopard. I tried making my external monitor the primary screen (OS X menu bar across top) but I still have the same "black screen" issue in VirtualBox when interacting with an OS X application.

So making the external monitor the primary does not seem to be a work around for our office. Here are my details should they matter:

  • Virtual Box Version 3.0.6 r52128
  • Guest OS: Windows XP SP3
  • Host System MacBookPro5,5 Intel Core 2 Duo 2.53 GHz 4 GB RAM running Snow Leopard
  • External Monitor Dell 2007WFP Mini Display Port to DVI

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 5 years ago by gwynevans

Replying to drewformica:

Just wanted to add another point of reference. I am (along with 2 other co-workers) experiencing the same issue since upgrading to Snow Leopard. I tried making my external monitor the primary screen (OS X menu bar across top) but I still have the same "black screen" issue in VirtualBox when interacting with an OS X application.

Are you using seamless mode, as the "when interacting with an OS X application" suggests that your issue is a slightly different one as the one that I'm seeing doesn't need any interaction with any OS X app! (Maybe continue in the referenced thread?)

comment:9 in reply to: ↑ 8 Changed 5 years ago by drewformica

Replying to gwynevans:

Replying to drewformica:

Just wanted to add another point of reference. I am (along with 2 other co-workers) experiencing the same issue since upgrading to Snow Leopard. I tried making my external monitor the primary screen (OS X menu bar across top) but I still have the same "black screen" issue in VirtualBox when interacting with an OS X application.

Are you using seamless mode, as the "when interacting with an OS X application" suggests that your issue is a slightly different one as the one that I'm seeing doesn't need any interaction with any OS X app! (Maybe continue in the referenced thread?)

No I'm not using seamless mode. I am seeing the "weird" black screen on start up of VBox, but if I resize the VBox window sometimes I can get everything to display properly. I can then work inside the VBox Guest OS fine, but as soon as I leave the VBox window to go to my other screen to use OS X Firefox, for example, as soon as the Host Window gains focus, the VBox Window goes black. Does that help any?

comment:10 Changed 5 years ago by calum

Same issue here, with OpenSolaris guest on external monitor. Everything goes back to normal when I drag the guest window back onto my MacBook Pro's internal monitor.

comment:11 follow-up: ↓ 12 Changed 5 years ago by nasacct

Hi.

I am having the same issue: Snow Leopard, vbox 3.0.6, Win XP, running on secondary display with the refresh problem. However I tried changing the Display Profile of the 2nd monitor and I noticed that if I select a different color profile the display refreshes to a previous state and if the color profile is the same as the main display it seems to work (not a workaround but something worth studying).

comment:12 in reply to: ↑ 11 Changed 5 years ago by drewformica

Update - so yesterday I changed the primary display on my Mac to the external 20" and then restarted VBox and it didn't seem to help. However when I rebooted my Mac this morning, I still had the external monitor as the primary and I am happy to say that I have not experienced any VBox black screen issues today.

So in short, with the external monitor set as primary on OS X startup I have not had issues. So it seems to be a "secondary' display issue with VBox and not an external monitor issue as previously stated. Sorry for any confusion I may have caused.

thanks drew

comment:13 Changed 5 years ago by nasacct

I did some more test changing the color profile of the 2nd display. It seems to be related to the frame buffer associated to the color profile. When changing the profile to the 2nd monitor, several different displays are refreshed depending on what was refreshed on that profile. If the color profile matches the primary display (at least without changing the primary display settings) it seems to work ok.

comment:14 Changed 5 years ago by Gumpieza

I can confirm that this is also happening. Mac book Pro 17 ",Snow leopard. vbox 3.0.6, Win 7 RC1, running on a second monitor acer. The display works fine on the main laptop monitor but not on the secondary.

comment:15 Changed 5 years ago by avdezign

I have the same problem using an iMac 24" 2.66 GHz Intel Core 2 Duo and a secondary monitor (Viewsonic 19"), and I can confirm that using the same colour profile for both monitors resolves the problem for now. It's not perfect but I can switch profiles when I need to use XP and then switch back when I'm designing. Thanks for all here who managed to find a workaround.

comment:16 Changed 5 years ago by bewst

Me too, FWIW

comment:17 Changed 5 years ago by bewst

In fact, even with the workaround in place, if my Mac's monitor goes into power saving mode, the guest's video seems to be permanently hosed.

comment:18 follow-up: ↓ 19 Changed 5 years ago by dustinroberts

This is still occurring with virtual box 3.08. I am very surprised that this bug was not resolved with the new update. I am stuck using 3.04. This is a make or break functionality issue, and should be receiving a lot more priority then it is.

comment:19 in reply to: ↑ 18 Changed 5 years ago by calum

Replying to dustinroberts:

This is still occurring with virtual box 3.08. I am very surprised that this bug was not resolved with the new update. I am stuck using 3.04. This is a make or break functionality issue, and should be receiving a lot more priority then it is.

I guess it's not receiving much attention because there's a simple workaround for most people. There are far more important and longer-standing OS X bugs to be fixed than this one, which have no workaround (e.g. #2372, can't use bluetooth devices in guests)...

comment:20 Changed 5 years ago by gothick

Well I'm glad to know I'm not the only one with the problem. Took me ages to work out what was going on to the extent that I could search for the problem, though! I guess this is because I'm a photographer, so I need my monitor colours to match, so I have different profiles on each. The workaround of having the same profile is going to be a pain for me :(

comment:21 follow-up: ↓ 22 Changed 5 years ago by tmarkel

Secondary workaround:

Use the remote display function and RDC to the client in full screen mode on the monitor of choice. It's not the "seamless" experience, but at least the clipboard syncs.

HTH,

Tony

comment:22 in reply to: ↑ 21 Changed 4 years ago by hooverbw

I have tried all workarounds to changing which screen is primary and matching color profiles and nothing works. I am left with a completely unusable VM. I cannot even get a stable enough display in order to log into the computer.

Here is my setup:

iMac 24" Core 2 Duo 3.06Ghz, 4GB RAM Secondary display: Dell 19" LCD Host OS: 10.6.1 Snow Leopard Guest OS: Windows 7 Professional, fully released and activated version Primary display - Dell 19" LCD Secondary display (with VM as full-screen) - iMac 24"

comment:23 follow-up: ↓ 24 Changed 4 years ago by poetzsch

  • Summary changed from Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6 to Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6 -> fixed in SVN

The bug is fixed in svn and the fix will be included in the next minor release.

comment:24 in reply to: ↑ 23 Changed 4 years ago by slackbax

Replying to poetzsch:

The bug is fixed in svn and the fix will be included in the next minor release.

I downloaded the newly posed 3.0.8 virtual box and this is still happening. I am using Mac OSX 10.6.1 host with Windows XP Guest. I have a Dell external monitor and when I move the virtual box over to this monitor the virtual box goes completely black and is completely unusable. If you move this back over to the main mac monitor it does work.

When can we expect a good version to work on a secondary monitor? Many thanks,

comment:25 Changed 4 years ago by frank

  • Summary changed from Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6 -> fixed in SVN to Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6 -> fixed in SVN / 3.0.10

The next release is actually 3.0.10, the current release is 3.0.8. Some more days patience please. Thank you!

comment:26 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:27 Changed 4 years ago by ukchucktown

  • Status changed from closed to reopened
  • Resolution fixed deleted

I don't think this problem is fixed in 3.0.10. I can reproduce it with the latest VirtualBox on my secondary display regardless of the guest operating system. Let me know if you need additional information.

comment:28 Changed 4 years ago by ukchucktown

We are testing and tracking the problem in the forums...

 http://forums.virtualbox.org/viewtopic.php?f=8&t=24439

comment:29 Changed 4 years ago by knitd

I found a workaround that works for me perfectly (Host: OS X 10.6.2, Guest: Windows XP SP3):

Go to System Preferences -> Monitors -> Colors. You need to use the exact same profile on all monitors. I know that the wrong profile looks ugly - but that workaround works perfectly for me.

Here is another thread in the forums:  http://forums.virtualbox.org/viewtopic.php?f=8&t=22880

comment:30 Changed 4 years ago by krohrbaugh

Confirmed that this is still occurring in VirtualBox v3.2.6 r63112 on Mac OS X 10.6.4 with guest OSes of Windows XP, Vista and 7.

Issue occurs whether focus remains inside the VM or not with VM display rarely repainting correctly. Issue does not occur when using a single monitor. Issue does not occur when dual monitors are configured with the same color profile, although colors on one of the monitors is distorted when doing so.

comment:31 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.0.6 to VirtualBox 3.2.6
  • Summary changed from Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6 -> fixed in SVN / 3.0.10 to Black Screen for Windows XP Guess on Mac OS 10.6 host after upgrading to VB 3.0.6

comment:32 Changed 3 years ago by wglas

I observe this issue under VirtualBox-4.0.2 on my MacBook Pro with debian squeeze as my guest OS.

Can we expect any activity on this issue, should we provide more informations?

TIA, Wolfgang

comment:33 Changed 3 years ago by virtualberliner

The same on my MacBook Pro: Moving the vb-window from the external monitor to the MacBook-display results in black windows or bad/delayed updated windows.

Host: OS X 10.6.6 Guest: Windows 7 (with and without SP1) vbox-version: 4.0.2 and 4.0.4

On request I will send more detailed information.

comment:34 Changed 3 years ago by tokanizar

I think I have the same problem here with Snow Leopard 10.6.7 & VBox 4.0.4 and whatever the guest OS is (Debian, CentOS, Windows XP). The virtual machine windows are fine on my macbook screen but not on the external monitor (24" one). It goes black on the external screen, if I have the mouse dragged around the window, it might come back to normal but immediately could go black. Very annoying!

comment:35 Changed 3 years ago by csmith.mtb

I also have the same issue. I'm using Macbook Pro (2011), Mac OS X 10.6.7 & VBox 4.0.6 with Ubuntu guest OS. The guest window updates just fine on my LCD but not on my external monitor. I have updated the Color profiles to be same and that does seem to "fix" the refresh issue. Although, I would consider that to be a workaround, not a fix, as the colors on my external monitor are very dark.

comment:36 Changed 3 years ago by frank

Could you check if VBox 4.0.8 fixes your problems?

comment:37 Changed 3 years ago by csmith.mtb

VBox 4.0.8 seems to have fixed the issue. I switched the color profile back to the original version for the external monitor and I no long seem to have the issue.

comment:38 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

comment:39 Changed 3 years ago by naimdjon

  • Status changed from closed to reopened
  • Resolution fixed deleted

This has come back on the latest version of VirtualBox, v4.0.12 r72916. I am on OS X 10.6.8 and the guest is XP SP3.

comment:40 Changed 19 months ago by Vin

Good Morning, I'm new here and I hope I'm in the right section. I would ask you a courtesy. I've got a #4942 similar situation: after having updated to VB 4.2.0, the virtual machine (XP SP3) has problem with video output (blank screen) if I put it on the 2nd monitor (external). If I drag the window on my notebook screen, everything is OK. My system is a MacBookPro w/OS 10.6.8 and XP. The guest additions are the latest released. I have also reinstalled the 4.2.1 package starting windows in "safe mode". But no results. Everything works fine for years until few days ago. Thanks in advance for your cooperation.

Sorry for my poor English. Regards, vin

comment:41 Changed 18 months ago by ckristo

Same problem here with VirtualBox 4.0.2, Mac OS X 10.6.8 and dual monitor setup:

If I drag the virtual host window to the secondary monitor and the window looses focus, It get's black. When focusing the window again, some parts of the window come back, some parts not.

Tested and confirmed for all of my virtual hosts (Windows 7, Windows XP, CentOS 6, Ubuntu 12.04)

Best Regards,

comment:42 Changed 17 months ago by mchugha

Yesterday, November 28th 2012 I upgraded a large number of VirtualBox installations on Mac OSX Snow Leopard installations to VirtualBox 4.2.4 and this bug came back by surprise. Once I made the color profile for both monitors the same (iMac) VirtualBox behaved normally. The bug as described in all the previous comments showed up for me exactly that way. HTH, Thanks!

comment:43 Changed 16 months ago by Wizzball

I'm having the same issue with our Creative Services Directors MacBook Pro running Windows 7 on Virtualbox 4.2.4 under Snow Leopard. Changing the color profile of the external Cinema Display to match the Notebook screen color profile is not a viable option as we are a large publishing house and need to have accurate color representation on the Mac's.

Surely Oracle can fix this as it's been around for 3 years now??

comment:44 Changed 14 months ago by fdy

BUg confirmed here on host Mac OSX 10.6.8 (run in a macbook pro 6,2) and guest Lubuntu 12.10: when moved to secondary display (Mac Cinema 21") the refresh does not work properly as soon as the focus switch to primary display

comment:45 Changed 11 months ago by gkholman

The workaround above of matching colour profiles has just worked for me.

I am running a Mac OS X 10.6.8 host with an XP guest on an external screen. I've been running VirtualBox-4.1.18-78361-OSX for a long time because each and every version available since has had problems with the text in XP windows not appearing, and window refreshes not working, including the current VirtualBox-4.2.12-84980-OSX.

But thanks to this thread, now when I set the colour profiles to be the same, the XP window works fine. When I set them to be different, I get the multitude of problems.

Sadly, when setting the profiles to be the same the external monitor doesn't look nearly as nice as it did before. Fortunately, this won't impact on my work.

But perhaps it helps the developers to know that I had no problems with mismatched colour profiles in VirtualBox-4.1.18-78361-OSX.

comment:46 Changed 11 months ago by whatever1

Bug confirmed on 4.2.12 Mac OS X 10.6.8;

another work around I found is to switch to scaled mode (Host+C) in your guest OS.

HTH

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use