VirtualBox

Ticket #4853 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

ActiveState perl GetUNCName doesn't return Windows UNC path => Fixed in SVN/3.0.8

Reported by: paulg_ca Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

I have run into what I think is a bug, I am starting to use VirtualBox to test Windows XP deployments and the software we use is written in perl and it makes a call to Win32::NetResource::GetUNCName() which should return the UNC name when it is given a network drive letter. Unfortunately it fails within the VirtualBox hosted guest OS.

I tried with ActivePerl 5.8.9.826 and 5.10.0.1005 and I get the same results.

Here are the results.

Real Windows XP SP3 C:\>Z:\testunc2.pl Calling GetUNCName z: success $ret = \pcserver\homes

VirutalBox Windows XP SP3 C:\>Z:\testunc2.pl Calling GetUNCName z: $ret = Unable to GetUNCName for z:: The network name cannot be found at y:\testunc2.pl line 21.

I have attached a test perl script.

Products Involved VirtualBox 3.0.4 Host OS: OpenSolaris 2009.06 Guest OS: Windows XP SP3 Perl: ActiveState 5.8.9.826 and 5.10.0.1005 Deployment software: Unattended ( http://unattended.sourceforge.net/)

Attachments

testunc2.pl Download (511 bytes) - added by paulg_ca 5 years ago.
test perl script
VBox.log Download (54.0 KB) - added by paulg_ca 5 years ago.
VirtualBox log file

Change History

Changed 5 years ago by paulg_ca

test perl script

Changed 5 years ago by paulg_ca

VirtualBox log file

comment:1 Changed 5 years ago by paulg_ca

I am not sure if the problem is is with VB, ActivePerl, but here is the ActiveState bug id link
 http://bugs.activestate.com/show_bug.cgi?id=84368

comment:2 Changed 5 years ago by paulg_ca

An update from activestate.com :
Bug report moved to the Win32::NetResource ticket queue:
 http://rt.cpan.org/Ticket/Display.html?id=49081[[BR]]

I'll close the bug here; all further updates should take place on RT.
I suspect that this is an issue with VirtualBox that cannot be solved in the module.

comment:3 Changed 5 years ago by paulg_ca

I just test VB 3.0.6 and the problem is still there[[BR]] Anyone have any clue on how to work around this issue ?

comment:4 Changed 5 years ago by sunlover

  • Version changed from VirtualBox 3.0.4 to VirtualBox 3.0.6

This was a bug in VBox guest additions. Please try fixed additions:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r52183.iso

comment:5 Changed 5 years ago by paulg_ca

I tested VBoxGuestAdditions-r52183 and it worked! This is great news!, Thank You! I assume this will be officially fixed in 3.0.7.

comment:6 Changed 5 years ago by frank

  • Summary changed from ActiveState perl GetUNCName doesn't return Windows UNC path to ActiveState perl GetUNCName doesn't return Windows UNC path => Fixed in SVN/3.0.8

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use