VirtualBox

Ticket #4829 (closed defect: duplicate)

Opened 6 years ago

Last modified 12 months ago

High idle CPU usage with pulseaudio

Reported by: Stephan.Ritscher Owned by:
Priority: major Component: audio
Version: VirtualBox 3.0.4 Keywords: pulseaudio,cpu,idle
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Hi, I use VirtualBox 3.04 with pulseaudio 0.9.9 in a Gentoo linux (kernel 2.6.30-r4). When my Windows XP guest is running both pulseaudio and VirtualBox consume 1-5% of CPU (according to "top") even if the machine is paused and no sound is played. On a Core 2 Duo T9300 this seems rather much. As soon as I quit VirtualBox, also the activity of pulseaudio drops to negligible values. The behaviour seems reproducible, also after a restart.

Attachments

pulseaudio.log Download (473.9 KB) - added by pippijn 2 years ago.
strace output of pulseaudio

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant.

Changed 2 years ago by pippijn

strace output of pulseaudio

comment:2 Changed 2 years ago by pippijn

  • Status changed from closed to reopened
  • Resolution fixed deleted

This still happens with the latest package of VirtualBox 4.2.

comment:3 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Description modified (diff)

I think this is a duplicate of #11615. Please check if the provided test build fixes your problem.

comment:4 Changed 15 months ago by pippijn

It still happens with VirtualBox 4.3.8 r92456.

comment:5 Changed 12 months ago by pippijn

It does no longer happen with VirtualBox 4.3.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use