VirtualBox

Ticket #4830 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

CentOS 5.3 Auto-resize does not work

Reported by: Perryg Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Several people had stated that they could not get the auto-resize to work and I have confirmed that this evening. Guest additions do install without error and everything else works but the resize is non-functional. I am attaching the VBox log, Xorg.0.log as well as the vboxadd-install.log I appears that it is not Host OS specific.

Attachments

CentOS-5.3-2009-08-21-20-30-34.log Download (54.0 KB) - added by Perryg 5 years ago.
vboxadd-install.log Download (64.6 KB) - added by Perryg 5 years ago.
Xorg.0.log Download (18.4 KB) - added by Perryg 5 years ago.
vbox-install.log Download (2.2 KB) - added by tedc 5 years ago.
vbox-install.2.log Download (2.2 KB) - added by tedc 5 years ago.
vbox-install.3.log Download (2.2 KB) - added by tedc 5 years ago.
vbox-install.4.log Download (2.2 KB) - added by tedc 5 years ago.
Xorg.0.2.log Download (20.9 KB) - added by tedc 5 years ago.
vbox-install.5.log Download (2.2 KB) - added by tedc 5 years ago.
vboxadd-install.2.log Download (8.4 KB) - added by tedc 5 years ago.
xorg-conf.txt Download (791 bytes) - added by Perryg 5 years ago.
Perryg-xorg.conf file for CentOS 5.3

Change History

Changed 5 years ago by Perryg

Changed 5 years ago by Perryg

Changed 5 years ago by Perryg

comment:1 Changed 5 years ago by tedc

In addition to auto-resize not working, CentOS 5.3 guest cannot produce a desktop display larger than 1280x800 on a 1920x1080 monitor. Attempts to allocate areas larger than 1280x800 either revert to 1024x768, or result in a scrollable view of only part of a desktop of some larger size. When the virtual machine boots, the mouse pointer sometimes appears as two arrows, separated by a vertical displacement that is proportional to the vertical distance from the top of the virtual machine's desktop--that is, moving the mouse down drags both cursors down, but the separation between them widens, and moving the mouse up drags them both up and the separation between them narrows. This "double cursor" phenomenon occurs only after using system-config-display or editing xorg.config to specify a screen resolution larger than 1024x768.

I am attaching vbox-install.log from the host, and vboxadd-install.log and Xorg.0.log from the guest.

Changed 5 years ago by tedc

Changed 5 years ago by tedc

Changed 5 years ago by tedc

Changed 5 years ago by tedc

Changed 5 years ago by tedc

Changed 5 years ago by tedc

comment:2 Changed 5 years ago by tedc

Sorry about those duplicates but it wasn't clear that any of them had succeeded--I expected the user interface to tell me if an upload had actually occurred.

Changed 5 years ago by tedc

comment:3 Changed 5 years ago by michael

Auto-resize currently only works when you don't have any modes set in xorg.conf.

Changed 5 years ago by Perryg

Perryg-xorg.conf file for CentOS 5.3

comment:4 Changed 5 years ago by Perryg

@michael, Thanks but I already knew that and my xorg.conf does not have a mode entry in it. I have to add a manual entry to get it to work if I want larger than 800x600. AFAIK all other GA functions do in fact work. I believe that it has something to do with the kernel they are using now though (2.6.18-128.4.1.el5) Let me know what I can send. For now I will mode the config. to get the resolution I need.

comment:5 Changed 5 years ago by frank

Moment, do you really talk about the feature that the guest screen resolution can be resized using the mouse? This will not work for Xorg 7.1.1 because at least XRandR 1.2 is required (Xorg 7.1.1 comes with XRandR 1.1 AFAIR).

comment:6 Changed 5 years ago by Perryg

You may be correct Frank. I do remember getting the resize to work for a few in the previous version of CentOS, but the new version 5.3 is where I loose it. No indication of any errors, it simply will not resize. If this is the true problem I will post a mode entry for them to use.

comment:7 Changed 5 years ago by DaveLevy

I have today been experimenting with a Centos 5.3 on Mac OSx 10.5.8 build.

As with others, GA installs with out error. I have installed Mode lines in the xorg.conf file using the system-config-display. No auto-resize and I cannot get a screen size larger than 1152x864.

comment:8 Changed 5 years ago by frank

Again, CentOS 5.3 ships XRandR 1.1 but for auto-resizing, XRandR 1.2 is required.

comment:9 Changed 4 years ago by Technologov

There are plenty of other Linux guests with similar (old) Xorg versions. Of course, I would prefer to see them all work with resizing and seamless mode, but not sure if this is possible.

-Technologov

comment:10 Changed 4 years ago by michael

The problem is that those older X servers did not support adding new resolutions while they were running. So short of adding several hundred resolutions statically, and jumping to the closest supported resolution when the guest window is resized (which is not really a nice solution), I don't think this is possible.

comment:11 Changed 4 years ago by Technologov

Close this as duplicate of bug #5840

-Technologov

comment:12 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use