VirtualBox

Opened 15 years ago

Closed 14 years ago

#4761 closed defect (fixed)

Win XP Guest does not recognize connected virtual network cable

Reported by: user2304 Owned by:
Component: other Version: VirtualBox 3.0.4
Keywords: Cc:
Guest type: Windows Host type: other

Description

Hi,

using VBox 3.0.4 with Win XP Guest and Intel Pro/1000 T-Serveradapter with NAT:

There's no reaction of the guest system if i connect the virtual network cable via the checkbox, even disconnecting an connecting again - the guest doesn't recognize.

Regards, user 2304

Attachments (2)

nat_no_cable_connected.jpg (31.2 KB ) - added by user2304 15 years ago.
Screenshot with output of ipconfig /all in guest
VBox.log (60.7 KB ) - added by user2304 15 years ago.
Log of Session with "cable disconnected" but internet access available in virtual machine

Download all attachments as: .zip

Change History (12)

by user2304, 15 years ago

Attachment: nat_no_cable_connected.jpg added

Screenshot with output of ipconfig /all in guest

comment:1 by user2304, 15 years ago

Addendum:

If i restart the guest Windows XP, it connect's to the internet, although the virtual network cable is disconnected. Strange.

comment:2 by Frank Mehnert, 15 years ago

Guest type: otherWindows

Which host is that?

comment:3 by user2304, 15 years ago

Sorry, i submitted ticket before changing some infos:

Guest: Windows XP Home SP 3 Host: openSUSE 11.1 64bit

Regards, user2304

comment:4 by user2304, 15 years ago

Addendum 2:

Changed networkadapter to PCnet-FAST III (NAT) - now works as expected. The state of the virtual network cable (connected, disconnected) is recognized properly.

So maybe just a problem with the Intel-adapter.

For me, issue solved.

comment:5 by Frank Mehnert, 15 years ago

Are you 100% sure that you are using VBox 3.0.4? With E1000, this works here as well and we fixed such a problem for E1000 some releases ago.

comment:6 by user2304, 15 years ago

Totally sure (took a look some seconds ago to get "highest sureness").
Updated from 3.0.2 where the issue appeared too.

comment:7 by Sander van Leeuwen, 15 years ago

It would be useful if you attached the VBox.log of such a session.

by user2304, 15 years ago

Attachment: VBox.log added

Log of Session with "cable disconnected" but internet access available in virtual machine

comment:8 by Frank Mehnert, 14 years ago

We just fixed a bug where the cable was disconnected but the guest was still able to send/receive. But this doesn't sound like this fixed your original problem.

comment:9 by Technologov, 14 years ago

Please retry with 3.2.0, as this release had some network changes.

-Technologov

comment:10 by Frank Mehnert, 14 years ago

Resolution: fixed
Status: newclosed

No response, closing.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use