VirtualBox

Ticket #4743 (closed defect: duplicate)

Opened 5 years ago

Last modified 3 years ago

VirtualBox 3.04, guest OS Windows 2003, reboot always Blue Screen

Reported by: AntiMatter Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

VirtualBox 3.04 Host: Windows XP SP3 Guest: Windows 2003 x32, Guest Additions 3.04 installed

VM was working OK under VirtualBox 2.24. After upgrade to 3.04, the VM always blue screen on reboot, either a simple reboot (Start VM, log in, and Start Menu again and select Restart). Or a restart prompted by Windows after a system or software update. All Warm Reboots end up by a blue screen. The first line say "A problem has been detected and WIndows has shutdown to prevent dammage to your computer":  http://tinypic.com/view.php?pic=21n0aog&s=3

If the VM is powered off, no more blue screen, Windows can start normally and login is successful.

Change History

comment:1 Changed 5 years ago by Lelik

I can't reproduce such problem with reboot, but If I switch Hard Disk controller type from PIIX3 to PIIX4 (probably 4 to 3 also will fail). Can you check which controller was before? And please attach VBox.log when BSOD happened.

comment:2 Changed 5 years ago by mike.merrett@…

I have the exact same reproducible problem, which affects all my variety of Windows guest test platforms - all 32-bit - Windows XP SP3, Windows Vista SP1, Windows 7 RTM. All use SATA virtual disks, all use NAT. Host is Mandriva 2009.1 Linux, 6GB RAM, AMD Phenom 9600. Every warm boot results in a 0x00007B BSOD for the guest - whereas a cold restart of the guest allows a normal bootup. For performance reasons all the VMs have VT and nested paging turned on, plus PAE.

It did not occur at all under previous versions of VirtualBox.

comment:3 Changed 5 years ago by sandervl73

mike: that's a SATA regression in 3.0.4 (there's another ticket for this) and already fixed. 3.0.6 will include the bug fix.

comment:4 Changed 5 years ago by AntiMatter

Sorry for not following up earlier. Seems like a SATA issue indeed. In all my Guests, I use SATA (AHCI), Channel 0.

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Ok, I'll make this one as a duplicate then.

comment:6 Changed 3 years ago by morris

I just got the "A problem has been detected and windows has been shut down to prevent damage to your computer" problem trying to use "Vista SP1 x86 with IE8 2009-Apr.vhd" from  http://www.microsoft.com/downloads/en/details.aspx?FamilyID=21eabb90-958f-4b64-b5f1-73d0a413c8ef&displaylang=en (Internet Explorer Application Compatibility VPC Image from Microsoft download centre) on VBox 3.2.4

The vhd images was configured on the SATA controller.

When I changed the image to be on the IDE controller (PIIX4) it booted fine.

Just adding this note in case anyone else has the same problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use